summaryrefslogtreecommitdiff
path: root/dev-util/bloaty
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-util/bloaty
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-util/bloaty')
-rw-r--r--dev-util/bloaty/Manifest5
-rw-r--r--dev-util/bloaty/bloaty-1.1.ebuild45
-rw-r--r--dev-util/bloaty/bloaty-9999.ebuild43
-rw-r--r--dev-util/bloaty/metadata.xml15
4 files changed, 103 insertions, 5 deletions
diff --git a/dev-util/bloaty/Manifest b/dev-util/bloaty/Manifest
index edc308ce4c21..1ed0fee73295 100644
--- a/dev-util/bloaty/Manifest
+++ b/dev-util/bloaty/Manifest
@@ -1,3 +1,6 @@
DIST bloaty-0_p20170420.tar.gz 3100016 BLAKE2B 74a3b44a5e63f8f06da7b554588be0ced62a0f6792513984fbf7cfab520f6f6173868d588427dd9ca322c6fbc29fd1b8931453ec045c591fd8de58904178bf2c SHA512 93947fd0c49c3223c1ec216c88fe22b24e68654511d4b9d4fb2bcbc816b92bbdaf47344abc1dc8f80ed0b38a8c8b09909f862f916fd9182048235582aa10feb0
+DIST bloaty-1.1.tar.bz2 5363836 BLAKE2B a538cf5634ed72844bb128238a521caf375eaab34fd3cce8fdd46002bcbc6c53ba986cc7c1e4b761b1253b2f01cb557c94e1e1585507ff89bec10c891e5f5a88 SHA512 142d0dd58fc0aadce3aee6e9260c6ed792a18cf5fe260c89051d51b9357c7527ba352c3d6c9e23a3494796fba3d88314b6ed8a3a76c6c0d111d4c509cae6b216
EBUILD bloaty-0_p20170420.ebuild 771 BLAKE2B 4ae64b49ea5409c692772834a7e6cd3b602551535f043caae15edd13ffb0a914189dd3cd2c0f7273e7de2041ad06516a3cdf70dca7868606c81feeed0798f99b SHA512 bb7c2e8461920737f157df3dfeadb8e8bcce290c23c88862e5870b36ebd1f6a568779117302dae9446f9343ba667f264738e120a047ed023cbe81e4ec855cac8
-MISC metadata.xml 245 BLAKE2B bb69925f4ce8806c3ae58c2bff19a846fbde514f04037a61c8c7280d2639eca514c08ad611f4d8c6202c1dcc652d9f7f9662f9ef8cc69a286288cd234d8dd40c SHA512 1e3616356c21ccb0027e00a1cda28ca8a90b05a1f5ef89c11ffb44033365216ab541dafcbff7b728b5ab852a4db539cdf5db54865b69c4d9c250233d43e70702
+EBUILD bloaty-1.1.ebuild 863 BLAKE2B c51884ed15178ef9a76090bb55ac298cb79a05e6cf884a48a40c666b8b62e252d62aad7bfe9047bda56c1daf67ab490d443604147a34bb87b42763a592651135 SHA512 2005017783c42be91fdeabdd9d20d80d42858882c19c9b35f74cfc7e358c86890a8a034854d49b55ab0ee1dde69a2b2c204f0f443861dd249d10dfd855a0d04c
+EBUILD bloaty-9999.ebuild 798 BLAKE2B c24d2c676dfcec75c3ee0246877eaa8bc094fb3abf8728af5096090093eaa2e94f4c685bcdb6ed03ef36bc4d70a65e1469e2b8a705792c44aca6994dbd6e0b4b SHA512 f2d7d6f6f09ca7cb021777e5aaf7530e3d69dcb967fe952d4fdf6e0156dad11a75cd3fab0dead023dcc58c8fbfef3be7756a43a78f7f882357f2e3a8a22eed6d
+MISC metadata.xml 449 BLAKE2B d5d4f84a73649bcf9dd3f72b67de86369c401dd65efea8455dcd42f20607d408c22bed118faed36f9768db0519b3da3e884261a7ef45ea596dbe3611b05194ba SHA512 06903ec854e5200edd588dbbab17a45364e76c324262c08b0b7fd1bf54bfd607b8275de5d4e5dc7c7ebcfe62bebbdaa6c00850747d3021bf2939db947cfef63a
diff --git a/dev-util/bloaty/bloaty-1.1.ebuild b/dev-util/bloaty/bloaty-1.1.ebuild
new file mode 100644
index 000000000000..227dcc50dcdf
--- /dev/null
+++ b/dev-util/bloaty/bloaty-1.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="A size profiler for binaries"
+HOMEPAGE="https://github.com/google/bloaty"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/google/${PN}"
+ IUSE="test"
+ RESTRICT="!test? ( test )"
+else
+ SRC_URI="https://github.com/google/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64"
+fi
+
+BDEPEND="
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/capstone:=
+ dev-libs/protobuf:=
+ dev-libs/re2:=
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBLOATY_ENABLE_CMAKETARGETS=OFF
+ -DBUILD_SHARED_LIBS=OFF
+ )
+ if [[ ${PV} == 9999 ]]; then
+ mycmakeargs+=(
+ -DBUILD_TESTING=$(usex test)
+ $(usex test -DINSTALL_GTEST=OFF "")
+ )
+ fi
+ cmake_src_configure
+}
diff --git a/dev-util/bloaty/bloaty-9999.ebuild b/dev-util/bloaty/bloaty-9999.ebuild
new file mode 100644
index 000000000000..4aa412ab17d3
--- /dev/null
+++ b/dev-util/bloaty/bloaty-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="A size profiler for binaries"
+HOMEPAGE="https://github.com/google/bloaty"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/google/${PN}"
+ IUSE="test"
+ RESTRICT="!test? ( test )"
+else
+ SRC_URI="https://github.com/google/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64"
+fi
+
+BDEPEND="
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/capstone:=
+ dev-libs/protobuf:=
+ dev-libs/re2:=
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBLOATY_ENABLE_CMAKETARGETS=OFF
+ )
+ if [[ ${PV} == 9999 ]]; then
+ mycmakeargs+=(
+ -DBUILD_TESTING=$(usex test)
+ )
+ fi
+ cmake_src_configure
+}
diff --git a/dev-util/bloaty/metadata.xml b/dev-util/bloaty/metadata.xml
index 146d5f454ee7..36b90a82850e 100644
--- a/dev-util/bloaty/metadata.xml
+++ b/dev-util/bloaty/metadata.xml
@@ -1,8 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
- <upstream>
- <remote-id type="github">google/bloaty</remote-id>
- </upstream>
+ <maintainer type="person">
+ <email>ngg@ngg.hu</email>
+ <name>Gergely Nagy</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">google/bloaty</remote-id>
+ </upstream>
</pkgmetadata>