summaryrefslogtreecommitdiff
path: root/dev-util/bitrise
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/bitrise
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/bitrise')
-rw-r--r--dev-util/bitrise/Manifest3
-rw-r--r--dev-util/bitrise/bitrise-1.16.1.ebuild42
-rw-r--r--dev-util/bitrise/metadata.xml19
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-util/bitrise/Manifest b/dev-util/bitrise/Manifest
new file mode 100644
index 000000000000..6dc0a9f83fd5
--- /dev/null
+++ b/dev-util/bitrise/Manifest
@@ -0,0 +1,3 @@
+DIST bitrise-1.16.1.tar.gz 3986520 BLAKE2B 2a38eb72abc2aee69b9494abe03434014531a5081e8d71e7883418d686dffd1de8d61b2dda8761a1d074392a4f84699a4cff36be4f6be8abf52ba705434b8283 SHA512 37d87a27f2d3c17df7c61eebb8ab50887c7f723901125af08a5833bd053c5706cf1a2d3310fa30a6ade3bec8292b30bc4ddfb3143ece8129c606fcbe5103ddd6
+EBUILD bitrise-1.16.1.ebuild 1046 BLAKE2B 51bb9aaea5bda07f1505af7e2982b476d5b78e3e5850bb943c74716d022bb71cc74054b9bc9c6228d65dcb1c7549ff4b971a1c59bf2d4f85f59bff4d870c7a08 SHA512 61f650a5c6a37edfe5d3444c1db3200a1f8b8a770686de9332b07767a7e82fe794eda33cb163184fe6b61f3936c856b865e236cae66c2e83390a383155e2deee
+MISC metadata.xml 1068 BLAKE2B 998f8032d11dfb6271d2fa37e6b56b66c3cbde70690a4eaac731e4cfd3a17c91bb0a3787f6001ad8fd8f213edfdca433ef9ab1d577257bd8fe490dacbe9fd4d3 SHA512 f5ab34d1cf7d68f1b79f379e6edf08533d0621ad06144d906160ad223df351713077dd1d26751fbb1995d4561f90862ce1104be279348079d2e01294c9ba716e
diff --git a/dev-util/bitrise/bitrise-1.16.1.ebuild b/dev-util/bitrise/bitrise-1.16.1.ebuild
new file mode 100644
index 000000000000..35fbfb5fcaf7
--- /dev/null
+++ b/dev-util/bitrise/bitrise-1.16.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit golang-build
+
+EGO_ON="github.com/bitrise-io"
+EGO_PN="${EGO_ON}/${PN}"
+
+DESCRIPTION="Run your Bitrise.io automations on any Mac or Linux machine"
+HOMEPAGE="https://www.bitrise.io/cli"
+SRC_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+S="${WORKDIR}/src/${EGO_ON}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ mkdir -p "${WORKDIR}/src/${EGO_ON}" || die "Couldn't create project dir in GOPATH"
+ mv "${WORKDIR}/${P}" "${WORKDIR}/src/${EGO_ON}/bitrise" || die "Couldn't move sources to GOPATH"
+}
+
+src_compile() {
+ GOPATH="${WORKDIR}" go build -v -o bin/bitrise || die "Couldn't compile bitrise"
+}
+
+src_test() {
+ export PULL_REQUEST_ID=""
+ export INTEGRATION_TEST_BINARY_PATH="${S}/bin/bitrise"
+ GOPATH="${WORKDIR}" go test -v ./_tests/integration/... || die "Integration tests failed"
+}
+
+src_install() {
+ dobin bin/bitrise
+ dodoc README.md
+ use doc && dodoc -r _docs
+}
diff --git a/dev-util/bitrise/metadata.xml b/dev-util/bitrise/metadata.xml
new file mode 100644
index 000000000000..d00260bae974
--- /dev/null
+++ b/dev-util/bitrise/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>karol.wrotniak@droidsonroids.pl</email>
+ <name>Karol Wrótniak</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>Run your Bitrise automations with this CLI tool on any Mac or Linux machine, and use the same configuration on bitrise.io (automation service, with a mobile app focus). Part of the Bitrise Continuous Integration, Delivery and Automations Stack, with stepman and envman. For a nice &amp; quick intro you should check: https://www.bitrise.io/cli</longdescription>
+ <upstream>
+ <bugs-to>https://github.com/bitrise-io/bitrise/issues</bugs-to>
+ <changelog>https://github.com/bitrise-io/bitrise/blob/master/CHANGELOG.md</changelog>
+ <doc>https://github.com/bitrise-io/bitrise/blob/master/README.md</doc>
+ <remote-id type="github">bitriseio/bitrise</remote-id>
+ </upstream>
+</pkgmetadata>