summaryrefslogtreecommitdiff
path: root/dev-util/bitcoin-tx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/bitcoin-tx
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/bitcoin-tx')
-rw-r--r--dev-util/bitcoin-tx/Manifest7
-rw-r--r--dev-util/bitcoin-tx/bitcoin-tx-0.15.1.ebuild102
-rw-r--r--dev-util/bitcoin-tx/bitcoin-tx-0.16.0.ebuild98
-rw-r--r--dev-util/bitcoin-tx/metadata.xml19
4 files changed, 226 insertions, 0 deletions
diff --git a/dev-util/bitcoin-tx/Manifest b/dev-util/bitcoin-tx/Manifest
new file mode 100644
index 000000000000..5b4fceb6014e
--- /dev/null
+++ b/dev-util/bitcoin-tx/Manifest
@@ -0,0 +1,7 @@
+DIST bitcoin-0.15.1.knots20171111.patches.tar.xz 443024 BLAKE2B 5010c8d0f6a0bc8cd22ca7d7c73d9e4e689e369f0ba39b59f62fa6b6af3dcf938dfc87d33d3fe595a6e54d99734277a34af068dc29a6e984c76d529fbbe2f383 SHA512 455fadeac6ad57be111104680ec6939d6bf235eb49cde89b9716d36f6914c255b1b69cdea459d89b1bbca56099e793be0c8d7aacf592a9d78495068297bb5890
+DIST bitcoin-0.16.0.knots20180322.patches.tar.xz 417544 BLAKE2B f14616c81e0694346fd0714032be501ad0b58e82e2a5fcc623b1fdd316759ae7ac584e6c4ab586e8c9f5a402694a36eceac6b2f1c7441da655479f832a8869bd SHA512 9eca9cbae8ce17b38ddb70326760e33e7812db78e79cfe2d1a3518b34eb8fc87fe4c145e46ab60278b14e70a75b3af238342b4e1808a77cbca4b62b8c72fb1eb
+DIST bitcoin-v0.15.1.tar.gz 7550228 BLAKE2B 0cbb7d0e9d0e5e8eb33502a28289c3f9c86b7c531ed179f7e3e8b601a69a423fa736238a2caae890fd8850eb505533995e578e676860a4014922fbc238185ebb SHA512 a09b6cb64a1649d11e3fd6deeb13a07b1bf4bed504a2fc1c585919459ca8ac1af8e5ecc89dee487359e831a8f12625d54f408f95bb341033d6380b82c290c0d9
+DIST bitcoin-v0.16.0.tar.gz 6628305 BLAKE2B 69adb5832e2a708431c06bd8ce695f25cfc2b84e7ccf11e77f40c8ec273146208c70a900d0d32f79790cf67fb359c2731b0cecfc1f27ac2d0c4057228a83aed3 SHA512 7a59de44196a3cd5b75bccfe851e8bd7d5a00ae45b6e771e082326d75846e7c6d1f6d449e18b539b95b25aa12b7b79c462367f1c89438bcd1ca6ec84eb42972c
+EBUILD bitcoin-tx-0.15.1.ebuild 2470 BLAKE2B 0beaf2e85ddbe60e53efed0fcea6877b9799695fac06da2dad962939a48d1a2bff1f530f1bea92799d3a8001e353cb0f08804d827bc145bca602c503eaadf42e SHA512 aba586d5ef584d1d060668a97117e9602ae1a1626b4e867f42f1a58be918678fece96fdb504b96e04317d3ade34382799100a769e00e5057ebd6f8bc738ee888
+EBUILD bitcoin-tx-0.16.0.ebuild 2432 BLAKE2B ed1721e555bcfa9490b7291e9d9dd0e901ec713ecf7a1316a930c13f337076ca27a0757afd562776a124a2553e3690a383884e850aa1156e2f457681ef4f60df SHA512 fb46d29926d4c7a1058a5452f36087c27d916608e853beb25ae79e13ea38bbd70842467a22a2170a1c73c0f1b1edc40c9f93e5e1643d5c96db9571a07973eee3
+MISC metadata.xml 620 BLAKE2B e779b6a929a58fad28773a0aba3ef3112df14ce82ce62376b88cbc3519a857faaac6b580d2b5d866b0ec809062cf170e3c29324b03acc005246aea3cef9a0381 SHA512 c253ed29dff90ef2b9cd19b191ad870bd22cbdd371b2f353e724ba950735350225fe6d83c4ca8823ebb395dde9fb5004e781ff78987e2a30c0281ad5e0a4623a
diff --git a/dev-util/bitcoin-tx/bitcoin-tx-0.15.1.ebuild b/dev-util/bitcoin-tx/bitcoin-tx-0.15.1.ebuild
new file mode 100644
index 000000000000..d4d855fafc42
--- /dev/null
+++ b/dev-util/bitcoin-tx/bitcoin-tx-0.15.1.ebuild
@@ -0,0 +1,102 @@
+# Copyright 2010-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools bash-completion-r1
+
+MyPV="${PV/_/}"
+MyPN="bitcoin"
+MyP="${MyPN}-${MyPV}"
+BITCOINCORE_COMMITHASH="7b57bc998f334775b50ebc8ca5e78ca728db4c58"
+KNOTS_PV="${PV}.knots20171111"
+KNOTS_P="${MyPN}-${KNOTS_PV}"
+
+IUSE="knots libressl"
+
+DESCRIPTION="Command-line Bitcoin transaction tool"
+HOMEPAGE="https://bitcoincore.org/ https://bitcoinknots.org/"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm ~arm64 ~mips ~ppc x86 ~amd64-linux ~x86-linux"
+
+SRC_URI="
+ https://github.com/${MyPN}/${MyPN}/archive/${BITCOINCORE_COMMITHASH}.tar.gz -> ${MyPN}-v${PV}.tar.gz
+ https://bitcoinknots.org/files/0.15.x/${KNOTS_PV}/${KNOTS_P}.patches.txz -> ${KNOTS_P}.patches.tar.xz
+"
+CORE_DESC="https://bitcoincore.org/en/2017/11/11/release-${PV}/"
+KNOTS_DESC="https://bitcoinknots.org/files/0.15.x/${KNOTS_PV}/${KNOTS_P}.desc.html"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0=[-bindist] )
+ libressl? ( dev-libs/libressl:0= )
+ >=dev-libs/libsecp256k1-0.0.0_pre20151118[recovery]
+ dev-libs/univalue
+ >=dev-libs/boost-1.52.0:=[threads(+)]
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( doc/bips.md doc/release-notes.md )
+
+S="${WORKDIR}/${MyPN}-${BITCOINCORE_COMMITHASH}"
+
+pkg_pretend() {
+ if use knots; then
+ einfo "You are building ${PN} from Bitcoin Knots."
+ einfo "For more information, see ${KNOTS_DESC}"
+ else
+ einfo "You are building ${PN} from Bitcoin Core."
+ einfo "For more information, see ${CORE_DESC}"
+ fi
+}
+
+KNOTS_PATCH() { echo "${WORKDIR}/${KNOTS_P}.patches/${KNOTS_P}.$@.patch"; }
+
+src_prepare() {
+ eapply "$(KNOTS_PATCH syslibs)"
+
+ if use knots; then
+ eapply "$(KNOTS_PATCH f)"
+ eapply "$(KNOTS_PATCH branding)"
+ eapply "$(KNOTS_PATCH ts)"
+ fi
+
+ eapply_user
+
+ echo '#!/bin/true' >share/genbuild.sh || die
+ mkdir -p src/obj || die
+ echo "#define BUILD_SUFFIX gentoo${PVR#${PV}}" >src/obj/build.h || die
+
+ eautoreconf
+ rm -r src/leveldb src/secp256k1 || die
+}
+
+src_configure() {
+ local my_econf=(
+ --disable-experimental-asm
+ --without-qtdbus
+ --without-libevent
+ --without-qrencode
+ --without-miniupnpc
+ --disable-tests
+ --disable-wallet
+ --disable-zmq
+ --enable-util-tx
+ --disable-util-cli
+ --disable-bench
+ --without-libs
+ --without-daemon
+ --without-gui
+ --disable-ccache
+ --disable-static
+ --with-system-libsecp256k1
+ --with-system-univalue
+ )
+ econf "${my_econf[@]}"
+}
+
+src_install() {
+ default
+
+ newbashcomp contrib/${PN}.bash-completion ${PN}
+}
diff --git a/dev-util/bitcoin-tx/bitcoin-tx-0.16.0.ebuild b/dev-util/bitcoin-tx/bitcoin-tx-0.16.0.ebuild
new file mode 100644
index 000000000000..e0f97bebbc18
--- /dev/null
+++ b/dev-util/bitcoin-tx/bitcoin-tx-0.16.0.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools bash-completion-r1
+
+BITCOINCORE_COMMITHASH="4b4d7eb255ca8f9a94b92479e6061d129c91a991"
+KNOTS_PV="${PV}.knots20180322"
+KNOTS_P="bitcoin-${KNOTS_PV}"
+
+DESCRIPTION="Command-line Bitcoin transaction tool"
+HOMEPAGE="https://bitcoincore.org/ https://bitcoinknots.org/"
+SRC_URI="
+ https://github.com/bitcoin/bitcoin/archive/${BITCOINCORE_COMMITHASH}.tar.gz -> bitcoin-v${PV}.tar.gz
+ https://bitcoinknots.org/files/0.16.x/${KNOTS_PV}/${KNOTS_P}.patches.txz -> ${KNOTS_P}.patches.tar.xz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~amd64-linux ~arm ~arm64 ~mips ~ppc ~x86 ~x86-linux"
+IUSE="knots libressl"
+
+DEPEND="
+ >=dev-libs/boost-1.52.0:=[threads(+)]
+ >=dev-libs/libsecp256k1-0.0.0_pre20151118:=[recovery]
+ dev-libs/univalue:=
+ !libressl? ( dev-libs/openssl:0=[-bindist] )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( doc/bips.md doc/release-notes.md )
+
+S="${WORKDIR}/bitcoin-${BITCOINCORE_COMMITHASH}"
+
+pkg_pretend() {
+ if use knots; then
+ elog "You are building ${PN} from Bitcoin Knots."
+ elog "For more information, see:"
+ elog "https://bitcoinknots.org/files/0.16.x/${KNOTS_PV}/${KNOTS_P}.desc.html"
+ else
+ elog "You are building ${PN} from Bitcoin Core."
+ elog "For more information, see:"
+ elog "https://bitcoincore.org/en/2017/11/11/release-${PV}/"
+ fi
+}
+
+src_prepare() {
+ local knots_patchdir="${WORKDIR}/${KNOTS_P}.patches/"
+
+ eapply "${knots_patchdir}/${KNOTS_P}.syslibs.patch"
+
+ if use knots; then
+ eapply "${knots_patchdir}/${KNOTS_P}.f.patch"
+ eapply "${knots_patchdir}/${KNOTS_P}.branding.patch"
+ eapply "${knots_patchdir}/${KNOTS_P}.ts.patch"
+ fi
+
+ eapply_user
+
+ echo '#!/bin/true' >share/genbuild.sh || die
+ mkdir -p src/obj || die
+ echo "#define BUILD_SUFFIX gentoo${PVR#${PV}}" >src/obj/build.h || die
+
+ eautoreconf
+ rm -r src/leveldb src/secp256k1 || die
+}
+
+src_configure() {
+ local my_econf=(
+ --disable-asm
+ --without-qtdbus
+ --without-libevent
+ --without-qrencode
+ --without-miniupnpc
+ --disable-tests
+ --disable-wallet
+ --disable-zmq
+ --enable-util-tx
+ --disable-util-cli
+ --disable-bench
+ --without-libs
+ --without-daemon
+ --without-gui
+ --disable-ccache
+ --disable-static
+ --with-system-libsecp256k1
+ --with-system-univalue
+ )
+ econf "${my_econf[@]}"
+}
+
+src_install() {
+ default
+
+ newbashcomp contrib/${PN}.bash-completion ${PN}
+}
diff --git a/dev-util/bitcoin-tx/metadata.xml b/dev-util/bitcoin-tx/metadata.xml
new file mode 100644
index 000000000000..62d40fbeff4c
--- /dev/null
+++ b/dev-util/bitcoin-tx/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>luke-jr+gentoobugs@utopios.org</email>
+ <name>Luke Dashjr</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ <flag name="knots">Build enhanced Bitcoin Knots version, rather than Bitcoin Core</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">bitcoin/bitcoin</remote-id>
+ <remote-id type="github">bitcoinknots/bitcoin</remote-id>
+ </upstream>
+</pkgmetadata>