summaryrefslogtreecommitdiff
path: root/dev-util/bitcoin-tx/bitcoin-tx-24.0.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-05 12:08:58 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-05 12:08:58 +0000
commitf29a41111b3a606f5d95049b1ba92daabbc68cc0 (patch)
tree310589df1ffb427b1a0595a329cfb2845335b778 /dev-util/bitcoin-tx/bitcoin-tx-24.0.1-r1.ebuild
parent083bdfbef9bc532b72cf116591025916eebaf676 (diff)
gentoo auto-resync : 05:01:2023 - 12:08:57
Diffstat (limited to 'dev-util/bitcoin-tx/bitcoin-tx-24.0.1-r1.ebuild')
-rw-r--r--dev-util/bitcoin-tx/bitcoin-tx-24.0.1-r1.ebuild82
1 files changed, 82 insertions, 0 deletions
diff --git a/dev-util/bitcoin-tx/bitcoin-tx-24.0.1-r1.ebuild b/dev-util/bitcoin-tx/bitcoin-tx-24.0.1-r1.ebuild
new file mode 100644
index 000000000000..0b44b98f9cba
--- /dev/null
+++ b/dev-util/bitcoin-tx/bitcoin-tx-24.0.1-r1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools bash-completion-r1
+
+DESCRIPTION="Command-line Bitcoin transaction tool"
+HOMEPAGE="https://bitcoincore.org/"
+SRC_URI="
+ https://bitcoincore.org/bin/bitcoin-core-${PV}/${P/-tx}.tar.gz
+"
+S="${WORKDIR}"/${P/-tx}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+# TODO: Can we drop virtual/bitcoin-leveldb from some bitcoin-*?
+# (only bitcoin-qt, bitcoind should need it?)
+RDEPEND="
+ >=dev-libs/boost-1.64.0:=
+ >=dev-libs/libsecp256k1-0.2:=[recovery,schnorr]
+ virtual/bitcoin-leveldb
+"
+DEPEND="${RDEPEND}"
+
+DOCS=(
+ doc/bips.md
+ doc/release-notes.md
+)
+
+PATCHES=(
+ "${FILESDIR}"/24.0.1-syslibs.patch
+)
+
+pkg_pretend() {
+ elog "You are building ${PN} from Bitcoin Core."
+ elog "For more information, see:"
+ elog "https://bitcoincore.org/en/releases/${PV}/"
+}
+
+src_prepare() {
+ default
+
+ eautoreconf
+ rm -r src/leveldb src/secp256k1 || die
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-asm
+ --without-qtdbus
+ --disable-ebpf
+ --without-natpmp
+ --without-qrencode
+ --without-miniupnpc
+ --disable-tests
+ --disable-wallet
+ --disable-zmq
+ --enable-util-tx
+ --disable-util-util
+ --disable-util-cli
+ --disable-util-wallet
+ --disable-bench
+ --without-libs
+ --without-daemon
+ --without-gui
+ --disable-fuzz
+ --disable-fuzz-binary
+ --disable-ccache
+ --with-system-libsecp256k1
+ --with-system-univalue
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ newbashcomp contrib/${PN}.bash-completion ${PN}
+}