summaryrefslogtreecommitdiff
path: root/dev-util/biew
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/biew
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/biew')
-rw-r--r--dev-util/biew/Manifest6
-rw-r--r--dev-util/biew/biew-6.1.0-r3.ebuild65
-rw-r--r--dev-util/biew/files/biew-610-crash.patch28
-rw-r--r--dev-util/biew/files/biew-610-fix_localedep-1.patch26
-rw-r--r--dev-util/biew/files/biew-610-portable_configure-1.patch167
-rw-r--r--dev-util/biew/metadata.xml11
6 files changed, 303 insertions, 0 deletions
diff --git a/dev-util/biew/Manifest b/dev-util/biew/Manifest
new file mode 100644
index 000000000000..8d5607d6839b
--- /dev/null
+++ b/dev-util/biew/Manifest
@@ -0,0 +1,6 @@
+AUX biew-610-crash.patch 1254 BLAKE2B daf3918abab9b8e552c968229c77d57658ca925ad88c0b0a421e92b0a214c63f28860cfb8935e970d45bd6fc9bbd24c72cd30e11b848150016cac44945cf1998 SHA512 ec71e70aacd171125100e2482fd888002d47f95cbeb909ba78acc1c2383a70bad5b8f8fb7acb709989e1466722e974b5a4689394fcdad96903354bd32306746e
+AUX biew-610-fix_localedep-1.patch 1003 BLAKE2B 6c6d81692a4ed14e1f0a229e31aa2f6432a0f093e8a38a20d523127b3d58838bc45c5d63332615460c3fca0ec1048d10d534b5b9d2cf8e3eaf15909fc64f6deb SHA512 d141df509fda58d2044fc8488bb73eca8b908fa33dd0449724475d8e6109e186d67245506c4af3100d24378d51866367da1b09bffbb664e91ff79f6bde7e68eb
+AUX biew-610-portable_configure-1.patch 4932 BLAKE2B 077f437ef02e20220c6f18b0baa472a73fc8de070b292e2ad5f75bbcd95616da110c3d723d42ac206eaa87d39500a43c893d623126dcf254e03ddb414bccfa06 SHA512 cce6564e9d65b6f8c6c4a8dba1919dcfffbc22641ddfcb4fdf1bcab45d56b437dedbee328c86426c1b821b57b923e3d8cc97fdcf140662deb794f64e29c6847c
+DIST biew-610-src.tar.bz2 860517 BLAKE2B 23ccb5e17dc3d99c6eeb303ad26a9779faa5a648208e0a7291b7f120f492db80f0995449ca2e6982de73543cbc7d9210c3f56077eeffceef46e4ea17cb838b5a SHA512 df8d3c10c30e30db1bc5fdba73601a148f7a1480e69a3d03a02ec303534f37db9c5a9eb7ac087d8f1d8cc64d4a0f6e11548c5b385e132e3a981a6f328e3b5742
+EBUILD biew-6.1.0-r3.ebuild 1737 BLAKE2B 9d0dea71af9358332d8e1f97583022c03ece983d6bdb9a51c5b6837003dfc64d11c05ea6e458da42cc23d83467d54f34008a18042e58a03ee0cdf49d3b7915f7 SHA512 17c0f8d50d00c1eb9a90ca1527737cf4728401c94845baba5c71cde5f1f095e4cadf2088ed2b939f6e3b4540718246e4c1ca3f2eac50f421cbf5b29e02c604f5
+MISC metadata.xml 327 BLAKE2B f4e3b7d00a6084b3b0cbffc2dcec2ffbea9d73717119295f8bb46b9a17c928086a61a01eccad85aedbd511ec5d9d73c52b5f0f3ab1944f9bce5d5da5c853abb1 SHA512 0e157ba1f9c8d78c203108d72e2871cda917a404223cd7d8b8ff261f72ec69be630a59e6e205112a0798d7daee06bfd60a3feaa950b327041187ae25701a24f2
diff --git a/dev-util/biew/biew-6.1.0-r3.ebuild b/dev-util/biew/biew-6.1.0-r3.ebuild
new file mode 100644
index 000000000000..d35ab26a9595
--- /dev/null
+++ b/dev-util/biew/biew-6.1.0-r3.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit eutils flag-o-matic toolchain-funcs versionator
+
+MY_P=${PN}-$(replace_all_version_separators "")
+
+DESCRIPTION="A portable viewer of binary files, hexadecimal and disassembler modes"
+HOMEPAGE="http://beye.sourceforge.net/"
+SRC_URI="mirror://sourceforge/beye/${PV}/${MY_P}-src.tar.bz2"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="gpm cpu_flags_x86_mmx cpu_flags_x86_sse"
+REQUIRED_USE="cpu_flags_x86_mmx cpu_flags_x86_sse"
+
+RDEPEND="gpm? ( sys-libs/gpm )"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ append-flags -mmmx -msse #362043
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-610-fix_localedep-1.patch"
+ epatch "${FILESDIR}/${PN}-610-portable_configure-1.patch"
+ epatch "${FILESDIR}/${PN}-610-crash.patch"
+ sed -i -e 's^man/man1/biew.1^share/man/man1/biew.1^' makefile || die "Failed to edit makefile."
+}
+
+src_configure() {
+ if use gpm; then
+ append-cppflags -DHAVE_MOUSE
+ else
+ append-cppflags -UHAVE_MOUSE
+ fi
+ ./configure --datadir=/usr/share/${PN} \
+ --prefix=/usr \
+ --cc="$(tc-getCC)" \
+ --ld="$(tc-getCC)" \
+ --ar="$(tc-getAR) -rcu" \
+ --as="$(tc-getAS)" \
+ --ranlib="$(tc-getRANLIB)" || die "configure failed."
+}
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc doc/{biew_en,release,unix}.txt
+}
+
+pkg_postinst() {
+ elog
+ elog "Note: if you are upgrading from <=dev-util/biew-6.1.0 you will need"
+ elog "to change the paths in the setup dialog (F9) from /usr/share/ to"
+ elog "/usr/share/biew/ Alternatively, you can delete ~/.biewrc and it will"
+ elog "automatically determine the correct locations on the next run."
+ elog
+}
diff --git a/dev-util/biew/files/biew-610-crash.patch b/dev-util/biew/files/biew-610-crash.patch
new file mode 100644
index 000000000000..244f94a7ad53
--- /dev/null
+++ b/dev-util/biew/files/biew-610-crash.patch
@@ -0,0 +1,28 @@
+If .biewrc does not exist, the setup dialog appears at program start. If you try
+to click a checkbox with the mouse, biew tries to dereference a null pointer
+(because the MainWindow is not yet set).
+
+This patch adds a workaround. Note that you actually cannot click a checkbox.
+But that is what users might expect. (Maybe the biew code should be changed to
+handle this properly.) Well, it is better not to crash, even if the checkboxes
+are not clickable.
+
+ –nico
+
+
+diff -Naur biew-610.orig/events.c biew-610/events.c
+--- biew-610.orig/events.c 2009-09-03 16:57:40.000000000 +0000
++++ biew-610/events.c 2011-09-06 09:41:01.000000000 +0000
+@@ -118,7 +118,11 @@
+ }
+ else
+ {
+- X1 = 0; X2 = twGetClientWidth(MainWnd); Y1 = 1; Y2 = twGetClientHeight(MainWnd) - 1;
++ TWindow *wnd =
++ MainWnd ? MainWnd : /*XXX:drop this line?*/
++ twGetWinAtPos(mx, my);
++ if(!wnd) return KE_MOUSE;
++ X1 = 0; X2 = twGetClientWidth(wnd); Y1 = 1; Y2 = twGetClientHeight(wnd) - 1;
+ }
+ wdh = X2 - X1;
+ hght = Y2 - Y1;
diff --git a/dev-util/biew/files/biew-610-fix_localedep-1.patch b/dev-util/biew/files/biew-610-fix_localedep-1.patch
new file mode 100644
index 000000000000..babe994e070a
--- /dev/null
+++ b/dev-util/biew/files/biew-610-fix_localedep-1.patch
@@ -0,0 +1,26 @@
+The configure script of biew-6.1.0 fails with
+ Checking for C compiler name ... gcc-Version
+if using the de_DE.UTF-8 locale and sys-devel/gcc-4.5.2. It may fail with other
+locales and/or compilers, too. The problem occurs due to the fact that the
+string “gcc version” written by gcc for ‘gcc -v’ is translated according to the
+language (German in the case mentioned above).
+
+This patch makes sure that the POSIX locale is used when the biew configure
+script checks for the name of the compiler. This allows the configure script to
+parse the output properly.
+
+ –nico
+
+
+diff -Naur biew-610.orig/configure biew-610/configure
+--- biew-610.orig/configure 2009-11-13 15:52:36.000000000 +0100
++++ biew-610/configure 2011-01-13 11:11:59.000000000 +0100
+@@ -497,7 +497,7 @@
+
+ _cdefos="-DDATADIR='\"$_datadir\"'"
+
+-cc_name=`$_cc -v 2>&1 | tail -n 1 | cut -d ' ' -f 1`
++cc_name=`LC_ALL=POSIX $_cc -v 2>&1 | tail -n 1 | cut -d ' ' -f 1`
+ cc_version=`$_cc -dumpversion`
+
+ echocheck "C compiler name"
diff --git a/dev-util/biew/files/biew-610-portable_configure-1.patch b/dev-util/biew/files/biew-610-portable_configure-1.patch
new file mode 100644
index 000000000000..c64f6280ba08
--- /dev/null
+++ b/dev-util/biew/files/biew-610-portable_configure-1.patch
@@ -0,0 +1,167 @@
+Changes the biew-610 configure script to use portable test constructs. See the
+Autoconf manual <URL:https://www.gnu.org/software/autoconf/manual/html_node/
+Limitations-of-Builtins.html#index-g_t_0040command_007btest_007d-1725> for
+explanations.
+
+ –nico
+
+
+diff -Naur biew-610.orig/configure biew-610/configure
+--- biew-610.orig/configure 2009-11-13 14:52:36.000000000 +0000
++++ biew-610/configure 2011-02-24 09:44:10.000000000 +0000
+@@ -171,7 +171,7 @@
+ # 1st: print out help
+
+ for parm in "$@" ; do
+- if test "$parm" = "--help" || test "$parm" = "-help" || test "$parm" = "-h" ; then
++ if test "X$parm" = "X--help" || test "X$parm" = "X-help" || test "X$parm" = "X-h" ; then
+ cat << EOF
+
+ Usage: $0 [OPTIONS]...
+@@ -235,7 +235,7 @@
+ _cp=cp
+ _libext=a
+ _libprefix=lib
+-test "$CC" && _cc="$CC"
++test "X$CC" != X && _cc="$CC"
+ _prefix="/usr/local"
+ _datadir=
+ _libdir=
+@@ -340,11 +340,11 @@
+ ;;
+ esac
+ done
+-test -z "$_datadir" && _datadir=$_prefix"/share/biew"
+-test -z "$_libdir" && _libdir=$_prefix"/lib/biew"
++test "X$_datadir" = X && _datadir=$_prefix"/share/biew"
++test "X$_libdir" = X && _libdir=$_prefix"/lib/biew"
+
+ for I in "$TMPDIR" "$TEMPDIR" "/tmp" ; do
+- test "$I" && break
++ test "X$I" != X && break
+ done
+
+ TMPLOG="config.log"
+@@ -357,8 +357,8 @@
+ _tee="tee -a $TMPLOG"
+
+ echocheck "architecture"
+-if test "$_target_arch" = auto ; then
+- if test -z "$host_arch" ; then
++if test "X$_target_arch" = Xauto ; then
++ if test "X$host_arch" = X ; then
+ host_arch=`( uname -p ) 2>&1`
+ log "uname -p :" "$host_arch"
+ case "$host_arch" in
+@@ -416,8 +416,8 @@
+ x86_64 && _bitness=64
+
+ echocheck "target OS"
+-if test "$_target_system" = auto ; then
+- if test -z "$system_name" ; then
++if test "X$_target_system" = Xauto ; then
++ if test "X$system_name" = X ; then
+ # OS name
+ system_name=`uname -s`
+ log "uname -s :" "$system_name"
+@@ -461,8 +461,8 @@
+ fi
+ fi
+
+-if test "$_target_system" = auto ; then
+- if test -z "$system_name" ; then
++if test "X$_target_system" = Xauto ; then
++ if test "X$system_name" = X ; then
+ # OS name
+ system_name=`/bin/sh --version 2>&1 | sed -n 's/^.*\([(]\)./\1/p'`
+ log "/bin/sh --version:" "$system_name"
+@@ -549,7 +549,7 @@
+ ;;
+ esac
+
+-if test -z "$_x11incdir" ; then
++if test "X$_x11incdir" = X ; then
+ echocheck "X11 headers"
+ for I in /usr/include /usr/X11R6/include /usr/X11/include /usr/openwin/include ; do
+ if test -d "$I/X11" ; then
+@@ -559,11 +559,11 @@
+ fi
+ done
+ fi
+-if test -z "$_x11incdir" ; then
++if test "X$_x11incdir" = X ; then
+ echores "x11inc not found"
+ fi
+
+-if test -z "$_x11libdir" ; then
++if test "X$_x11libdir" = X ; then
+ echocheck "X11 libs"
+ for I in /usr/X11R6/lib /usr/X11/lib /usr/lib32 /usr/openwin/lib ; do
+ if test -d "$I" ; then
+@@ -573,24 +573,24 @@
+ fi
+ done
+ fi
+-if test -z "$_x11libdir" ; then
++if test "X$_x11libdir" = X ; then
+ echores "x11lib not found"
+ fi
+
+-test -z "$_debug" && _osldef="-s $_osldef" || _cdefos="-finline-limit-5 $_cdefos"
+-if test "$_profile" -o "$_debug" -o "$_gcov"; then
++test "X$_debug" = X && _osldef="-s $_osldef" || _cdefos="-finline-limit-5 $_cdefos"
++if test "X$_profile" != X || test "X$_debug" != X || test "X$_gcov" != X ; then
+ _cdefos="-W -Wall -O2 -fno-builtin $_debug $_profile $_gcov $_cdefos"
+ _osldef="$_debug $_profile $_osldef"
+-elif test -z "$CFLAGS" ; then
++elif test "X$CFLAGS" = X ; then
+ _cdefos="-DNDEBUG=1 -O2 -ffast-math -fomit-frame-pointer $_cdefos"
+ x86 && _cdefos="-mmmx -msse $_cdefos"
+ else
+ _cdefos="-DNDEBUG=1 $CFLAGS $_cdefos"
+ fi
+-test -n "$LDFLAGS" && _osldef="$LDFLAGS $_osldef"
+-test -n "$LIBS" && _osldef="$LIBS $_osldef"
++test "X$LDFLAGS" != X && _osldef="$LDFLAGS $_osldef"
++test "X$LIBS" != X && _osldef="$LIBS $_osldef"
+
+-if test "$_target_system" = dos ; then
++if test "X$_target_system" = Xdos ; then
+ # disable cc_check call for DJGPP due bugs in bash
+ _cdefos="-D__HAVE_PRAGMA_PACK__=1 $_cdefos"
+ else
+@@ -668,10 +668,10 @@
+ _curseslib=
+ disable _curses
+ cc_check -lcurses && _curseslib="-lcurses"
+- if test -z "$_curseslib" ; then
++ if test "X$_curseslib" = X ; then
+ cc_check -lncurses && _curseslib="-lncurses"
+ fi
+- if test -n "$_curseslib" ; then
++ if test "X$_curseslib" != X ; then
+ enable _curses
+ _cdefos="-D_CURSES_ -D__OS_NAME__='\"Unix/Curses\"' $_cdefos"
+ _oslibs="$_curseslib $_oslibs"
+@@ -711,10 +711,10 @@
+ enabled sys_resource_h && _cdefos="-DHAVE_SYS_RESOURCE=1 $_cdefos"
+ echores "$sys_resource_h"
+
+-if test -z "$_x11libdir" ; then
++if test "X$_x11libdir" = X ; then
+ _cdefos="$_cdefos"
+ else
+- if test -z "$_x11incdir" ; then
++ if test "X$_x11incdir" = X ; then
+ _cdefos="$_cdefos"
+ else
+ _cdefos="-DHAVE_X11 $_cdefos"
+@@ -738,7 +738,7 @@
+ fi
+
+ # Checking for INSTALL
+-if test -z $_install
++if test "X$_install" = X
+ then
+ _install="install"
+ $_install --version 1>/dev/null 2>/dev/null || _install=""
diff --git a/dev-util/biew/metadata.xml b/dev-util/biew/metadata.xml
new file mode 100644
index 000000000000..5894b06df22b
--- /dev/null
+++ b/dev-util/biew/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">beye</remote-id>
+ </upstream>
+</pkgmetadata>