summaryrefslogtreecommitdiff
path: root/dev-util/bear
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-07-04 14:05:23 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-07-04 14:05:23 +0100
commit05b8b0e0af1d72e51a3ee61522941bf7605cd01c (patch)
tree43b0410e62aba677b4b256bc3ffe3fd333d28dbe /dev-util/bear
parent90c88731bd036e5698b281fbc0a5f3aa4c9983ac (diff)
gentoo resync : 04.07.2020
Diffstat (limited to 'dev-util/bear')
-rw-r--r--dev-util/bear/Manifest3
-rw-r--r--dev-util/bear/bear-2.4.3.ebuild61
-rw-r--r--dev-util/bear/metadata.xml19
3 files changed, 83 insertions, 0 deletions
diff --git a/dev-util/bear/Manifest b/dev-util/bear/Manifest
new file mode 100644
index 000000000000..87788535cf53
--- /dev/null
+++ b/dev-util/bear/Manifest
@@ -0,0 +1,3 @@
+DIST bear-2.4.3.tar.gz 49933 BLAKE2B 2a91c30d81f9d0e58a25458579f6b0c867c07d2e532bd2ed29305645e152bd564156f708c4a07a683577412b3fdab1f106685ecf1ad88eaad2f33f0bc43a5baa SHA512 a4690cfc9938d8752ca5c8322ca4c5039746ade059e4459e7f3f91b2bf3d36ea691a5d855cab7a4e7ad8ff76478c48c4394593e069a1cf8396ead41017421753
+EBUILD bear-2.4.3.ebuild 1634 BLAKE2B e0adf19fb18817851269ce6ee51bc32a91ecadeded8245ff8febd2e521f5cb5a3892b862186e2bf58d893a6ea63b9fde70868c338563b3347518b186ada5ec62 SHA512 80713166f3397724f34824d1498ac338b6b5cfefa39b6dc323f190e01dfbbebee031c2ada1186cfe493006abd7a9294f3d70c66583c31db7b1bf0b154acdc0e0
+MISC metadata.xml 914 BLAKE2B 791cac2c9a3850bc49848ec8f6ff889a21802ddce6937783afccdda45045b3861f0c79e44028ea6df18f046c5fc1b6ad89ac1a940afc9e4d6607507a12933382 SHA512 a7b29ce47f3c9d91f2ba5d1abf5975d64a9229619737b75d38d54b3bde860a47a859e6de7a959ad67cba21b2a0ced8a9fbaf508c02cace63c4090afbac2005ba
diff --git a/dev-util/bear/bear-2.4.3.ebuild b/dev-util/bear/bear-2.4.3.ebuild
new file mode 100644
index 000000000000..83600bfdb38f
--- /dev/null
+++ b/dev-util/bear/bear-2.4.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit cmake python-single-r1
+
+DESCRIPTION="Build EAR generates a compilation database for clang tooling"
+HOMEPAGE="https://github.com/rizsotto/Bear"
+SRC_URI="https://github.com/rizsotto/Bear/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+IUSE="test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="test? (
+ app-shells/bash
+ $(python_gen_cond_dep '
+ dev-python/lit[${PYTHON_USEDEP}]
+ ')
+)"
+
+RDEPEND="${PYTHON_DEPS}"
+
+RESTRICT="!test? ( test )"
+
+S="${WORKDIR}/${P^}"
+
+src_compile() {
+ cmake_src_compile
+ # need to fix it now, before tests are run
+ python_fix_shebang "${BUILD_DIR}"/bear/bear
+ python_fix_shebang test/functional/tools/cdb_diff.py
+}
+
+src_test() {
+ if has sandbox ${FEATURES}; then
+ ewarn "\'FEATURES=sandbox\' detected"
+ ewarn "Bear overrides LD_PRELOAD and conflicts with gentoo sandbox"
+ ewarn "Skipping tests"
+ elif
+ has usersandbox ${FEATURES}; then
+ ewarn "\'FEATURES=usersandbox\' detected"
+ ewarn "Skipping tests"
+ elif
+ has_version -b 'sys-devel/gcc-config[-native-symlinks]'; then
+ ewarn "\'sys-devel/gcc-config[-native-symlinks]\' detected, tests call /usr/bin/cc directly (hardcoded)"
+ ewarn "and will fail without generic cc symlink"
+ ewarn "Skipping tests"
+ else
+ einfo "removing unwanted/unsupported/xfail tests"
+ rm -v test/functional/cases/{end-to-end/scons.ft,intercept/cuda/successful_build.fts,run_pep8.ft} || die
+ einfo "test may use optional tools if found: qmake gfortran"
+ cmake_build check
+ fi
+}
diff --git a/dev-util/bear/metadata.xml b/dev-util/bear/metadata.xml
new file mode 100644
index 000000000000..f8c8a305d1e4
--- /dev/null
+++ b/dev-util/bear/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gyakovlev@gentoo.org</email>
+ <name>Georgy Yakovlev</name>
+ </maintainer>
+ <longdescription lang="en">
+ Bear is a tool that generates a compilation database for clang tooling.
+ The concept behind Bear is: to execute the original build command and intercept the exec calls issued by the build tool.
+ To achieve that, Bear uses the LD_PRELOAD or DYLD_INSERT_LIBRARIES mechanisms provided by the dynamic linker.
+ Bear has two components: the library and the binary.
+ The library redefines the exec methods to be used by all child processes.
+ The executable enables the use of the library for child processes and writes the output file.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">rizsotto/Bear</remote-id>
+ </upstream>
+</pkgmetadata>