summaryrefslogtreecommitdiff
path: root/dev-util/bcpp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/bcpp
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/bcpp')
-rw-r--r--dev-util/bcpp/Manifest3
-rw-r--r--dev-util/bcpp/bcpp-20150811-r1.ebuild35
-rw-r--r--dev-util/bcpp/metadata.xml5
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-util/bcpp/Manifest b/dev-util/bcpp/Manifest
new file mode 100644
index 000000000000..b17f2682f44e
--- /dev/null
+++ b/dev-util/bcpp/Manifest
@@ -0,0 +1,3 @@
+DIST bcpp-20150811.tgz 145969 BLAKE2B c7cdb21b6c07599c93c6f3fdf6ca4f5e825d4ae5f955e1c969d744a9ff2594bf3c7dcded1582dff695201f6e7e8ed57d5796883b63c5c57476c6601da6a49717 SHA512 a11462574bd87cf66dc50ce23f188d335480aae5448b527694791d4b7ae5cde27c0e0c0850dc8899b2b66198c37a434985c833f95f7f2d2d88a3b7dfe4ff34a9
+EBUILD bcpp-20150811-r1.ebuild 912 BLAKE2B 83362edbe78e6587ff3df1ccd6e32a919aa39094170ee5670fbc3716d7825039d075b01547cd89a31af302f0e9550eedcf1aa4ac9a601c51581e713176fc0717 SHA512 b76858bb46a572a0fb64184496146b6b2c47a87330095b96562d62617f2179b9c3f442692296614e2f02cccf206a34163823cff0840a707b51b754057c6eea58
+MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/dev-util/bcpp/bcpp-20150811-r1.ebuild b/dev-util/bcpp/bcpp-20150811-r1.ebuild
new file mode 100644
index 000000000000..32f56aaee9d7
--- /dev/null
+++ b/dev-util/bcpp/bcpp-20150811-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+DESCRIPTION="Indents C/C++ source code"
+HOMEPAGE="http://invisible-island.net/bcpp/"
+SRC_URI="ftp://invisible-island.net/bcpp/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+src_compile() {
+ emake CPPFLAGS='-DBCPP_CONFIG_DIR=\"/etc/bcpp/\"'
+}
+
+src_install() {
+ default
+ dodoc CHANGES MANIFEST README VERSION txtdocs/hirachy.txt \
+ txtdocs/manual.txt
+
+ insinto /etc/bcpp
+ doins bcpp.cfg indent.cfg
+}
+
+pkg_postinst() {
+ elog "Check the documentation for more information on how to"
+ elog "Run bcpp. Please note that in order to get help for"
+ elog "bcpp, please run bcpp -h and not the command by itself."
+ elog ""
+ elog "Configuration files are at /etc/bcpp."
+ elog "To use them, use the -c option followed by the filename."
+}
diff --git a/dev-util/bcpp/metadata.xml b/dev-util/bcpp/metadata.xml
new file mode 100644
index 000000000000..6f49eba8f496
--- /dev/null
+++ b/dev-util/bcpp/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+</pkgmetadata>