summaryrefslogtreecommitdiff
path: root/dev-util/bazel
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-util/bazel
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-util/bazel')
-rw-r--r--dev-util/bazel/Manifest6
-rw-r--r--dev-util/bazel/bazel-0.4.5-r1.ebuild70
-rw-r--r--dev-util/bazel/bazel-0.5.2.ebuild77
-rw-r--r--dev-util/bazel/metadata.xml23
4 files changed, 176 insertions, 0 deletions
diff --git a/dev-util/bazel/Manifest b/dev-util/bazel/Manifest
new file mode 100644
index 000000000000..06c05ca76980
--- /dev/null
+++ b/dev-util/bazel/Manifest
@@ -0,0 +1,6 @@
+DIST bazel-0.4.5-dist.zip 101505017 SHA256 2b737be42678900470ae9e48c975ac5b2296d9ae23c007bf118350dbe7c0552b SHA512 bc70e379a9f6f962440d05d4a706959461690e28a943833e17d6e2b7e3cd7dd2344f329f72d833ec5104334a71764fde195e50b09a582ae7c1b89bd62822943b WHIRLPOOL d236eb387373f4b1cba32084a8b282f2bc75e6a0a714f18229cf5064230ad912bd879df2e7ebcc30da18538958ded4a1b8e59c27c0716aa6b677690b10a0356e
+DIST bazel-0.5.2-dist.zip 100003640 SHA256 2418c619bdd44257a170b85b9d2ecb75def29e751b725e27186468ada2e009ea SHA512 2580b41a09d8e7766bf06ed55bca06f542a13fecf050b105829811d8a95e8f9a4395ebc8d3ce6436ecec8faab704afd608d71e2d368e51c668df3f766ca6e9c1 WHIRLPOOL 8ea9522bbd38ec5d9de4eebae0586c71ab2cf2f782430e0e0bd5fc84c8d431df7f758627ad9f0aeb57445c1c3d4b3de34702e2e2a6a73aea246519543d8ff118
+EBUILD bazel-0.4.5-r1.ebuild 1820 SHA256 5fc8efbdf3f33a0a571c299620dc248cf367b9d4c1a3c5fe8cdf71fb600f78dd SHA512 eea6c74fa9ceaea72fd8ffd2f40b1a96858cad297168eba38213993f176eb8069ac7ba6e8f166d7eff43af56b2c1ba2039c268bbe86efb7dcf842fe33d5cf583 WHIRLPOOL c01f964c36314bbff5f4259837fe6eed7049a2b3122a28a366eb774d218de34db0167db3c62148ec2e68e1113773944f992e9259685291deab5fcbec50ceb0ef
+EBUILD bazel-0.5.2.ebuild 1977 SHA256 1b9478c334b87f8d3b3f9fceec65a824d8c4a355f6da5ad674a3cb9a640ba61f SHA512 1ebbd3512a16af79b14cec5e365dd43cc280356cd9fe1bd9af10db2f81fc69ddabd337cab48a960731c9d5a9cde0d4fba8ed1cdf57356d9603b6a959edb67e76 WHIRLPOOL 54ba799fe5f5768762595b89fd1ea4d009edc4516365c6bc8287dea860b4d450b57a5b69e3585db47d3e7b6ad32d08615f53f0e0365f706334ed1678c897861f
+MISC ChangeLog 897 SHA256 8294a290203448f900849de62e63c76b7dbb156b4f7e8515236615ddc1563a03 SHA512 32d4e758dfdebd9b0641117e943f638f1068eebcdbd80ff5c1024205f5ae95c0356e825ec89ea087e3b9ffc3cb0991e7b4eee54f5d2a6715d1470f88b0741b40 WHIRLPOOL 0b9248ea794466e598293a0035df5dd96bb41c2300dd050d6d1100d565d2e19583ded5766a40ee02cc8cd717d94e67b126e988ebe0c6a773111a5242e20eb35f
+MISC metadata.xml 789 SHA256 0383e35dc373a0c7f4cea80787481ad95790be959eae2e685ab1eae275464141 SHA512 e5790a5b54ca33ce53646382ff667656e0a843494cac2a6fbd3f11cc45b711b8dd656df1c16921484b186bf80708179602630d9aae4382587a19fe5b5270d77b WHIRLPOOL f4883d618b4e1d6de0acd756b8e5d402f3cca806a30836797b2928a2bbe38015dd6b3eaaae4bd17a16cacc781924df7cb230c1725bad0a0c2942b8ec78999ff8
diff --git a/dev-util/bazel/bazel-0.4.5-r1.ebuild b/dev-util/bazel/bazel-0.4.5-r1.ebuild
new file mode 100644
index 000000000000..d3b75d558a98
--- /dev/null
+++ b/dev-util/bazel/bazel-0.4.5-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1 java-pkg-2
+
+DESCRIPTION="Fast and correct automated build system"
+HOMEPAGE="http://bazel.io/"
+SRC_URI="https://github.com/bazelbuild/bazel/releases/download/${PV}/${P}-dist.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples tools zsh-completion"
+# strip corrupts the bazel binary
+RESTRICT="strip"
+RDEPEND="virtual/jdk:1.8"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ app-arch/zip"
+
+S="${WORKDIR}"
+
+pkg_setup() {
+ echo ${PATH} | grep -q ccache && \
+ ewarn "${PN} usually fails to compile with ccache, you have been warned"
+ java-pkg-2_pkg_setup
+}
+
+src_compile() {
+ VERBOSE=yes ./compile.sh || die
+ # Use standalone strategy to deactivate the bazel sandbox, since it
+ # conflicts with FEATURES=sandbox.
+ echo "build --verbose_failures --spawn_strategy=standalone --genrule_strategy=standalone" \
+ > "${T}/bazelrc" || die
+ output/bazel --bazelrc="${T}/bazelrc" build scripts:bazel-complete.bash || die
+ mv bazel-bin/scripts/bazel-complete.bash output/ || die
+}
+
+src_test() {
+ output/bazel test \
+ --verbose_failures \
+ --spawn_strategy=standalone \
+ --genrule_strategy=standalone \
+ --verbose_test_summary \
+ examples/cpp:hello-success_test || die
+}
+
+src_install() {
+ output/bazel shutdown
+ dobin output/bazel
+ newbashcomp output/bazel-complete.bash ${PN}
+ if use zsh-completion ; then
+ insinto /usr/share/zsh/site-functions
+ doins scripts/zsh_completion/_bazel
+ fi
+ if use examples; then
+ docinto examples
+ dodoc -r examples/*
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ # could really build tools but I don't know which ones
+ # are actually used
+ if use tools; then
+ docinto tools
+ dodoc -r tools/*
+ docompress -x /usr/share/doc/${PF}/tools
+ fi
+}
diff --git a/dev-util/bazel/bazel-0.5.2.ebuild b/dev-util/bazel/bazel-0.5.2.ebuild
new file mode 100644
index 000000000000..4684dc2d3b48
--- /dev/null
+++ b/dev-util/bazel/bazel-0.5.2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1 java-pkg-2
+
+DESCRIPTION="Fast and correct automated build system"
+HOMEPAGE="http://bazel.io/"
+SRC_URI="https://github.com/bazelbuild/bazel/releases/download/${PV}/${P}-dist.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples tools zsh-completion"
+# strip corrupts the bazel binary
+RESTRICT="strip"
+RDEPEND="virtual/jdk:1.8"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ app-arch/zip"
+
+S="${WORKDIR}"
+
+pkg_setup() {
+ echo ${PATH} | grep -q ccache && \
+ ewarn "${PN} usually fails to compile with ccache, you have been warned"
+ java-pkg-2_pkg_setup
+}
+
+src_compile() {
+ # F: fopen_wr
+ # S: deny
+ # P: /proc/self/setgroups
+ # A: /proc/self/setgroups
+ # R: /proc/24939/setgroups
+ # C: /usr/lib/systemd/systemd
+ addpredict /proc
+ VERBOSE=yes ./compile.sh || die
+ # Use standalone strategy to deactivate the bazel sandbox, since it
+ # conflicts with FEATURES=sandbox.
+ echo "build --verbose_failures --spawn_strategy=standalone --genrule_strategy=standalone" \
+ > "${T}/bazelrc" || die
+ output/bazel --bazelrc="${T}/bazelrc" build scripts:bazel-complete.bash || die
+ mv bazel-bin/scripts/bazel-complete.bash output/ || die
+}
+
+src_test() {
+ output/bazel test \
+ --verbose_failures \
+ --spawn_strategy=standalone \
+ --genrule_strategy=standalone \
+ --verbose_test_summary \
+ examples/cpp:hello-success_test || die
+}
+
+src_install() {
+ output/bazel shutdown
+ dobin output/bazel
+ newbashcomp output/bazel-complete.bash ${PN}
+ if use zsh-completion ; then
+ insinto /usr/share/zsh/site-functions
+ doins scripts/zsh_completion/_bazel
+ fi
+ if use examples; then
+ docinto examples
+ dodoc -r examples/*
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ # could really build tools but I don't know which ones
+ # are actually used
+ if use tools; then
+ docinto tools
+ dodoc -r tools/*
+ docompress -x /usr/share/doc/${PF}/tools
+ fi
+}
diff --git a/dev-util/bazel/metadata.xml b/dev-util/bazel/metadata.xml
new file mode 100644
index 000000000000..518e125be253
--- /dev/null
+++ b/dev-util/bazel/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>bicatali@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">bazelbuild/bazel</remote-id>
+ </upstream>
+ <longdescription>
+ Bazel is Google's own build tool. Bazel has built-in support for
+ building both client and server software, including client
+ applications for both Android and iOS platforms. It also provides
+ an extensible framework that you can use to develop your own build
+ rules.
+ </longdescription>
+ <use>
+ <flag name="tools">Install extra bazel tools to build from sources</flag>
+ </use>
+</pkgmetadata>