summaryrefslogtreecommitdiff
path: root/dev-util/bazel/bazel-0.7.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-22 14:00:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-22 14:00:47 +0100
commit91c0ec2d7067f6ab1ef578bd9967b32ca07eb502 (patch)
treef4c7f54d0aeb344c21de9b9d1a3f1e9826d7a64c /dev-util/bazel/bazel-0.7.0.ebuild
parent2bacbb3374587799c77a999f56352233a353b19e (diff)
gentoo resync : 22.05.2018
Diffstat (limited to 'dev-util/bazel/bazel-0.7.0.ebuild')
-rw-r--r--dev-util/bazel/bazel-0.7.0.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-util/bazel/bazel-0.7.0.ebuild b/dev-util/bazel/bazel-0.7.0.ebuild
index 4684dc2d3b48..0a5efcceeb51 100644
--- a/dev-util/bazel/bazel-0.7.0.ebuild
+++ b/dev-util/bazel/bazel-0.7.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit bash-completion-r1 java-pkg-2
+inherit bash-completion-r1 java-pkg-2 multiprocessing
DESCRIPTION="Fast and correct automated build system"
HOMEPAGE="http://bazel.io/"
@@ -36,11 +36,12 @@ src_compile() {
# R: /proc/24939/setgroups
# C: /usr/lib/systemd/systemd
addpredict /proc
+ export EXTRA_BAZEL_ARGS="--jobs=$(makeopts_jobs)"
VERBOSE=yes ./compile.sh || die
# Use standalone strategy to deactivate the bazel sandbox, since it
# conflicts with FEATURES=sandbox.
echo "build --verbose_failures --spawn_strategy=standalone --genrule_strategy=standalone" \
- > "${T}/bazelrc" || die
+ "--jobs=$(makeopts_jobs)" > "${T}/bazelrc" || die
output/bazel --bazelrc="${T}/bazelrc" build scripts:bazel-complete.bash || die
mv bazel-bin/scripts/bazel-complete.bash output/ || die
}