summaryrefslogtreecommitdiff
path: root/dev-util/bats
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/bats
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/bats')
-rw-r--r--dev-util/bats/Manifest5
-rw-r--r--dev-util/bats/bats-0.4.0.ebuild23
-rw-r--r--dev-util/bats/bats-0.4.0_p20170219.ebuild29
-rw-r--r--dev-util/bats/metadata.xml25
4 files changed, 82 insertions, 0 deletions
diff --git a/dev-util/bats/Manifest b/dev-util/bats/Manifest
new file mode 100644
index 000000000000..87f0d332e1be
--- /dev/null
+++ b/dev-util/bats/Manifest
@@ -0,0 +1,5 @@
+DIST bats-0.4.0.tar.gz 17258 BLAKE2B e43b29a413194e697c25a3f1dd3dc72a23ab9444e48bbe04434f8d6d48ff754ef1c12a1e1ab936bed8389b8fe970799cca13be932f1852c643a529babdb43420 SHA512 83c6c0e3ceec149708a8db5d33e95cc84852d8189498c22131c00f4288a6c870f9d522bae9230157f442338dc101e1468451d78dfa274afb83a6f0dd614c8bdb
+DIST bats-0.4.0_p20170219.tar.gz 18776 BLAKE2B 994649547424ee2e0859e7a82f9d46266645c6fc5cc3f47313d8780c3f81755b77d0109ad397c77381d04ba30708536acdacd0f158dc000cca9df23e25558653 SHA512 dc0e185b09dab5cc026ec39a2b15485751f038a6bab2e1089e55ea7e2913c0b99262edb54014300a25e0e3b6cad7ca61b4068f6ab328adaa61878dbb8efdf450
+EBUILD bats-0.4.0.ebuild 485 BLAKE2B ef5b83cc2119b9fc9d96b3a3e7bc465fa8ba6d73892a7d63f6f7de531f96c489e3f7692ac0142ba9dabd0f2871004de956032a8809453434fc1f5d26b67dc920 SHA512 48856743881d5bec9e275531d2d50897e3d31401d5f4e189a7f9b62f8fde45b108791f50ae4f6c9a9e3f129cad83c391ba220bd359527e1851ab6a97664e43ef
+EBUILD bats-0.4.0_p20170219.ebuild 658 BLAKE2B 5ca6fe1c1822722ccca8687173d7555539b319c78aecf89869d8266479b5cdeaad97bd1dcda6b677b68d01449174c23e99abf24e584b141c879258d5f85691fa SHA512 92ff0bb55481e30b5c770430681a29dfee5d5db2e56d8c88a4edf2f60e010949034c023b49e3898bd9f728eb6915ae141992b9c3ba7aae91bc5a479ce01dda36
+MISC metadata.xml 896 BLAKE2B bde071263574d67573e1ff65d1be19ce34a7a91ba8fea97300a296ed163e08ff7693d126cab84109a3669683ce8a4880b0b7d64ff2827d8bce9b3c6ad89c7945 SHA512 da70a0d89d4b892128e2ce7544d2a1db3b11fbd47c17aca53b220af2d3f46c77e99abb02fdfb814bc5010f2a54cd91841ed60b894b3655d0b910b303fa75a482
diff --git a/dev-util/bats/bats-0.4.0.ebuild b/dev-util/bats/bats-0.4.0.ebuild
new file mode 100644
index 000000000000..0af7a00bf20f
--- /dev/null
+++ b/dev-util/bats/bats-0.4.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="An automated testing system for bash"
+HOMEPAGE="https://github.com/sstephenson/bats/"
+SRC_URI="https://github.com/sstephenson/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_test() {
+ bin/bats --tap test || die "Tests failed"
+}
+
+src_install() {
+ einstalldocs
+
+ dobin libexec/*
+ doman man/bats.1 man/bats.7
+}
diff --git a/dev-util/bats/bats-0.4.0_p20170219.ebuild b/dev-util/bats/bats-0.4.0_p20170219.ebuild
new file mode 100644
index 000000000000..8bff3f4e87f1
--- /dev/null
+++ b/dev-util/bats/bats-0.4.0_p20170219.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+COMMITHASH="03608115df2071fff4eaaff1605768c275e5f81f"
+
+DESCRIPTION="An automated testing system for bash"
+HOMEPAGE="https://github.com/sstephenson/bats/"
+SRC_URI="https://github.com/sstephenson/bats/archive/${COMMITHASH}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+S="${WORKDIR}/bats-${COMMITHASH}"
+
+src_test() {
+ bin/bats --tap test || die "Tests failed"
+}
+
+src_install() {
+ exeinto /usr/libexec/bats
+ doexe libexec/*
+ dosym ../libexec/bats/bats /usr/bin/bats
+
+ dodoc README.md
+ doman man/bats.1 man/bats.7
+}
diff --git a/dev-util/bats/metadata.xml b/dev-util/bats/metadata.xml
new file mode 100644
index 000000000000..b8f6a46a9071
--- /dev/null
+++ b/dev-util/bats/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>nelo@wallus.de</email>
+ <name>Nelo-Thara Wallus</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>polynomial-c@gentoo.org</email>
+ <name>Lars Wendler</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">sstephenson/bats</remote-id>
+ </upstream>
+ <longdescription lang="en">
+ Bats is a TAP-compliant testing framework for Bash. It provides a simple
+ way to verify that the UNIX programs you write behave as expected.
+
+ A Bats test file is a Bash script with special syntax for defining test
+ cases. Under the hood, each test case is just a function with a description.
+
+ Bats is most useful when testing software written in Bash, but you can use
+ it to test any UNIX program.
+ </longdescription>
+</pkgmetadata>