summaryrefslogtreecommitdiff
path: root/dev-util/bats/bats-1.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-util/bats/bats-1.2.1.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-util/bats/bats-1.2.1.ebuild')
-rw-r--r--dev-util/bats/bats-1.2.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-util/bats/bats-1.2.1.ebuild b/dev-util/bats/bats-1.2.1.ebuild
new file mode 100644
index 000000000000..0ab0773b5e99
--- /dev/null
+++ b/dev-util/bats/bats-1.2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="bats-core"
+DESCRIPTION="Bats-core: Bash Automated Testing System"
+HOMEPAGE="https://github.com/bats-core/bats-core/"
+SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+
+DEPEND="app-shells/bash:*"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_test() {
+ bin/bats --formatter tap test || die "Tests failed"
+}
+
+src_install() {
+ exeinto /usr/libexec/${MY_PN}
+ doexe libexec/${MY_PN}/*
+ exeinto /usr/lib/${MY_PN}
+ doexe lib/${MY_PN}/*
+ dobin bin/${PN}
+
+ dodoc README.md
+ doman man/${PN}.1 man/${PN}.7
+}