summaryrefslogtreecommitdiff
path: root/dev-util/babeltrace
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-util/babeltrace
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-util/babeltrace')
-rw-r--r--dev-util/babeltrace/Manifest3
-rw-r--r--dev-util/babeltrace/babeltrace-1.5.8.ebuild19
-rw-r--r--dev-util/babeltrace/files/babeltrace-1.5.8-slibtool.patch119
3 files changed, 137 insertions, 4 deletions
diff --git a/dev-util/babeltrace/Manifest b/dev-util/babeltrace/Manifest
index c03a9c0c80b6..e02c523b236f 100644
--- a/dev-util/babeltrace/Manifest
+++ b/dev-util/babeltrace/Manifest
@@ -1,3 +1,4 @@
+AUX babeltrace-1.5.8-slibtool.patch 4148 BLAKE2B e086dd6aee512a0d2cd3db63a33275dcabb129def9bbaff6cd1b081bed3dc7fcc99d3f645fe009f55db72b72e86b420c9c12757544f85bfe253b55e7940f4c81 SHA512 3a43c19309297838752181c1c4f1957b7fe93900e932410dc237c8d11b4cfa7a5044826e2f60e192dbfeb1fee46185508ed2fa093d62a200dd86ffd78e24a553
DIST babeltrace-1.5.8.tar.bz2 992610 BLAKE2B 3d47f9ba40b406271a0b35e441968718c93e8744f95b56f79acf8359001ebffb4966931f2860d48ced4f0d98261b37156564a0d798bf8d9e0ed465c05355cc5d SHA512 827749ae8507efd433bb97ef668628837a3ff15b5be5097af5621d46055c6f10401da0be1f9d9f843a96c8c307b33745e04284d166e275e03b7ddb0a7dd57e96
-EBUILD babeltrace-1.5.8.ebuild 687 BLAKE2B cf7474300f099faa5072a69dc4b014bf24d63f1f59d8cb0ab615ff18a0c29b392f5b45153ab3cfe0ae13157bd6d534f1d34e986743436d7b0c82a44117df1396 SHA512 1cb2e5ab371d11067e658f4ba6e7611411a642b787483c4d2e9224fb20e3608c9a1bab49ed9ff3f88de9d9618d417866fb90b8d7505438c0c7ee0296beb9df73
+EBUILD babeltrace-1.5.8.ebuild 795 BLAKE2B ed86a7ec023ed5553b60359ed1d547c34711607d300fee95e1028c40117b31c9d92b81aad019f22c7a8c30a9ec96b9c88748b60e58fd053e2d25346d11391262 SHA512 b99ee491b62e70be6c93e92e2cf7d1f777912815cb19b002df70909168e3402d1e2eb69af2e25c01778a58b982b3e04b6e4509735d1a0c1d1a966c7381a2713e
MISC metadata.xml 464 BLAKE2B d4bef73cb09891c097caa7406df51a41fc2a32c8c5e88309858a41aaaeb863c41ccf1329f5915ad08831fdea621edcb2bfa6ea1b9a9af5d333364edf43607c9d SHA512 399d6e2343ef12310a982b17a2a9e45543b023da54aac23f077b9999358e280e186937aac6753b53b6830be991a0ed6c6bc349841f135e7675b1f546931cb77d
diff --git a/dev-util/babeltrace/babeltrace-1.5.8.ebuild b/dev-util/babeltrace/babeltrace-1.5.8.ebuild
index 73c74b6ae152..35e3b9f18b6a 100644
--- a/dev-util/babeltrace/babeltrace-1.5.8.ebuild
+++ b/dev-util/babeltrace/babeltrace-1.5.8.ebuild
@@ -1,7 +1,9 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+inherit autotools
DESCRIPTION="A command-line tool and library to read and convert trace files"
HOMEPAGE="https://babeltrace.org/"
@@ -17,12 +19,23 @@ RDEPEND="dev-libs/glib:2
dev-libs/popt
dev-libs/elfutils
sys-apps/util-linux
- "
+"
DEPEND="${RDEPEND}
sys-devel/bison
sys-devel/flex
- "
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-slibtool.patch"
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
src_configure() {
econf $(use_enable test glibtest) \
--enable-debug-info
diff --git a/dev-util/babeltrace/files/babeltrace-1.5.8-slibtool.patch b/dev-util/babeltrace/files/babeltrace-1.5.8-slibtool.patch
new file mode 100644
index 000000000000..39572985b94e
--- /dev/null
+++ b/dev-util/babeltrace/files/babeltrace-1.5.8-slibtool.patch
@@ -0,0 +1,119 @@
+From 2780bd0b908b4021bcd2a12a56094deb7861c3fc Mon Sep 17 00:00:00 2001
+From: orbea <orbea@riseup.net>
+Date: Sat, 7 May 2022 20:31:24 -0700
+Subject: [PATCH] Fix the build with slibtool
+
+gentoo bug: https://bugs.gentoo.org/777444
+---
+ formats/ctf-text/Makefile.am | 4 +---
+ formats/ctf-text/types/Makefile.am | 3 +--
+ formats/ctf/Makefile.am | 1 -
+ formats/ctf/ir/Makefile.am | 3 +--
+ formats/ctf/metadata/Makefile.am | 2 +-
+ formats/ctf/types/Makefile.am | 3 +--
+ formats/ctf/writer/Makefile.am | 3 +--
+ lib/Makefile.am | 4 +---
+ 8 files changed, 7 insertions(+), 16 deletions(-)
+
+diff --git a/formats/ctf-text/Makefile.am b/formats/ctf-text/Makefile.am
+index d773c8157..f2f6b22e3 100644
+--- a/formats/ctf-text/Makefile.am
++++ b/formats/ctf-text/Makefile.am
+@@ -12,9 +12,7 @@ libbabeltrace_ctf_text_la_LDFLAGS = \
+ $(LD_NO_AS_NEEDED) -version-info $(BABELTRACE_LIBRARY_VERSION) \
+ types/libctf-text-types.la
+
+-libbabeltrace_ctf_text_la_LIBADD = \
+- $(top_builddir)/lib/libbabeltrace.la \
+- $(top_builddir)/formats/ctf/libbabeltrace-ctf.la
++libbabeltrace_ctf_text_la_LIBADD =
+
+ if ENABLE_DEBUG_INFO
+ libbabeltrace_ctf_text_la_LIBADD += $(top_builddir)/lib/libdebug-info.la
+diff --git a/formats/ctf-text/types/Makefile.am b/formats/ctf-text/types/Makefile.am
+index 576d29d7d..596a6a859 100644
+--- a/formats/ctf-text/types/Makefile.am
++++ b/formats/ctf-text/types/Makefile.am
+@@ -14,5 +14,4 @@ libctf_text_types_la_SOURCES = \
+
+ libctf_text_types_la_LDFLAGS = $(LT_NO_UNDEFINED)
+
+-libctf_text_types_la_LIBADD = \
+- $(top_builddir)/lib/libbabeltrace.la
++libctf_text_types_la_LIBADD =
+diff --git a/formats/ctf/Makefile.am b/formats/ctf/Makefile.am
+index 23ae0b93c..65de7cf87 100644
+--- a/formats/ctf/Makefile.am
++++ b/formats/ctf/Makefile.am
+@@ -17,7 +17,6 @@ libbabeltrace_ctf_la_LDFLAGS = \
+ $(LD_NO_AS_NEEDED) -version-info $(BABELTRACE_LIBRARY_VERSION)
+
+ libbabeltrace_ctf_la_LIBADD = \
+- $(top_builddir)/lib/libbabeltrace.la \
+ types/libctf-types.la \
+ metadata/libctf-parser.la \
+ metadata/libctf-ast.la \
+diff --git a/formats/ctf/ir/Makefile.am b/formats/ctf/ir/Makefile.am
+index 6f5b06e4d..3af40cfc1 100644
+--- a/formats/ctf/ir/Makefile.am
++++ b/formats/ctf/ir/Makefile.am
+@@ -22,8 +22,7 @@ libctf_ir_la_SOURCES = \
+
+ libctf_ir_la_LDFLAGS = $(LT_NO_UNDEFINED)
+
+-libctf_ir_la_LIBADD = \
+- $(top_builddir)/lib/libbabeltrace.la
++libctf_ir_la_LIBADD =
+
+ if BABELTRACE_BUILD_WITH_LIBUUID
+ libctf_ir_la_LIBADD += -luuid
+diff --git a/formats/ctf/metadata/Makefile.am b/formats/ctf/metadata/Makefile.am
+index 573f94d31..a181e784c 100644
+--- a/formats/ctf/metadata/Makefile.am
++++ b/formats/ctf/metadata/Makefile.am
+@@ -24,7 +24,7 @@ libctf_ast_la_SOURCES = ctf-visitor-xml.c \
+ ctf-visitor-semantic-validator.c \
+ ctf-visitor-generate-io-struct.c
+ libctf_ast_la_LIBADD = \
+- $(top_builddir)/lib/libbabeltrace.la
++ $(top_builddir)/types/libbabeltrace_types.la
+ libctf_ast_la_LDFLAGS = $(LT_NO_UNDEFINED)
+
+ if BABELTRACE_BUILD_WITH_LIBUUID
+diff --git a/formats/ctf/types/Makefile.am b/formats/ctf/types/Makefile.am
+index a1bcfb2fe..9ae105868 100644
+--- a/formats/ctf/types/Makefile.am
++++ b/formats/ctf/types/Makefile.am
+@@ -14,5 +14,4 @@ libctf_types_la_SOURCES = \
+
+ libctf_types_la_LDFLAGS = $(LT_NO_UNDEFINED)
+
+-libctf_types_la_LIBADD = \
+- $(top_builddir)/lib/libbabeltrace.la
++libctf_types_la_LIBADD =
+diff --git a/formats/ctf/writer/Makefile.am b/formats/ctf/writer/Makefile.am
+index e328084be..ab27b0742 100644
+--- a/formats/ctf/writer/Makefile.am
++++ b/formats/ctf/writer/Makefile.am
+@@ -6,8 +6,7 @@ libctf_writer_la_SOURCES = \
+ writer.c \
+ functor.c
+
+-libctf_writer_la_LIBADD = \
+- $(top_builddir)/lib/libbabeltrace.la
++libctf_writer_la_LIBADD =
+
+ libctf_writer_la_LDFLAGS = $(LT_NO_UNDEFINED)
+
+diff --git a/lib/Makefile.am b/lib/Makefile.am
+index 48620e8fd..e4748cadc 100644
+--- a/lib/Makefile.am
++++ b/lib/Makefile.am
+@@ -28,6 +28,4 @@ libdebug_info_la_LIBADD = libbabeltrace.la
+ endif
+
+ libbabeltrace_la_LIBADD = \
+- prio_heap/libprio_heap.la \
+- $(top_builddir)/types/libbabeltrace_types.la \
+- $(top_builddir)/compat/libcompat.la
++ prio_heap/libprio_heap.la