summaryrefslogtreecommitdiff
path: root/dev-util/b2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-11 19:06:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-11 19:06:53 +0000
commit427aed27427f356a75db3288d7b96ce7e2a044b2 (patch)
tree259ea4d9db267c160cbae0bdd575dcd349d23d8b /dev-util/b2
parenteb72a69c0109ff53b8c18b2f6c3b160489376e2e (diff)
gentoo auto-resync : 11:01:2024 - 19:06:52
Diffstat (limited to 'dev-util/b2')
-rw-r--r--dev-util/b2/Manifest2
-rw-r--r--dev-util/b2/b2-5.0.0.ebuild72
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-util/b2/Manifest b/dev-util/b2/Manifest
index b6be4281b32d..8028044c4911 100644
--- a/dev-util/b2/Manifest
+++ b/dev-util/b2/Manifest
@@ -5,5 +5,7 @@ AUX b2-4.9.2-no-implicit-march-flags.patch 8376 BLAKE2B 50e0b8effbb268467d90cc51
AUX b2-4.9.2-odr.patch 1109 BLAKE2B 0bf70f2b2237369acd5089d1d1c6e1362f1d3528b036a7f7b9c5c4d077e60850f45c87a67c830f441297e09be2f7dd8bf41ea45a2c66b307678404c4a0db0ed5 SHA512 90ca58661322b35c4af6543558015368385a1b0e12740cd76723d893f95411645ec4a3a23694503863dd786b73a0ec9b0cb34b473e357334d8e82d973f800e4b
AUX site-config.jam 688 BLAKE2B e43a7ad1a94d113a7f890e8b634770f5c60556101d428d83f655bbbe72c46b587485886a9941d05a2ae4319fc325f1e0ecfb9b660158b81c5e9fd02e0b1c0530 SHA512 b65bf1be3133f9f66d3139b00f195a288591bb20a13ba35041507c2c33d7d2da6047c3b02dc27bc4eb21798b91e1262a60e294b7fd4af90808b9de0f5af517df
DIST b2-4.10.1.tar.gz 982429 BLAKE2B bb1e6ef741ca10d3b0029e64d69a7ee7eb0d40d26c68d2a3932d4210e8e2a83131c9bac2d54f2885373725d58fe73dd7fa7aebfc5781059f01c3462c738d426c SHA512 0bc4897a342685190626a6593926c4b200c5ca9b498ba77287a7c49467a8e3f65cb850b9616fd05d4aea9ebfab32ec46792d7d8226bed89911a711ce14ecce30
+DIST b2-5.0.0.tar.gz 1015818 BLAKE2B 87b6f34733002479f91f658aee4f776930ae6441f33b2540b82049e18c4199280e73047afafa90dc156cc75db8b587c5bb9e2ce65d93c493775ac4107ce3201b SHA512 37403f0bd863753c5313393405dd8514a4f8d9f0839ccd397ee1856e02af6116bd238d345e5b766512441ca1c0b09883386588e270bd982eca45235eef1b01b7
EBUILD b2-4.10.1.ebuild 1916 BLAKE2B a44e6b760572a4263a227d52b18f6e3395e7525254fe82a86f6a7e08a24a59b5f7c8d5b23b5d4a1a9f9d7bf088ba79d7bd822de8183eeec4e0acfc08edf23677 SHA512 eac4b27ab24abfd0845d51f2dc043ec3bc3df7b0480e048c0eb7ef4f0e389b9984123f9867b45ce66ba55b7fbe85e50d4e1db3beaec4e38b406c9edc669b0028
+EBUILD b2-5.0.0.ebuild 1967 BLAKE2B 50870cad043adccccf37779a3503559b4a6be57a71e2e857be2ae2c9ce597471156e37989c395540cb36bff9fb19af8e1494f9be3b59e3ca9da71517734a0583 SHA512 73a50407df672b50894653bec1cc091a93e9593301ea4be19ff8cd45d95966885c6e30e9f6b0aa5554d19101fb5728b786abda6b0ba42d17586f6ea8ed6172a4
MISC metadata.xml 320 BLAKE2B e32bcf6d7bfe5e8a0f36d34022d49ef8baf1d4c0324fa7e7b25e1fa41ac81c21e010a8e49d456b7ce6027c51af57b6b07f3bdc8b7e05daa18b288c63a58a171e SHA512 767da992cd650d91b393848e73d6f0626febcb02eba350a16d390e8416a2832c49b1ca2608be98a9f4abd9ae2078a7f1a543a387be139e5533f90d82171796bf
diff --git a/dev-util/b2/b2-5.0.0.ebuild b/dev-util/b2/b2-5.0.0.ebuild
new file mode 100644
index 000000000000..6cff0eca434e
--- /dev/null
+++ b/dev-util/b2/b2-5.0.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo flag-o-matic toolchain-funcs
+
+MY_PV="$(ver_rs 1- _)"
+
+DESCRIPTION="A system for large project software construction, simple to use and powerful"
+HOMEPAGE="https://www.bfgroup.xyz/b2/"
+SRC_URI="https://github.com/bfgroup/b2/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P}/src"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="examples"
+RESTRICT="test"
+
+RDEPEND="!dev-util/boost-build"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.9.2-disable_python_rpath.patch
+ "${FILESDIR}"/${PN}-4.9.2-darwin-gentoo-toolchain.patch
+ "${FILESDIR}"/${PN}-4.9.2-add-none-feature-options.patch
+ "${FILESDIR}"/${PN}-4.9.2-no-implicit-march-flags.patch
+)
+
+src_configure() {
+ # need to enable LFS explicitly for 64-bit offsets on 32-bit hosts (#761100)
+ append-lfs-flags
+}
+
+src_compile() {
+ cd engine || die
+
+ # don't call windres since it leads to broken relocations
+ export B2_DONT_EMBED_MANIFEST=1
+
+ # upstream doesn't want separate flags for CPPFLAGS/LDFLAGS
+ # https://github.com/bfgroup/b2/pull/187#issuecomment-1335688424
+ edo ${CONFIG_SHELL:-${BASH}} ./build.sh cxx \
+ --cxx="$(tc-getCXX)" \
+ --cxxflags="${CXXFLAGS} ${CPPFLAGS} ${LDFLAGS}" \
+ -d+2 \
+ --without-python
+}
+
+src_test() {
+ # Forget tests, b2 is a lost cause
+ :
+}
+
+src_install() {
+ dobin engine/b2
+
+ insinto /usr/share/b2/src
+ doins -r "${FILESDIR}/site-config.jam" \
+ build-system.jam ../example/user-config.jam \
+ build contrib options tools util
+
+ find "${ED}"/usr/share/b2/src -iname '*.py' -delete || die
+
+ dodoc ../notes/{changes,release_procedure,build_dir_option,relative_source_paths}.txt
+
+ if use examples; then
+ docinto examples
+ dodoc -r ../example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}