summaryrefslogtreecommitdiff
path: root/dev-util/astyle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-20 01:14:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-20 01:14:49 +0100
commitbc4457d8e0e53a2e43c4254d08053ba9708663e1 (patch)
tree4f8809f23d683eed73ef800d99ce7aa628a82527 /dev-util/astyle
parent5f593f75391c28294f0dffa4dd1df280a4d8df73 (diff)
gentoo auto-resync : 20:06:2023 - 01:14:49
Diffstat (limited to 'dev-util/astyle')
-rw-r--r--dev-util/astyle/Manifest2
-rw-r--r--dev-util/astyle/astyle-3.4.ebuild77
2 files changed, 79 insertions, 0 deletions
diff --git a/dev-util/astyle/Manifest b/dev-util/astyle/Manifest
index 6038ec7a3420..7fe686303081 100644
--- a/dev-util/astyle/Manifest
+++ b/dev-util/astyle/Manifest
@@ -1,3 +1,5 @@
+DIST astyle-3.4.tar.bz2 226981 BLAKE2B 1d3db58a7123e516657f224c217ac300fc9d75a50c3ed5cddf8d51868e251397c45ffb43dac9a9f414eaf47896171002bd5eb857ffe4336153fb1bddff3d7eb7 SHA512 c81fb18a8ebba89500639377291d320107983ebc842fa99973d00efa08c41950ffac7fe78faddb3d025b30eae58ccf8d643582965c1a3df2604f0a0240fd8e82
DIST astyle_3.1_linux.tar.gz 185589 BLAKE2B d0bc9bf3403de89d207f33ac885c7cd57fd1e71314c947e1593ee24ade9ce36c83c6fd8e7021f44d8d3b344ea3add63fa5a7b246c40f10193dc38b51e7ad36bc SHA512 2e8f13d291abda66bbba30174c364c81a81a490e0a21376f7da7cf471644c22caa37b9eefb100d093bf26d1a8bfa9d2f14b4c2a9b75b3cb84428b4514e277ff2
EBUILD astyle-3.1-r2.ebuild 1891 BLAKE2B fea27eafaf14eaf1245a87a873dbfa327a23987468a291a9bf8de1af50d57f168143ae94b6dfb8dadfdf121ee3fc13f6efd90656962bd866093e27c2477544be SHA512 ecab4c77e646ee8dd2f174e50e8b5c3af9a077b1c1ddfac4ab05ec56e1b83e82ff7f8053d3f52454c282a9f545a470ba2caa2f1786956a26514b6f0adb988fe7
+EBUILD astyle-3.4.ebuild 1857 BLAKE2B 86499c77af050c94a5d3459a9fe9a4a468b8b92deadea4703eb918cdf263ab0c4653fcc9ad870666fe63fbb3b4f4bc7e30510466f9a94acb026544010dc39927 SHA512 7ea107261645e5530516ebc4738ccc89d8b58615a90d8eff1cce75757fed7331796c746aeb5b688110e0ae402bad46ae505500bd355691bac269734a289097e2
MISC metadata.xml 754 BLAKE2B c034556afe246a6d75d57b2e37399bdd24a37046a1bf0181757ed449f144f099964e7cdf470502f83542707094c752de3841d92bf2844fa7ee0b6038d25494f2 SHA512 0e4087bab09255528dfce61e21b12a4a05b93d3eaf75874b2a2b12f168046c0e9e040c29321766cfd505bdc5360eb6d16d320a73b317849d19b2555a95415396
diff --git a/dev-util/astyle/astyle-3.4.ebuild b/dev-util/astyle/astyle-3.4.ebuild
new file mode 100644
index 000000000000..729799088abb
--- /dev/null
+++ b/dev-util/astyle/astyle-3.4.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs java-pkg-opt-2
+
+DESCRIPTION="Artistic Style is a re-indenter and reformatter for C++, C and Java source code"
+HOMEPAGE="https://astyle.sourceforge.net/"
+SRC_URI="mirror://sourceforge/astyle/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0/3.2"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="examples java static-libs"
+
+DEPEND="
+ app-arch/xz-utils
+ java? ( >=virtual/jdk-1.6:= )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ if use java ; then
+ java-pkg-opt-2_src_prepare
+ sed -e "s:^\(JAVAINCS\s*\)=.*$:\1= $(java-pkg_get-jni-cflags):" \
+ -e "s:ar crs:$(tc-getAR) crs:" \
+ -i build/gcc/Makefile || die
+ else
+ default
+ fi
+}
+
+src_configure() {
+ tc-export CXX
+ default
+}
+
+src_compile() {
+ # ../build/clang/Makefile is identical except for CXX line.
+ emake CXX="$(tc-getCXX)" -f ../build/gcc/Makefile -C src \
+ ${PN} \
+ shared \
+ $(usev java) \
+ $(usev static-libs static)
+}
+
+src_install() {
+ doheader src/${PN}.h
+
+ pushd src/bin >/dev/null || die
+ dobin ${PN}
+
+ local libastylename="lib${PN}.so.${SLOT##*/}.0"
+ local libastylejname="lib${PN}j.so.${SLOT##*/}.0"
+ local libdestdir="/usr/$(get_libdir)"
+
+ dolib.so "${libastylename}"
+ dosym "${libastylename}" "${libdestdir}/lib${PN}.so.$(ver_cut 1 ${SLOT##*/})"
+ dosym "${libastylename}" "${libdestdir}/lib${PN}.so"
+ if use java ; then
+ dolib.so "${libastylejname}"
+ dosym "${libastylejname}" "${libdestdir}/lib${PN}j.so.$(ver_cut 1 ${SLOT##*/})"
+ dosym "${libastylejname}" "${libdestdir}/lib${PN}j.so"
+ fi
+ if use static-libs ; then
+ dolib.a lib${PN}.a
+ fi
+ popd >/dev/null || die
+ if use examples ; then
+ docinto examples
+ dodoc -r file/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ local HTML_DOCS=( doc/. )
+ einstalldocs
+}