summaryrefslogtreecommitdiff
path: root/dev-util/astyle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/astyle
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/astyle')
-rw-r--r--dev-util/astyle/Manifest5
-rw-r--r--dev-util/astyle/astyle-3.0.1-r1.ebuild89
-rw-r--r--dev-util/astyle/astyle-3.1-r2.ebuild89
-rw-r--r--dev-util/astyle/metadata.xml22
4 files changed, 205 insertions, 0 deletions
diff --git a/dev-util/astyle/Manifest b/dev-util/astyle/Manifest
new file mode 100644
index 000000000000..a78fe5316106
--- /dev/null
+++ b/dev-util/astyle/Manifest
@@ -0,0 +1,5 @@
+DIST astyle_3.0.1_linux.tar.gz 172483 BLAKE2B 4c80491cbcc976aa38ff294014df0dc01b39685eafdac6989bea082b1f61120c3985d14ff6db9f76606bbe8da1aaa344c2e0c9c2999a014f5d54384c0420cf97 SHA512 3e8d617c0ec89682bfb076081bb63ae9d44e897de0c85d5109b28adbbfe0620d5dacf59a4bd96ac30a5a4fcb3be136758e9c6fe2c69258b37956c212890a7158
+DIST astyle_3.1_linux.tar.gz 185589 BLAKE2B d0bc9bf3403de89d207f33ac885c7cd57fd1e71314c947e1593ee24ade9ce36c83c6fd8e7021f44d8d3b344ea3add63fa5a7b246c40f10193dc38b51e7ad36bc SHA512 2e8f13d291abda66bbba30174c364c81a81a490e0a21376f7da7cf471644c22caa37b9eefb100d093bf26d1a8bfa9d2f14b4c2a9b75b3cb84428b4514e277ff2
+EBUILD astyle-3.0.1-r1.ebuild 2401 BLAKE2B c27dd1d6b4e886cf68a795563d15d3fc942b62480aeae96116f108ea70dc0c6383a2d4efa5622c2aab03dda4d8ecb8d202eb7fa95c4ada8e2f8229be0f5a98dd SHA512 868aa688a44823004342598fe128af286aa78a071612cecdf335410cf7ccd88ebe91774d3385afd68c29f00fb5d26e95c235f0a2c4afb0650c75b2d802aef67a
+EBUILD astyle-3.1-r2.ebuild 2409 BLAKE2B e3e29396801ed158bf96660d80617ed202b4482e989491ecd31c73605e95f65239a7179498ee73e29f5ed08f371d258bd3a0195ddaa5c2ec4be171af68580bbf SHA512 1682a25a8327cc5bb7fdb0ef23c4341946926b27a119d413f33b0c4c8808520ae5dbb7d24704549c0acf3442d991ea6b4b2d9e17ef56dd1b118efe943db3f52e
+MISC metadata.xml 753 BLAKE2B ddd9b5eb1eaf20f626bdb0b568c856f6e2bb548fff3b6271bd163d6b1f711e66635d2e3fd839c67421f92232a7a8c7343179a4a95e39266dcf44b91bffc0c2c3 SHA512 2896e9eb1f69dfcef21bbc4f622e0ee7e2a88ab882d1ed91623642d4b7ddabb3b9e4e060e1662254e40cd4cdc77f189dc6888dd509ca40633c1f197fb2e4610b
diff --git a/dev-util/astyle/astyle-3.0.1-r1.ebuild b/dev-util/astyle/astyle-3.0.1-r1.ebuild
new file mode 100644
index 000000000000..2d3fd9cf88ce
--- /dev/null
+++ b/dev-util/astyle/astyle-3.0.1-r1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs versionator java-pkg-opt-2
+
+DESCRIPTION="Artistic Style is a re-indenter and reformatter for C++, C and Java source code"
+HOMEPAGE="http://astyle.sourceforge.net/"
+SRC_URI="mirror://sourceforge/astyle/astyle_${PV}_linux.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/3.0"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="examples java static-libs"
+
+DEPEND="app-arch/xz-utils
+ java? ( >=virtual/jdk-1.6:= )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ if use java ; then
+ java-pkg-opt-2_src_prepare
+ sed -e "s:^\(JAVAINCS\s*\)=.*$:\1= $(java-pkg_get-jni-cflags):" \
+ -e "s:ar crs:$(tc-getAR) crs:" \
+ -i build/gcc/Makefile || die
+ else
+ default
+ fi
+}
+
+src_configure() {
+ append-cxxflags -std=c++11
+ tc-export CXX
+ default
+}
+
+src_compile() {
+ # ../build/clang/Makefile is identical except for CXX line.
+ emake CXX="$(tc-getCXX)" -f ../build/gcc/Makefile -C src \
+ ${PN} \
+ shared \
+ $(usev java) \
+ $(usex static-libs static '')
+}
+
+src_install() {
+ doheader src/${PN}.h
+
+ pushd src/bin >/dev/null || die
+ dobin ${PN}
+
+ local libastylename="lib${PN}.so.${PV}"
+ local libastylejname="lib${PN}j.so.${PV}"
+ local libdestdir="${EPREFIX}/usr/$(get_libdir)"
+
+ dolib.so "${libastylename}"
+ dosym "${libastylename}" "${libdestdir}/lib${PN}.so.$(get_major_version)"
+ dosym "${libastylename}" "${libdestdir}/lib${PN}.so"
+ if use java ; then
+ dolib.so "${libastylejname}"
+ dosym "${libastylejname}" "${libdestdir}/lib${PN}j.so.$(get_major_version)"
+ dosym "${libastylejname}" "${libdestdir}/lib${PN}j.so"
+ fi
+ if use static-libs ; then
+ dolib.a lib${PN}.a
+ fi
+ popd >/dev/null || die
+ if use examples ; then
+ docinto examples
+ dodoc -r file/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ local HTML_DOCS=( doc/. )
+ einstalldocs
+}
+
+pkg_postinst() {
+ if [[ -n "$REPLACING_VERSIONS" && "$(get_major_version $REPLACING_VERSIONS)" -lt 3 ]]; then
+ elog "Artistic Style 3.0 introduces new configuration verbiage more fitting"
+ elog "for modern use. Some options that were valid in 2.06 or older are now"
+ elog "deprecated. For more information, consult astyle's release notes at"
+ elog "http://astyle.sourceforge.net/news.html. To view offline, see:"
+ elog
+ elog "${EROOT%/}/usr/share/doc/${P}/html"
+ fi
+}
diff --git a/dev-util/astyle/astyle-3.1-r2.ebuild b/dev-util/astyle/astyle-3.1-r2.ebuild
new file mode 100644
index 000000000000..4394e1defb22
--- /dev/null
+++ b/dev-util/astyle/astyle-3.1-r2.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs versionator java-pkg-opt-2
+
+DESCRIPTION="Artistic Style is a re-indenter and reformatter for C++, C and Java source code"
+HOMEPAGE="http://astyle.sourceforge.net/"
+SRC_URI="mirror://sourceforge/astyle/astyle_${PV}_linux.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/3.1"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="examples java static-libs"
+
+DEPEND="app-arch/xz-utils
+ java? ( >=virtual/jdk-1.6:= )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ if use java ; then
+ java-pkg-opt-2_src_prepare
+ sed -e "s:^\(JAVAINCS\s*\)=.*$:\1= $(java-pkg_get-jni-cflags):" \
+ -e "s:ar crs:$(tc-getAR) crs:" \
+ -i build/gcc/Makefile || die
+ else
+ default
+ fi
+}
+
+src_configure() {
+ append-cxxflags -std=c++11
+ tc-export CXX
+ default
+}
+
+src_compile() {
+ # ../build/clang/Makefile is identical except for CXX line.
+ emake CXX="$(tc-getCXX)" -f ../build/gcc/Makefile -C src \
+ ${PN} \
+ shared \
+ $(usev java) \
+ $(usex static-libs static '')
+}
+
+src_install() {
+ doheader src/${PN}.h
+
+ pushd src/bin >/dev/null || die
+ dobin ${PN}
+
+ local libastylename="lib${PN}.so.${PV}.0"
+ local libastylejname="lib${PN}j.so.${PV}.0"
+ local libdestdir="${EPREFIX}/usr/$(get_libdir)"
+
+ dolib.so "${libastylename}"
+ dosym "${libastylename}" "${libdestdir}/lib${PN}.so.$(get_major_version)"
+ dosym "${libastylename}" "${libdestdir}/lib${PN}.so"
+ if use java ; then
+ dolib.so "${libastylejname}"
+ dosym "${libastylejname}" "${libdestdir}/lib${PN}j.so.$(get_major_version)"
+ dosym "${libastylejname}" "${libdestdir}/lib${PN}j.so"
+ fi
+ if use static-libs ; then
+ dolib.a lib${PN}.a
+ fi
+ popd >/dev/null || die
+ if use examples ; then
+ docinto examples
+ dodoc -r file/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ local HTML_DOCS=( doc/. )
+ einstalldocs
+}
+
+pkg_postinst() {
+ if [[ -n "$REPLACING_VERSIONS" && "$(get_major_version $REPLACING_VERSIONS)" -lt 3 ]]; then
+ elog "Artistic Style 3.0 introduces new configuration verbiage more fitting"
+ elog "for modern use. Some options that were valid in 2.06 or older are now"
+ elog "deprecated. For more information, consult astyle's release notes at"
+ elog "http://astyle.sourceforge.net/news.html. To view offline, see:"
+ elog
+ elog "${EROOT%/}/usr/share/doc/${P}/html"
+ fi
+}
diff --git a/dev-util/astyle/metadata.xml b/dev-util/astyle/metadata.xml
new file mode 100644
index 000000000000..0491ce853e32
--- /dev/null
+++ b/dev-util/astyle/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tamiko@gentoo.org</email>
+ <name>Matthias Maier</name>
+ </maintainer>
+ <longdescription>
+ astyle is a code formatter for C, C++, and Java source code, with many
+ granular formatting options to assist in enforcing code formatting
+ standards in projects.
+ </longdescription>
+ <upstream>
+ <maintainer status="active">
+ <email>jimp03@email.com</email>
+ <name>Jim Pattee</name>
+ </maintainer>
+ <remote-id type="sourceforge">astyle</remote-id>
+ <bugs-to>https://sourceforge.net/p/astyle/bugs/</bugs-to>
+ <doc>http://astyle.sourceforge.net/astyle.html</doc>
+ </upstream>
+</pkgmetadata>