summaryrefslogtreecommitdiff
path: root/dev-util/aruba/aruba-1.1.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-31 20:20:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-31 20:20:25 +0000
commitc4b414ba84991b36b62c066b701385eaf44cdd49 (patch)
tree5cbdb7a51f1abb965fdfe90b686f8130e100afaa /dev-util/aruba/aruba-1.1.2-r1.ebuild
parentea5bad4d0ba1eb937df22adb7f6cc57ea77f03d8 (diff)
gentoo auto-resync : 31:12:2022 - 20:20:25
Diffstat (limited to 'dev-util/aruba/aruba-1.1.2-r1.ebuild')
-rw-r--r--dev-util/aruba/aruba-1.1.2-r1.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/dev-util/aruba/aruba-1.1.2-r1.ebuild b/dev-util/aruba/aruba-1.1.2-r1.ebuild
deleted file mode 100644
index 0d5d922bf2ac..000000000000
--- a/dev-util/aruba/aruba-1.1.2-r1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby26 ruby27"
-
-RUBY_FAKEGEM_RECIPE_TEST="cucumber"
-RUBY_FAKEGEM_RECIPE_DOC="none"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_GEMSPEC="aruba.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Cucumber steps for driving out command line applications"
-HOMEPAGE="https://github.com/cucumber/aruba"
-SRC_URI="https://github.com/cucumber/aruba/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="MIT"
-
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~s390 ~sparc ~x86"
-SLOT="$(ver_cut 1)"
-IUSE=""
-
-DEPEND="${DEPEND} test? ( sys-devel/bc )"
-RDEPEND="${RDEPEND}"
-
-ruby_add_rdepend "
- =dev-ruby/bundler-2*
- >=dev-ruby/childprocess-2.0 <dev-ruby/childprocess-5
- >=dev-ruby/contracts-0.16.0:0 <dev-ruby/contracts-0.18:0
- >=dev-ruby/rspec-expectations-3.4:3
- dev-ruby/thor:1
- >=dev-util/cucumber-2.4 <dev-util/cucumber-7"
-
-ruby_add_bdepend "test? ( dev-ruby/pry dev-ruby/rspec:3 )"
-
-all_ruby_prepare() {
- # Remove bundler-related code.
- sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb || die
- rm Gemfile || die
-
- sed -i -e '/simplecov/I s:^:#:' \
- -e '/Before/,/^end/ s:^:#:' \
- spec/spec_helper.rb features/support/env.rb || die
- rm -f features/support/simplecov_setup.rb || die
-
- sed -e 's:_relative ": "./:' \
- -e 's/git ls-files -z/find * -print0/' \
- -i ${RUBY_FAKEGEM_GEMSPEC} || die
-
- # Avoid features with minor output differences
- sed -i -e '/Use .aruba. with .Minitest./i@wip' features/01_getting_started_with_aruba/supported_testing_frameworks.feature || die
- sed -i -e '/Create files for Minitest/i@wip' features/06_use_aruba_cli/initialize_project_with_aruba.feature || die
-
- # Avoid feature that requires aruba to be installed already
- rm -r features/03_testing_frameworks/cucumber/disable_bundler.feature || die
-}
-
-each_ruby_test() {
- RSPEC_VERSION=3 ruby-ng_rspec
- RUBYLIB="$(pwd)/lib" ruby-ng_cucumber
-}