summaryrefslogtreecommitdiff
path: root/dev-util/android-studio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-07 13:16:39 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-07 13:16:39 +0100
commite91a1aaa5ec8fab37f0fd082ac6024d41c6651e2 (patch)
treeee7587dfd365faadd9b297d595c31368bf94f9ca /dev-util/android-studio
parent2d446203bcf1a0db08e99abca43513d246dfa73d (diff)
gentoo resync : 07.04.2018
Diffstat (limited to 'dev-util/android-studio')
-rw-r--r--dev-util/android-studio/Manifest2
-rw-r--r--dev-util/android-studio/android-studio-3.1.0.16.173.4670197.ebuild108
2 files changed, 110 insertions, 0 deletions
diff --git a/dev-util/android-studio/Manifest b/dev-util/android-studio/Manifest
index ca5e7baef2c4..d54be0032abd 100644
--- a/dev-util/android-studio/Manifest
+++ b/dev-util/android-studio/Manifest
@@ -1,3 +1,5 @@
DIST android-studio-ide-171.4443003-linux.zip 773670325 BLAKE2B b8cff0b85cf20f9d181b4f5c29dc75385539ca2d8e2677211c6c42fcb115616c4208faa5df8cc8a8210c4e9e869d00ae42e7c9dd212756608ff9d4f47bdc8943 SHA512 ba91309c59e4f258222f5b5978bc9ea048476bab4d0662235c7900590f9d58716dc77e937464fab0e57752ee18353a13c163ee98615474f48d0b99e04dae1d34
+DIST android-studio-ide-173.4670197-linux.zip 894043298 BLAKE2B fe8f5175a4a6fa66bffc351e0af3ab5241f0876ba531d6db6cfee28deab1cf00e9a162f4089d87be2e582c4e77908e428fc707e42166688da80d86901548c57c SHA512 2b5b2e84c980036a82a345e57a8ee4ae670db6c3f20e13c4a6fe5860aa74d4a8ac6b9902742455be43c78347dde71c087cbdb21a497bd0b13c6b1a15f9bc135b
EBUILD android-studio-3.0.1.0.171.4443003.ebuild 3072 BLAKE2B 8c5552536ef579a96c6cd72deef2103996e00c8425307da0c286dd0f09b9a3c7166a2431e4bf668065925f5bc2c1266218bd7d698839458200459355c414c4cb SHA512 3230961e4108f533365f501567eb4f95d2617582a00858f06764452af0cc982c2b25e391de415f38d6f83e613c4f904872cbd50c5c66dd2641753ab52c1e5ab6
+EBUILD android-studio-3.1.0.16.173.4670197.ebuild 3074 BLAKE2B e8eaa428420dddd0e0fcd5ace1dcd0eaf64b6ee8011d2ca961e8ee166d0e1f7ace254c3b28208b1b19558910842d9c9876e8a56fc2781aacb5c15e61a4fb6356 SHA512 1c6ffdf4f63b5701ba2633ba3c58dace43f5921695c9bd3165fb0a6343ca024dad2655ec328237e22e988d45488d57256c47bcac73fa02e1604329d9bbdc50aa
MISC metadata.xml 220 BLAKE2B d2e2757e926d61fa1d52be7a4f8e61b94c2f09f9868089255d89dd548d58b5898d8be4e5ea0c5c36cba3436b12026702443d43af0e4f7d6d41754b5c84c1c879 SHA512 9316c4d43c1ca819f3d2111553313246af1166f9fb95a666797ff28ca6b0410e92fbe4f94cf70a046e8086d824b47bed8b3c0d1ec1498a3be779cf9a828e9868
diff --git a/dev-util/android-studio/android-studio-3.1.0.16.173.4670197.ebuild b/dev-util/android-studio/android-studio-3.1.0.16.173.4670197.ebuild
new file mode 100644
index 000000000000..10d45b8040b7
--- /dev/null
+++ b/dev-util/android-studio/android-studio-3.1.0.16.173.4670197.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils java-pkg-2 versionator
+
+RESTRICT="strip"
+QA_PREBUILT="opt/${PN}/bin/libbreakgen*.so
+ opt/${PN}/bin/fsnotifier*
+ opt/${PN}/lib/libpty/linux/x86*/libpty.so
+ opt/${PN}/plugins/android/lib/libwebp_jni*.so
+ opt/${PN}/plugins/android/resources/perfa/*/libperfa.so
+ opt/${PN}/plugins/android/resources/perfd/*/perfd
+ opt/${PN}/plugins/android/resources/simpleperf/*/simpleperf"
+
+if [[ $(get_version_component_count) -eq 6 ]]; then
+ STUDIO_V=$(get_version_component_range 1-4)
+ BUILD_V=$(get_version_component_range 5-6)
+else
+ STUDIO_V=$(get_version_component_range 1-3)
+ BUILD_V=$(get_version_component_range 4-5)
+fi
+
+DESCRIPTION="A new Android development environment based on IntelliJ IDEA"
+HOMEPAGE="http://developer.android.com/sdk/installing/studio.html"
+SRC_URI="https://dl.google.com/dl/android/studio/ide-zips/${STUDIO_V}/${PN}-ide-${BUILD_V}-linux.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="selinux"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-arch/zip
+ dev-java/commons-logging:0
+ dev-java/log4j:0"
+
+# dev-java/guava:18
+RDEPEND=">=virtual/jdk-1.7
+ selinux? ( sec-policy/selinux-android )
+ >=app-arch/bzip2-1.0.6-r4
+ dev-java/commons-logging:0
+ dev-java/log4j:0
+ >=dev-libs/expat-2.1.0-r3
+ >=dev-libs/libffi-3.0.13-r1
+ >=media-libs/fontconfig-2.10.92
+ >=media-libs/freetype-2.5.5
+ >=media-libs/libpng-1.2.51
+ >=media-libs/mesa-10.2.8
+ || ( gnome-extra/zenity kde-apps/kdialog x11-apps/xmessage x11-libs/libnotify )
+ >=sys-libs/ncurses-5.9-r3:5/5[tinfo]
+ >=sys-libs/zlib-1.2.8-r1
+ >=x11-libs/libX11-1.6.2
+ >=x11-libs/libXau-1.0.7-r1
+ >=x11-libs/libXdamage-1.1.4-r1
+ >=x11-libs/libXdmcp-1.1.1-r1
+ >=x11-libs/libXext-1.3.2
+ >=x11-libs/libXfixes-5.0.1
+ >=x11-libs/libXrender-0.9.8
+ >=x11-libs/libXxf86vm-1.1.3
+ >=x11-libs/libdrm-2.4.46
+ >=x11-libs/libxcb-1.9.1
+ >=x11-libs/libxshmfence-1.1"
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ eapply_user
+ # This is really a bundled jdk not a jre
+ rm -R "${S}/jre" || die "Could not remove bundled jdk"
+
+ # Replace bundled jars with system
+ # has problems with newer jdom:0 not updated to jdom:2
+ cd "${S}/lib" || die
+ local JARS="commons-logging log4j"
+ local j
+ for j in ${JARS}; do
+ rm -v ${j/:*/}*.jar || die
+ java-pkg_jar-from ${j}
+ done
+
+ cd "${S}" || die
+
+ # bug 629404
+ echo "-Djdk.util.zip.ensureTrailingSlash=false" >> bin/studio64.vmoptions || die
+ echo "-Djdk.util.zip.ensureTrailingSlash=false" >> bin/studio.vmoptions || die
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ local dir="/opt/${PN}"
+
+ insinto "${dir}"
+ # Replaced bundled jre with system vm/jdk
+ # This is really a bundled jdk not a jre
+ doins -r *
+
+ rm -rf "${D}${dir}/jre" || die
+ dosym "/etc/java-config-2/current-system-vm" "${dir}/jre"
+
+ fperms 755 "${dir}/bin/studio.sh" "${dir}"/bin/fsnotifier{,64}
+ chmod 755 "${D}${dir}"/gradle/gradle-*/bin/gradle || die
+
+ newicon "bin/studio.png" "${PN}.png"
+ make_wrapper ${PN} ${dir}/bin/studio.sh
+ make_desktop_entry ${PN} "Android Studio" ${PN} "Development;IDE" "StartupWMClass=jetbrains-studio"
+}