summaryrefslogtreecommitdiff
path: root/dev-util/0xtools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-15 16:50:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-15 16:50:39 +0100
commit3be8faef74cb863e207124a6fccbf01ce90c0799 (patch)
tree222958402b707645e8b7bcb072c607c538f2f5c0 /dev-util/0xtools
parentea3e1bbf643d1d8892f4df05e4f05c1b2a2125d8 (diff)
gentoo auto-resync : 15:09:2023 - 16:50:39
Diffstat (limited to 'dev-util/0xtools')
-rw-r--r--dev-util/0xtools/0xtools-1.2.4.ebuild62
-rw-r--r--dev-util/0xtools/0xtools-9999.ebuild62
-rw-r--r--dev-util/0xtools/Manifest4
-rw-r--r--dev-util/0xtools/metadata.xml27
4 files changed, 155 insertions, 0 deletions
diff --git a/dev-util/0xtools/0xtools-1.2.4.ebuild b/dev-util/0xtools/0xtools-1.2.4.ebuild
new file mode 100644
index 000000000000..3b7026647b97
--- /dev/null
+++ b/dev-util/0xtools/0xtools-1.2.4.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit python-single-r1 systemd toolchain-funcs
+
+DESCRIPTION="Always-on profiling for production systems"
+HOMEPAGE="https://0x.tools/
+ https://github.com/tanelpoder/0xtools/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/tanelpoder/${PN}.git"
+else
+ SRC_URI="https://github.com/tanelpoder/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+BDEPEND="${RDEPEND}"
+
+DOCS=( CHANGELOG.md README.md )
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} ${LDFLAGS}"
+
+ sed -e "/^sys.path.append/s|(.*)|('$(python_get_sitedir)/${PN}')|" \
+ -i bin/psn -i bin/schedlat || die
+}
+
+src_install() {
+ # C executables and scripts
+ exeinto /usr/bin
+ doexe bin/{run_xcapture.sh,run_xcpu.sh,vmtop,xcapture}
+
+ # Python executables
+ python_domodule lib/${PN}
+ python_doscript bin/psn
+ python_doscript bin/schedlat
+
+ # Service
+ systemd_dounit xcapture.service
+ systemd_dounit xcapture-restart.service
+ systemd_dounit xcapture-restart.timer
+
+ # Service config
+ insinto /etc/default
+ newins xcapture.default xcapture
+
+ # Service logs
+ keepdir /var/log/xcapture
+
+ einstalldocs
+}
diff --git a/dev-util/0xtools/0xtools-9999.ebuild b/dev-util/0xtools/0xtools-9999.ebuild
new file mode 100644
index 000000000000..3b7026647b97
--- /dev/null
+++ b/dev-util/0xtools/0xtools-9999.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit python-single-r1 systemd toolchain-funcs
+
+DESCRIPTION="Always-on profiling for production systems"
+HOMEPAGE="https://0x.tools/
+ https://github.com/tanelpoder/0xtools/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/tanelpoder/${PN}.git"
+else
+ SRC_URI="https://github.com/tanelpoder/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+BDEPEND="${RDEPEND}"
+
+DOCS=( CHANGELOG.md README.md )
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} ${LDFLAGS}"
+
+ sed -e "/^sys.path.append/s|(.*)|('$(python_get_sitedir)/${PN}')|" \
+ -i bin/psn -i bin/schedlat || die
+}
+
+src_install() {
+ # C executables and scripts
+ exeinto /usr/bin
+ doexe bin/{run_xcapture.sh,run_xcpu.sh,vmtop,xcapture}
+
+ # Python executables
+ python_domodule lib/${PN}
+ python_doscript bin/psn
+ python_doscript bin/schedlat
+
+ # Service
+ systemd_dounit xcapture.service
+ systemd_dounit xcapture-restart.service
+ systemd_dounit xcapture-restart.timer
+
+ # Service config
+ insinto /etc/default
+ newins xcapture.default xcapture
+
+ # Service logs
+ keepdir /var/log/xcapture
+
+ einstalldocs
+}
diff --git a/dev-util/0xtools/Manifest b/dev-util/0xtools/Manifest
new file mode 100644
index 000000000000..b46760777ed1
--- /dev/null
+++ b/dev-util/0xtools/Manifest
@@ -0,0 +1,4 @@
+DIST 0xtools-1.2.4.tar.gz 61830 BLAKE2B 6221ded289bc4cf4c39527f35d1ad3ee43f41a60a4a9877056a5ff74fcdd203575d96edbf13af1d32bcc49465d87a2133a8dbec813ae9a5bb233b5fe2e4a36b3 SHA512 f835de65e783d9eb4b26f38be155961a2f4da91639c7e1e39df71cf8be17d27987c8749e44b7b6affe6cdc45c5f65c90be5b2cf22b2f37dcc2eb45452a384ff3
+EBUILD 0xtools-1.2.4.ebuild 1360 BLAKE2B 1a710510aeade291b21d2b1e124244ae2ce5e5666909198a45fb3a4544fe88bfa5f964fb6a98d510f3a0544336a10538e50396663c7d0e47394f02fcf4c4b2ca SHA512 7404eda4db8655977d3db08b594c9f2861937e3663faa57781f19e2697d57310a2ccb08db8df3f617b1ce6006f1caa7d07b79baa123d97e971fb703d6a29c089
+EBUILD 0xtools-9999.ebuild 1360 BLAKE2B 1a710510aeade291b21d2b1e124244ae2ce5e5666909198a45fb3a4544fe88bfa5f964fb6a98d510f3a0544336a10538e50396663c7d0e47394f02fcf4c4b2ca SHA512 7404eda4db8655977d3db08b594c9f2861937e3663faa57781f19e2697d57310a2ccb08db8df3f617b1ce6006f1caa7d07b79baa123d97e971fb703d6a29c089
+MISC metadata.xml 1292 BLAKE2B b7e2505d33b7af4424dc4336a7d8d1536ed70f92e4dccccf725a54473b109f7718adac34960b5238753336c6b2da5fd0e49def8ae249509c4b0c9e4bc42a89cf SHA512 0ecf2c2bab2cf03656f980788cf05849c3d2e5905f70753b03f76615da377a5463b3d30decddc3a97eaf83d9bef55e31ce104ca6cd459eb0f116c9edeba0edf2
diff --git a/dev-util/0xtools/metadata.xml b/dev-util/0xtools/metadata.xml
new file mode 100644
index 000000000000..204bb4159e5d
--- /dev/null
+++ b/dev-util/0xtools/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ 0x.tools is a set of open-source utilities for analyzing application
+ performance on Linux. It has a goal of deployment simplicity and minimal
+ dependencies, to reduce friction of systematic troubleshooting. There’s no
+ need to upgrade the OS, install kernel modules, heavy monitoring
+ frameworks, Java agents or databases. These tools also work on
+ over-decade-old Linux kernels, like version 2.6.18 from 14 years ago.
+ 0x.tools allow you to measure individual thread level activity, like thread
+ sleep states, currently executing system calls and kernel wait locations.
+ Additionally, you can drill down into CPU usage of any thread or the system
+ as a whole. You can be systematic in your troubleshooting - no need for
+ guessing or clever metric-voodoo tricks with traditional system-level
+ statistics.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/tanelpoder/0xtools/issues</bugs-to>
+ <remote-id type="github">tanelpoder/0xtools</remote-id>
+ </upstream>
+</pkgmetadata>