summaryrefslogtreecommitdiff
path: root/dev-tex/xcolor/xcolor-2.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-tex/xcolor/xcolor-2.12.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-tex/xcolor/xcolor-2.12.ebuild')
-rw-r--r--dev-tex/xcolor/xcolor-2.12.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-tex/xcolor/xcolor-2.12.ebuild b/dev-tex/xcolor/xcolor-2.12.ebuild
new file mode 100644
index 000000000000..3071962f1eb5
--- /dev/null
+++ b/dev-tex/xcolor/xcolor-2.12.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+inherit latex-package
+
+DESCRIPTION="xcolor -- easy driver-independent access to colors"
+HOMEPAGE="http://www.ukern.de/tex/xcolor.html"
+SRC_URI="http://www.ukern.de/tex/xcolor/ctan/${P//[.-]/}.zip"
+
+LICENSE="LPPL-1.2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc"
+
+RDEPEND="dev-texlive/texlive-latex"
+
+DEPEND="${RDEPEND}
+ doc? (
+ dev-texlive/texlive-pstricks
+ dev-texlive/texlive-latexextra
+ )
+ app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+
+TEXMF="/usr/share/texmf-site"
+
+src_install() {
+ export VARTEXFONTS="${T}/fonts"
+
+ latex-package_src_install || die
+
+ dodoc README ChangeLog
+}