summaryrefslogtreecommitdiff
path: root/dev-tex/pythontex
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-tex/pythontex
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-tex/pythontex')
-rw-r--r--dev-tex/pythontex/Manifest3
-rw-r--r--dev-tex/pythontex/metadata.xml14
-rw-r--r--dev-tex/pythontex/pythontex-0.16.ebuild55
3 files changed, 72 insertions, 0 deletions
diff --git a/dev-tex/pythontex/Manifest b/dev-tex/pythontex/Manifest
new file mode 100644
index 000000000000..70a94636161e
--- /dev/null
+++ b/dev-tex/pythontex/Manifest
@@ -0,0 +1,3 @@
+DIST pythontex-0.16.tar.gz 1787147 SHA256 b33cf0189319752ffd14bb5735d0f3570e68545da834793c6fa2c81e164b6f5e SHA512 9a84fd7b7f568308addf9ba01c46fadfaface54b9d484c766831f1048064288fd1ecb5c56774bb0041d8f5705f8d5f8a9cd7258dc33157467eca7b3c70259183 WHIRLPOOL 7c8bd31208e9c4dcb640cc79d1a1885233c544485fcd4bf65772f7d7bc4efa0a5a6c60d15bae9e7d9e27f833b1ef2b06ea313a7008c3f000ec9b017a63ad0fbd
+EBUILD pythontex-0.16.ebuild 1235 SHA256 39ac83a7cb6f396b2a43c193a2d3aabe2eeba5aae105d191b6cce05e8d94965c SHA512 e902e56657b9a46c8529870b91ed9f5480ddd04bb731ec67f8fa3aa7e6711886869e9d8830f1c67fff45c0cc261590d28a32f707291ec8ef3691ed63198c002d WHIRLPOOL 69c6ae5c9a3f56055a676f01d917fe8ecd2e0741812b7983e91da1a4abac62fa1f0cfbcf691549bb0b35e35e8c1a5cd29b5785f07af34320bd673f8db6cc7540
+MISC metadata.xml 455 SHA256 2082468c2782a0377d80bc5437fff34b4bd852c1ace4673ccb646b4de9ed08ca SHA512 8f87ee6e99c9cd263e6e6ec6241a463b2c3c7496a03314998015840a332fcfb3a9ebd7ac2970faa7afabde5ced10d1bdf5c553d2ae91c20bc97a0295c9250a3d WHIRLPOOL e4e1f727f24aa8694665ab12d03acb662561c9532646aee247c8e2726bcfd45c54c0087812817a16bf7b58c23b7d80789e237e4e92852404368c144f3a05c1e4
diff --git a/dev-tex/pythontex/metadata.xml b/dev-tex/pythontex/metadata.xml
new file mode 100644
index 000000000000..9586dee6f5e6
--- /dev/null
+++ b/dev-tex/pythontex/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <use>
+ <flag name="highlighting">Syntax highlighting using <pkg>dev-python/pygments</pkg></flag>
+ </use>
+ <upstream>
+ <remote-id type="github">gpoore/pythontex</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-tex/pythontex/pythontex-0.16.ebuild b/dev-tex/pythontex/pythontex-0.16.ebuild
new file mode 100644
index 000000000000..4e2cabb8f62e
--- /dev/null
+++ b/dev-tex/pythontex/pythontex-0.16.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit latex-package python-r1
+
+DESCRIPTION="Fast Access to Python from within LaTeX"
+HOMEPAGE="https://github.com/gpoore/pythontex"
+SRC_URI="https://github.com/gpoore/pythontex/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LPPL-1.3 BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE="highlighting"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=dev-texlive/texlive-latex-2016"
+RDEPEND="${DEPEND}
+ >=dev-texlive/texlive-latex-2016
+ highlighting? ( dev-python/pygments[${PYTHON_USEDEP}] )"
+
+TEXMF=/usr/share/texmf-site
+
+src_compile() {
+ cd ${PN} || die
+ ebegin "Compiling ${PN}"
+ rm ${PN}.sty || die
+ VARTEXFONTS="${T}/fonts" latex ${PN}.ins extra || die
+ eend
+}
+
+src_install() {
+ dodoc ${PN}/README "${S}"/*rst ${PN}_quickstart/*
+
+ cd ${PN} || die
+
+ installation() {
+ if python_is_python3; then
+ python_domodule {de,}${PN}3.py
+ else
+ python_domodule {de,}${PN}2.py
+ fi
+ python_domodule ${PN}_{engines,utils}.py
+ python_doscript {de,}${PN}.py syncpdb.py
+ python_optimize
+ }
+ python_foreach_impl installation
+
+ latex-package_src_doinstall dtx ins sty
+}