summaryrefslogtreecommitdiff
path: root/dev-tex/pythontex
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /dev-tex/pythontex
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'dev-tex/pythontex')
-rw-r--r--dev-tex/pythontex/Manifest2
-rw-r--r--dev-tex/pythontex/pythontex-0.18.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-tex/pythontex/Manifest b/dev-tex/pythontex/Manifest
index a3cef2fafd3d..6eb0d3b28d5f 100644
--- a/dev-tex/pythontex/Manifest
+++ b/dev-tex/pythontex/Manifest
@@ -1,3 +1,5 @@
DIST pythontex-0.17.tar.gz 1800631 BLAKE2B 5c4ab31ccd890ca708142e83d047a46d704d2eaead611521a9f272f7a63cfb4016b991741c0338b1874d8cd2949c83b9c5ab59c3004e26540c171666a4f05e63 SHA512 ac248579f8645c225839ca9698b6193d2a7d8360a50e9a8406fae5616f54418a173635d1c2e8c47b18e85cdd1fa1e81c9435169c44f06fb19505c280f9bbaee5
+DIST pythontex-0.18.tar.gz 1807531 BLAKE2B 0f3293043780e93290fb9b3988513f919983a1a19c18344c6d5b1223dea40310581c0b5938da695485516648db3b23dbbef3eb40091f2ccd8f5a7576179043a7 SHA512 ad7dcb91d7df3eb37cdfaab870001f70976a55ca300c029ae931ade53103cbd71f7c3a4fa5d1360fdd1d9fc092f39c0427f13d2328033197057dcbc490d4ca7b
EBUILD pythontex-0.17.ebuild 1100 BLAKE2B 640affdf4137eaedbc559897ca9deb257e76640a8cf93bd33550072a7966be1da3ecac39070c035e6d41b31fafb24147a9baa0a2839a6aba77f4c739988af565 SHA512 7c35d9fc357851299e949e8bef4638305218e9f65851f18461d95b9140d0638657bbb8fe7ca321058fdc976337b98716af4a795b05b705720de4fd5e2a3cddae
+EBUILD pythontex-0.18.ebuild 1102 BLAKE2B c3d6a4c615e49716ff5bbec9b8d563256e822397dbc266b499ed816c09f8a5956d92c85f6f57e0c76664f4f6750f42ff85fd2643785029cbcbf1095811df4489 SHA512 15a0778edd1cf38ae1f34387cb8de0410400a1ae38aaf24ffef97ed9b5af0720a302b23cdd118731a60a6779a8092e940c828e31117c3c456d4719219ca41aa8
MISC metadata.xml 481 BLAKE2B a2f7635ff8274af4b35ebbab9e56ebf8d66375b0bf29103a82960aaebeea8a2a477b16468ebd5c74193983f3086416d2b80cc32829be7640e4af040e5ebe7065 SHA512 dece9e9c55b7f176030ae1f1d9f85a5ca57bb15f70504492e49e77d62a0d09bd732f6e3112b5e3ecafe5476d2b44935d60924cecb165a4b71ebe6303240e0481
diff --git a/dev-tex/pythontex/pythontex-0.18.ebuild b/dev-tex/pythontex/pythontex-0.18.ebuild
new file mode 100644
index 000000000000..9c876cfd094a
--- /dev/null
+++ b/dev-tex/pythontex/pythontex-0.18.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit latex-package python-r1
+
+DESCRIPTION="Fast Access to Python from within LaTeX"
+HOMEPAGE="https://github.com/gpoore/pythontex"
+SRC_URI="https://github.com/gpoore/pythontex/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LPPL-1.3 BSD"
+KEYWORDS="~amd64 ~ppc ~riscv ~x86"
+IUSE="doc highlighting"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=dev-texlive/texlive-latexextra-2016
+ dev-tex/pgf
+"
+RDEPEND="${DEPEND}
+ dev-python/pygments[${PYTHON_USEDEP}]
+"
+
+TEXMF=/usr/share/texmf-site
+
+src_compile() {
+ cd ${PN} || die
+ rm ${PN}.sty || die
+ VARTEXFONTS="${T}/fonts" latex ${PN}.ins extra || die
+}
+
+src_install() {
+ dodoc *rst
+ use doc && dodoc ${PN}_quickstart/*pdf ${PN}/*pdf
+
+ cd ${PN} || die
+
+ installation() {
+ python_domodule {de,}${PN}3.py
+ python_domodule ${PN}_{engines,utils}.py
+ python_doscript {de,}${PN}.py syncpdb.py
+ python_optimize
+ }
+ python_foreach_impl installation
+
+ latex-package_src_doinstall sty
+}