summaryrefslogtreecommitdiff
path: root/dev-tex/pythontex/pythontex-0.16.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-tex/pythontex/pythontex-0.16.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-tex/pythontex/pythontex-0.16.ebuild')
-rw-r--r--dev-tex/pythontex/pythontex-0.16.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-tex/pythontex/pythontex-0.16.ebuild b/dev-tex/pythontex/pythontex-0.16.ebuild
new file mode 100644
index 000000000000..7e0fa1b75525
--- /dev/null
+++ b/dev-tex/pythontex/pythontex-0.16.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit latex-package python-r1
+
+DESCRIPTION="Fast Access to Python from within LaTeX"
+HOMEPAGE="https://github.com/gpoore/pythontex"
+SRC_URI="https://github.com/gpoore/pythontex/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LPPL-1.3 BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE="highlighting"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=dev-texlive/texlive-latexextra-2016
+ dev-tex/pgf"
+RDEPEND="${DEPEND}
+ highlighting? ( dev-python/pygments[${PYTHON_USEDEP}] )"
+
+TEXMF=/usr/share/texmf-site
+
+src_compile() {
+ cd ${PN} || die
+ ebegin "Compiling ${PN}"
+ rm ${PN}.sty || die
+ VARTEXFONTS="${T}/fonts" latex ${PN}.ins extra || die
+ eend
+}
+
+src_install() {
+ dodoc ${PN}/README "${S}"/*rst ${PN}_quickstart/*
+
+ cd ${PN} || die
+
+ installation() {
+ if python_is_python3; then
+ python_domodule {de,}${PN}3.py
+ else
+ python_domodule {de,}${PN}2.py
+ fi
+ python_domodule ${PN}_{engines,utils}.py
+ python_doscript {de,}${PN}.py syncpdb.py
+ python_optimize
+ }
+ python_foreach_impl installation
+
+ latex-package_src_doinstall dtx ins sty
+}