summaryrefslogtreecommitdiff
path: root/dev-tex/pythontex/pythontex-0.16.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-tex/pythontex/pythontex-0.16.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-tex/pythontex/pythontex-0.16.ebuild')
-rw-r--r--dev-tex/pythontex/pythontex-0.16.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/dev-tex/pythontex/pythontex-0.16.ebuild b/dev-tex/pythontex/pythontex-0.16.ebuild
deleted file mode 100644
index 7e0fa1b75525..000000000000
--- a/dev-tex/pythontex/pythontex-0.16.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit latex-package python-r1
-
-DESCRIPTION="Fast Access to Python from within LaTeX"
-HOMEPAGE="https://github.com/gpoore/pythontex"
-SRC_URI="https://github.com/gpoore/pythontex/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-LICENSE="LPPL-1.3 BSD"
-KEYWORDS="~amd64 ~x86"
-IUSE="highlighting"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="${PYTHON_DEPS}
- >=dev-texlive/texlive-latexextra-2016
- dev-tex/pgf"
-RDEPEND="${DEPEND}
- highlighting? ( dev-python/pygments[${PYTHON_USEDEP}] )"
-
-TEXMF=/usr/share/texmf-site
-
-src_compile() {
- cd ${PN} || die
- ebegin "Compiling ${PN}"
- rm ${PN}.sty || die
- VARTEXFONTS="${T}/fonts" latex ${PN}.ins extra || die
- eend
-}
-
-src_install() {
- dodoc ${PN}/README "${S}"/*rst ${PN}_quickstart/*
-
- cd ${PN} || die
-
- installation() {
- if python_is_python3; then
- python_domodule {de,}${PN}3.py
- else
- python_domodule {de,}${PN}2.py
- fi
- python_domodule ${PN}_{engines,utils}.py
- python_doscript {de,}${PN}.py syncpdb.py
- python_optimize
- }
- python_foreach_impl installation
-
- latex-package_src_doinstall dtx ins sty
-}