summaryrefslogtreecommitdiff
path: root/dev-tex/ppower4/ppower4-0.9.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-tex/ppower4/ppower4-0.9.6.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-tex/ppower4/ppower4-0.9.6.ebuild')
-rw-r--r--dev-tex/ppower4/ppower4-0.9.6.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-tex/ppower4/ppower4-0.9.6.ebuild b/dev-tex/ppower4/ppower4-0.9.6.ebuild
new file mode 100644
index 000000000000..4f42ccd175ca
--- /dev/null
+++ b/dev-tex/ppower4/ppower4-0.9.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit latex-package eutils
+
+DESCRIPTION="Post-process presentations in PDF format which were prepared using (La)TeX to add dynamic effects"
+
+# Taken from:
+#SRC_URI="http://www.tex.ac.uk/tex-archive/support/ppower4/pp4sty.zip
+# http://www.tex.ac.uk/tex-archive/support/ppower4/pp4p.jar
+# http://www.tex.ac.uk/tex-archive/support/ppower4/ppower4
+# http://www.tex.ac.uk/tex-archive/support/ppower4/manual.pdf"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+HOMEPAGE="http://www.tex.ac.uk/tex-archive/support/ppower4/index.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 x86"
+
+IUSE=""
+DEPEND="app-arch/unzip"
+RDEPEND="${DEPEND}
+ virtual/jre"
+
+src_unpack() {
+
+ unpack ${A}
+ cd "${S}"
+ unzip pp4sty.zip
+
+ epatch "${FILESDIR}/${PN}-gentoo.patch"
+}
+
+src_install() {
+
+ latex-package_src_install || die
+
+ dobin ppower4
+
+ insinto /usr/lib/${PN}
+ doins pp4p.jar
+
+ insinto /usr/share/doc/${PF}
+ doins manual.pdf
+}