summaryrefslogtreecommitdiff
path: root/dev-tex/minted/minted-2.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-20 01:49:56 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-20 01:49:56 +0000
commit30be4d7d2806b014770312920fcda743d4dc67d0 (patch)
tree229c7337dfd56654c52009367273c078b016a25c /dev-tex/minted/minted-2.6.ebuild
parentf287ecad888abdeb38e617d0485de282cd6819db (diff)
gentoo auto-resync : 20:12:2022 - 01:49:56
Diffstat (limited to 'dev-tex/minted/minted-2.6.ebuild')
-rw-r--r--dev-tex/minted/minted-2.6.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-tex/minted/minted-2.6.ebuild b/dev-tex/minted/minted-2.6.ebuild
new file mode 100644
index 000000000000..eb8f3b628aa0
--- /dev/null
+++ b/dev-tex/minted/minted-2.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit latex-package
+
+DESCRIPTION="LaTeX package for source code syntax highlighting"
+HOMEPAGE="https://github.com/gpoore/minted/"
+SRC_URI="https://github.com/gpoore/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/${P}/source
+
+SLOT="0"
+LICENSE="|| ( BSD LPPL-1.3 )"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ dev-python/pygments
+ dev-texlive/texlive-latexextra
+"
+
+DOCS=( ../CHANGES.md ../README.md )
+
+src_prepare() {
+ default
+
+ rm "${S}"/${PN}.pdf || die
+}
+
+src_install() {
+ LATEX_DOC_ARGUMENTS="-shell-escape"
+
+ latex-package_src_install
+
+ use doc && latex-package_src_doinstall pdf
+}