summaryrefslogtreecommitdiff
path: root/dev-tex/lgrind/lgrind-3.67-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
commit77398e424e45d9e98c1cef3c43bdadb9d56e81ef (patch)
tree5aeffd3fc7b92fc615bd2c222fa8831aeda1925b /dev-tex/lgrind/lgrind-3.67-r3.ebuild
parentbd4aeefe33e63f613512604e47bfca7b2187697d (diff)
gentoo resync : 10.11.2019
Diffstat (limited to 'dev-tex/lgrind/lgrind-3.67-r3.ebuild')
-rw-r--r--dev-tex/lgrind/lgrind-3.67-r3.ebuild20
1 files changed, 11 insertions, 9 deletions
diff --git a/dev-tex/lgrind/lgrind-3.67-r3.ebuild b/dev-tex/lgrind/lgrind-3.67-r3.ebuild
index 7c92be12ec1b..bf0507cc8966 100644
--- a/dev-tex/lgrind/lgrind-3.67-r3.ebuild
+++ b/dev-tex/lgrind/lgrind-3.67-r3.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
-inherit latex-package toolchain-funcs eutils
+inherit latex-package toolchain-funcs
DESCRIPTION="A pretty printer for various programming languages with tex output."
SRC_URI="https://dev.gentoo.org/~dilfridge/distfiles/${P}.tgz"
@@ -15,12 +15,12 @@ IUSE="examples"
S=${WORKDIR}/${PN}
-src_unpack() {
- unpack ${A}
- cd "${S}"
- echo 'CFLAGS+=-DDEFSFILE=\"$(DEFSFILE)\" -DVERSION=\"$(VERSION)\"' > source/Makefile
- echo 'lgrind: lgrind.o lgrindef.o regexp.o' >> source/Makefile
- epatch "${FILESDIR}/${P}-fgets.patch"
+PATCHES=( "${FILESDIR}/${P}-fgets.patch" )
+
+src_prepare() {
+ echo 'CFLAGS+=-DDEFSFILE=\"$(DEFSFILE)\" -DVERSION=\"$(VERSION)\"' > source/Makefile || die "Fixing Makefile failed"
+ echo 'lgrind: lgrind.o lgrindef.o regexp.o' >> source/Makefile || die "Fixing Makefile failed"
+ default
}
src_compile() {
@@ -28,7 +28,7 @@ src_compile() {
latex-package_src_compile
cd "${S}"/source
- emake DEFSFILE="/usr/share/texmf/tex/latex/${PN}/lgrindef" VERSION="${PV}" || die
+ emake DEFSFILE="/usr/share/texmf/tex/latex/${PN}/lgrindef" VERSION="${PV}"
}
src_install() {
@@ -42,10 +42,12 @@ src_install() {
# and finally, the documentation
dodoc FAQ README
+
if use examples ; then
docinto examples
dodoc example/*
fi
+
cd "${S}"/source
doman lgrind.1 lgrindef.5
}