summaryrefslogtreecommitdiff
path: root/dev-tex/latexdiff/latexdiff-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-tex/latexdiff/latexdiff-9999.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-tex/latexdiff/latexdiff-9999.ebuild')
-rw-r--r--dev-tex/latexdiff/latexdiff-9999.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-tex/latexdiff/latexdiff-9999.ebuild b/dev-tex/latexdiff/latexdiff-9999.ebuild
new file mode 100644
index 000000000000..38ed7743a7e7
--- /dev/null
+++ b/dev-tex/latexdiff/latexdiff-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Compare two latex files and mark up significant differences"
+HOMEPAGE="http://www.ctan.org/tex-archive/support/latexdiff/ https://github.com/ftilmann/latexdiff/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ftilmann/latexdiff.git"
+else
+ SRC_URI="https://github.com/ftilmann/latexdiff/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+IUSE="test"
+
+RDEPEND="
+ >=dev-lang/perl-5.8
+ virtual/latex-base
+ || ( dev-texlive/texlive-plaingeneric dev-texlive/texlive-genericrecommended )
+ dev-perl/Algorithm-Diff
+"
+DEPEND="${RDEPEND}
+ dev-perl/Pod-LaTeX
+ test? ( app-shells/tcsh )
+"
+
+src_compile() {
+ export VARTEXFONTS="${T}/fonts"
+ PATH="${S}/dist:${PATH}" emake -j1 distribution
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ cd dist || die
+ dobin latexdiff latexrevise latexdiff-vc
+ doman latexdiff.1 latexrevise.1 latexdiff-vc.1
+ dodoc README doc/latexdiff-man.pdf
+}