summaryrefslogtreecommitdiff
path: root/dev-tex/hyphen_show
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-tex/hyphen_show
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-tex/hyphen_show')
-rw-r--r--dev-tex/hyphen_show/Manifest4
-rw-r--r--dev-tex/hyphen_show/files/hyphen_show-gcc34.patch78
-rw-r--r--dev-tex/hyphen_show/hyphen_show-20000425.ebuild33
-rw-r--r--dev-tex/hyphen_show/metadata.xml16
4 files changed, 131 insertions, 0 deletions
diff --git a/dev-tex/hyphen_show/Manifest b/dev-tex/hyphen_show/Manifest
new file mode 100644
index 000000000000..2571fcadc2d7
--- /dev/null
+++ b/dev-tex/hyphen_show/Manifest
@@ -0,0 +1,4 @@
+AUX hyphen_show-gcc34.patch 2314 BLAKE2B 1d432748078a9580751acf608ac1dbd79ecb645c0bfe75b1fdaa3b0563bceae381f1ff18c32606753d67bb8f36c325cfd3389d258a79edd4d5e1b5d419a114d0 SHA512 589b6c660a668fb04cc5e8d5ec58ee65ef56a54aa5a94324125943b67b8cee15b62d371c8e324983b44f33ffd8c4c292812e8d91a66d58bf9f28a7f09a521eac
+DIST hyphen-show_20000425.orig.tar.gz 8723 BLAKE2B 8320aca42393d9be2e7557c15a05045ff48f7ba63f5af8f5184f0ead34e755d57891226166c3b7ad1d3b8e46f229f2960169d4de9873cf8165e99ff046418acc SHA512 77904ac52171dd245f900e80c7b7ef48a67fc8dffe13dcb3f321a8582c4fe907295f1f19e8513cc612d2089aedc67c29ba03e1928af94c7009e6fd7327c6552e
+EBUILD hyphen_show-20000425.ebuild 702 BLAKE2B df9c4f335450c89ad6b68e8c8ae86feef364003e78ea067f196b661fb5bd82d02bd67f4dc51faf1c607cbcfcdb01bf741d19b41768b7f92d712f6143b2535ad9 SHA512 288ddfe875eb8e47b21d12a54e6026adac6364a9db8dd9c3e9f1671e4f86f7047c8528f23e337ddd8f65282e7ffe5caa2acdcb67b3d8233a7adf985439f71c4c
+MISC metadata.xml 555 BLAKE2B 0e8fafed25cda424d789b044080643795bb50e7940149b36ca4ea0b1bc50d80fc9f8f0a0302ec8fa68a3431f73e322d08a51fcf9f099d50dcb858e8fe9e8d8c8 SHA512 2384c8699f315875657dc4ea50eea937542a15b283c3670a2ebd88c2b68a661d7c136ebe90e31d9b2518ee999ab09a7c20488e52af0bedc7984307d757f7e68c
diff --git a/dev-tex/hyphen_show/files/hyphen_show-gcc34.patch b/dev-tex/hyphen_show/files/hyphen_show-gcc34.patch
new file mode 100644
index 000000000000..9da98c9d1000
--- /dev/null
+++ b/dev-tex/hyphen_show/files/hyphen_show-gcc34.patch
@@ -0,0 +1,78 @@
+--- hyphen-show-20000425/hyphen_show.c.orig 2002-01-29 00:08:12.000000000 +0100
++++ hyphen-show-20000425/hyphen_show.c 2005-09-29 09:34:01.000000000 +0200
+@@ -79,9 +79,9 @@
+ Linux (gcc),
+ SGI IRIS 5.2 */
+ #include <sys/fcntl.h>
+- int close(int);
+- int read(int,char *,unsigned);
+- int isalpha(char);
++ #include <unistd.h>
++ #include <stdlib.h>
++ #include <ctype.h>
+ #endif
+
+ int gchar(unsigned char *);
+@@ -106,7 +106,6 @@
+ char zugelassen(char, unsigned char);
+ char* text_clear(char *, int *);
+ void eop(void);
+-long pow(int,int);
+ void eingabe(long *, unsigned char);
+ void right(unsigned char);
+ void w0(void);
+@@ -114,7 +113,7 @@
+ void x0(void);
+ void x(unsigned char);
+ void down(unsigned char);
+-void y0(void);
++void y_0(void);
+ void y(unsigned char);
+ void z0(void);
+ void z(unsigned char);
+@@ -491,24 +490,16 @@
+ s_p = 0;
+ }
+
+-long pow(int b,int p)
+- { int w,k;
+- w = b;
+- for (k=1; k < p; k++) {w = w *b;};
+- return w;
+- }
+-
+ void eingabe(long* dd, unsigned char k)
+- { char neg; unsigned char hk;
++ { unsigned char hk;
+ long hn,hw;
+ hw = (int) e_inbyte();
+- neg = FALSE;
+- if (hw > 127) {neg = TRUE;};
++ if (hw > 127) hw -= 256;
+ for (hn = 2; hn <= (long) k; hn++)
+ { hk = e_inbyte();
+ hw = hw*256+hk;
+ };
+- if (neg == TRUE) {*dd = -(pow(2,k*8))+hw; } else *dd = hw;
++ *dd = hw;
+ }
+
+ void right(unsigned char code)
+@@ -544,7 +535,7 @@
+ if (d_v > v_grenze_zeile) a_outimage();
+ }
+
+-void y0(void)
++void y_0(void)
+ { if (d_y > y_grenze) a_outimage();
+ if (abs(d_y) > y_grenze_zeile) a_outimage();
+ }
+@@ -698,7 +689,7 @@
+ else if (k == 152) {x0();} /* x0 */
+ else if (k <= 156) {x(k);} /* x1 bis x4 */
+ else if (k <= 160) {down(k);} /* down1 bis down4 */
+- else if (k == 161) {y0();} /* y0 */
++ else if (k == 161) {y_0();} /* y0 */
+ else if (k <= 165) {y(k);} /* y1 bis y4 */
+ else if (k == 166) {z0();} /* z0 */
+ else if (k <= 170) {z(k);} /* z1 bis z4 */
diff --git a/dev-tex/hyphen_show/hyphen_show-20000425.ebuild b/dev-tex/hyphen_show/hyphen_show-20000425.ebuild
new file mode 100644
index 000000000000..ca4a35ad7917
--- /dev/null
+++ b/dev-tex/hyphen_show/hyphen_show-20000425.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+inherit eutils toolchain-funcs
+
+MY_PN=${PN//_/-}
+DESCRIPTION="Show hyphenations in DVI files"
+HOMEPAGE="http://packages.debian.org/stable/tex/hyphen-show"
+SRC_URI="mirror://debian/pool/main/h/${MY_PN}/${MY_PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc64 x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${PN}-gcc34.patch
+}
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} hyphen_show.c -o hyphen_show || die
+}
+
+src_install() {
+ dobin hyphen_show || die
+ doman hyphen_show.1 || die
+ dodoc README.hyphen_show || die
+}
diff --git a/dev-tex/hyphen_show/metadata.xml b/dev-tex/hyphen_show/metadata.xml
new file mode 100644
index 000000000000..300b7beec5d0
--- /dev/null
+++ b/dev-tex/hyphen_show/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>ulm@gentoo.org</email>
+</maintainer>
+<maintainer type="project">
+ <email>tex@gentoo.org</email>
+ <name>Gentoo TeX Project</name>
+</maintainer>
+<longdescription>
+ hyphen_show scans a DVI file, tries to find all hyphenations and writes them
+ to stdout. It is useful to check whether TeX's hyphenation algorithm really
+ did the good job it is supposed to do.
+</longdescription>
+</pkgmetadata>