summaryrefslogtreecommitdiff
path: root/dev-tex/hyphen_show/hyphen_show-20000425.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
commit36ac65103bf5503e5bad1ecc7e8cb9e7643f6840 (patch)
treed9d1fbc20509d4c90f57fb2d9e1459bc8034c831 /dev-tex/hyphen_show/hyphen_show-20000425.ebuild
parenta1392efe64137262023d92492396ca9156d22396 (diff)
Revert "gentoo resync : 13.09.2019"
This reverts commit a1392efe64137262023d92492396ca9156d22396.
Diffstat (limited to 'dev-tex/hyphen_show/hyphen_show-20000425.ebuild')
-rw-r--r--dev-tex/hyphen_show/hyphen_show-20000425.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-tex/hyphen_show/hyphen_show-20000425.ebuild b/dev-tex/hyphen_show/hyphen_show-20000425.ebuild
new file mode 100644
index 000000000000..ca4a35ad7917
--- /dev/null
+++ b/dev-tex/hyphen_show/hyphen_show-20000425.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+inherit eutils toolchain-funcs
+
+MY_PN=${PN//_/-}
+DESCRIPTION="Show hyphenations in DVI files"
+HOMEPAGE="http://packages.debian.org/stable/tex/hyphen-show"
+SRC_URI="mirror://debian/pool/main/h/${MY_PN}/${MY_PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc64 x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${PN}-gcc34.patch
+}
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} hyphen_show.c -o hyphen_show || die
+}
+
+src_install() {
+ dobin hyphen_show || die
+ doman hyphen_show.1 || die
+ dodoc README.hyphen_show || die
+}