summaryrefslogtreecommitdiff
path: root/dev-tex/hevea
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-18 18:50:06 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-18 18:50:06 +0000
commitbc7e0dbdbd194a8c2e09f82e1a5a4ea5e1b556f4 (patch)
treecb9186c88b5cfbd6c51e4b283677075c5c6ea38e /dev-tex/hevea
parentebb07c94f800907e02d2a6b92c1bc757b2f86f49 (diff)
gentoo auto-resync : 18:03:2024 - 18:50:06
Diffstat (limited to 'dev-tex/hevea')
-rw-r--r--dev-tex/hevea/Manifest2
-rw-r--r--dev-tex/hevea/hevea-2.36.ebuild70
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-tex/hevea/Manifest b/dev-tex/hevea/Manifest
index 712e5166c28a..65124aee8448 100644
--- a/dev-tex/hevea/Manifest
+++ b/dev-tex/hevea/Manifest
@@ -1,3 +1,5 @@
DIST hevea-2.35.tar.gz 1006773 BLAKE2B 80a8f80955a4eee641c53784cbe4543072062d0bf4d757fe0c8270d6370d54495eeab3a9279bd992dc45b80b23de0438ee4fe6fa932981c777b25782c42ca4a8 SHA512 dc1a5179489626176b1fcae47a9c7eb4cf9c1c6127c749cb938808697ccd6179277089fb20f4d5da7b82056d15b1d64acd9ba9884d1950a74d98c98864b4180a
+DIST hevea-2.36.tar.gz 1007317 BLAKE2B d8e6d3490b02b990e992a343a287ae5ff1f32624722760df52aa703d8989ef802b9f297ec97576b96937edb70d1a35910ba11fd88ac675254368451ee68ad044 SHA512 9335666f5f77ff33b61ef3817feaff6e58ff9896a4e1478ecab893086177f66420020c174594ff0290c2c19ea5a46f52a03daf50e6e502dc9c2f2545463effa2
EBUILD hevea-2.35-r1.ebuild 1534 BLAKE2B bf12d72fdfaa81e5ac3172a58d8b3da96f979e5b7f96e8b0a03c9a93c2e21e6d4fe952078a4b6f341b1d576a56088bf82069c25b9a8f8fd2bd7328a30374e348 SHA512 ddf3675a86f80661d4ce7ef2688da44194d627313e923cbbd9f314f76237b0310b380fa0856082636a790c19cad5882653c374c771934e5bfa10eb9eaf48db73
+EBUILD hevea-2.36.ebuild 1803 BLAKE2B a967308a29202c717321ff7c4efe9da3e0751acf6c64e9955fca658be1d00dbbcbec72cec6dc6725fbe2cfd5a4915c9341b9f2b748b5ff135e0123b69c0e8ac1 SHA512 50664cfcea375f2ca55a9300cef744f98027559ef84221b57ef64664c25a781055d6a056553c69167d50fde4181ddfb0581d64b1d5560c9b43ec1f3bbd9fb208
MISC metadata.xml 329 BLAKE2B 64acd8c9f75ce005c04ce59fb090ce76bc174398b7f26f97feb172f4d142368e138f1e13136e7f920ba7c4672dc6e2cd1e492d305a6e6c24fcd76fcb8065897b SHA512 4dacb52ad4dec5a448232a745532408a239186503cb691e9ad97aec107e957ab113d01c2399bfd144a5e6622a930cda1351236b6a1cb70fc084ce68de4bd6cf3
diff --git a/dev-tex/hevea/hevea-2.36.ebuild b/dev-tex/hevea/hevea-2.36.ebuild
new file mode 100644
index 000000000000..51948f1e861c
--- /dev/null
+++ b/dev-tex/hevea/hevea-2.36.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="HeVeA is a quite complete and fast LaTeX to HTML translator"
+HOMEPAGE="https://hevea.inria.fr/"
+SRC_URI="https://hevea.inria.fr/distri/${P}.tar.gz"
+
+LICENSE="QPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+# - hevea's imagen script calls gs from app-text/ghostscript-gpl, hence
+# the RDEPEND (https://bugs.gentoo.org/927003).
+DEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt=]"
+RDEPEND="
+ ${DEPEND}
+ app-text/ghostscript-gpl
+ dev-texlive/texlive-latexextra
+"
+BDEPEND="dev-ml/ocamlbuild"
+
+# bug #734350
+QA_FLAGS_IGNORED=(
+ /usr/bin/bibhva
+ /usr/bin/hevea
+ /usr/bin/esponja
+ /usr/bin/hacha
+)
+
+src_compile() {
+ rm -f config.sh || die
+
+ emake PREFIX=/usr DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)/hevea" LATEXLIBDIR="/usr/share/texmf-site/tex/latex/hevea" config.sh
+
+ if use ocamlopt; then
+ emake PREFIX=/usr
+ else
+ emake PREFIX=/usr TARGET=byte
+ fi
+}
+
+src_install() {
+ if use ocamlopt; then
+ emake DESTDIR="${ED}" PREFIX=/usr install
+ else
+ emake DESTDIR="${ED}" PREFIX=/usr TARGET=byte install
+ fi
+
+ dodoc README CHANGES
+}
+
+# If texmf-update is present this means we have a latex install; update it so
+# that hevea.sty can be found
+# Do not (r)depend on latex though because hevea does not need it itself
+# If latex is installed later, it will see hevea.sty
+
+pkg_postinst() {
+ if [[ -z "${ROOT}" ]] && [[ -x "${EPREFIX}"/usr/sbin/texmf-update ]] ; then
+ "${EPREFIX}"/usr/sbin/texmf-update || die "texmf-update returned non-zero exit status ${?}"
+ fi
+}
+
+pkg_postrm() {
+ if [[ -z "${ROOT}" ]] && [[ -x "${EPREFIX}"/usr/sbin/texmf-update ]] ; then
+ "${EPREFIX}"/usr/sbin/texmf-update || die "texmf-update returned non-zero exit status ${?}"
+ fi
+}