summaryrefslogtreecommitdiff
path: root/dev-tex/dot2tex
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-tex/dot2tex
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-tex/dot2tex')
-rw-r--r--dev-tex/dot2tex/Manifest2
-rw-r--r--dev-tex/dot2tex/dot2tex-2.11.3.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-tex/dot2tex/Manifest b/dev-tex/dot2tex/Manifest
index 9241c6a27d3a..8ee0c1d4b0a4 100644
--- a/dev-tex/dot2tex/Manifest
+++ b/dev-tex/dot2tex/Manifest
@@ -1,3 +1,5 @@
+DIST dot2tex-2.11.3.tar.gz 664750 BLAKE2B 9c7effeca0d71810ce37e126df9e7df2b9df19be41393916c85e49df0dc116f42e58a2b29cce9e2bac700fa00859c63c1a4a8c41c70a9db96a5fc210960f463b SHA512 1595299811461b18cff490a8a56c0215f46989dd4a46fa087b455c717ed5d5f7a5782d04acaa3e4567b4e348bca866d5f24d21663012c4cd813445804ef6f714
DIST dot2tex-2.9.0.tar.gz 663372 BLAKE2B 807093c5bd7304a6c315568e69c8c8387a377a8aa47790d558feb84036ca6ce2d00534823254a50af9852206d0e27b2e15f2a8ba0e8333e2bb8b20a983947e74 SHA512 97ba9983643254d5a3034d2fc8c454c445849ac546bd285676b854e20c8aae9a25d61e73632717da1562541ce9b3a4ae8aa4daa29e33f78105e28a34b5ebae5d
+EBUILD dot2tex-2.11.3.ebuild 1022 BLAKE2B 1981dec3f53ab5d53c33cd70dec906f28f3ec7fe316d3d6e13c16c9cbf253734d8aaf01c4b32864e28f4e4e540b8c725fe72f53edc6efe2d5bb746599199dc38 SHA512 d0d2a995b9e969ba0cbb028e3d2ef1b89d8b7525bea6e0bf5f8da0d26a216d3ff9fde91d73cac766db058b46e3f6c79813b9847230b08532f126fa7992b635a8
EBUILD dot2tex-2.9.0.ebuild 1000 BLAKE2B 37a968728290d1232bfb93c723fa1dae92a1c8b93b0330f46ea41d426f5e8c300013c925c6ac10f46e530dfe2058ab940d59eeff9f8ef6afd2a6f7608a9dc596 SHA512 85af4840d7ba4aa62bb772191e1cda2c45ee7c9f30b1ffc5f6131cc80af04dc5c7876afa6e36bcd2e39000477d611a979591bc009d58e80c203eeea7e665f723
MISC metadata.xml 381 BLAKE2B ab936fa6e8bedf30df2713557cb55b558831dd2230be87fdea15ef84c7ded1a665b90d74cea23a3a2d4ff0bef03e43af9f226e1d236c5e5e79ebfb51a2b55358 SHA512 1b1e745b1979792a554d0a0fbd15e5f97f4806e668ccf3ddb519e60cf70af7081194f1f442b6cd7ef5ff4676fd2a837833e59879d4b05dff817927a11449700e
diff --git a/dev-tex/dot2tex/dot2tex-2.11.3.ebuild b/dev-tex/dot2tex/dot2tex-2.11.3.ebuild
new file mode 100644
index 000000000000..2ea47959d682
--- /dev/null
+++ b/dev-tex/dot2tex/dot2tex-2.11.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7})
+
+inherit distutils-r1
+
+DESCRIPTION="A Graphviz to LaTeX converter"
+HOMEPAGE="https://dot2tex.readthedocs.org/ https://github.com/kjellmf/dot2tex"
+SRC_URI="https://github.com/kjellmf/dot2tex/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
+IUSE="doc examples"
+
+DEPEND="dev-python/pyparsing[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/pydot[${PYTHON_USEDEP}]
+ media-gfx/graphviz"
+DEPEND="${DEPEND}
+ doc? ( dev-python/sphinx )"
+
+python_compile_all() {
+ if use doc ; then
+ cd "${S}/docs"
+ emake html
+ fi
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use doc; then
+ dodoc -r docs/_build/html
+ fi
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}