summaryrefslogtreecommitdiff
path: root/dev-tex/catdvi/catdvi-0.14-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-tex/catdvi/catdvi-0.14-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-tex/catdvi/catdvi-0.14-r1.ebuild')
-rw-r--r--dev-tex/catdvi/catdvi-0.14-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-tex/catdvi/catdvi-0.14-r1.ebuild b/dev-tex/catdvi/catdvi-0.14-r1.ebuild
new file mode 100644
index 000000000000..7783adcdb420
--- /dev/null
+++ b/dev-tex/catdvi/catdvi-0.14-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit eutils autotools toolchain-funcs flag-o-matic
+
+DESCRIPTION="DVI to plain text translator"
+HOMEPAGE="http://catdvi.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="virtual/tex-base
+ dev-libs/kpathsea"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-kpathsea.patch"
+ eautoconf
+ has_version '>=dev-libs/kpathsea-6.2.1' && append-cppflags "$($(tc-getPKG_CONFIG) --cflags kpathsea)"
+}
+
+src_compile() {
+ # Do not use plain emake here, because make tests
+ # may cache fonts and generate sandbox violations.
+ emake catdvi CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin catdvi
+ doman catdvi.1
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}