summaryrefslogtreecommitdiff
path: root/dev-tcltk/togl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-tcltk/togl
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-tcltk/togl')
-rw-r--r--dev-tcltk/togl/Manifest3
-rw-r--r--dev-tcltk/togl/metadata.xml31
-rw-r--r--dev-tcltk/togl/togl-2.0-r2.ebuild46
3 files changed, 80 insertions, 0 deletions
diff --git a/dev-tcltk/togl/Manifest b/dev-tcltk/togl/Manifest
new file mode 100644
index 000000000000..4b3cffafaeb9
--- /dev/null
+++ b/dev-tcltk/togl/Manifest
@@ -0,0 +1,3 @@
+DIST Togl2.0-src.tar.gz 244968 BLAKE2B f094fb4bba7049470d7f61a2748d4a5baaf47c99c766d96ef8061e254673acf7f2a11555e202ec01f5d6b7a00ae7c275a33981fba5df7f1478f69da17f3180b8 SHA512 2be3062baada848d96b2802582bc5590b215f2ab4dc02c91761e72af2bf8c0ba768a71a2ffb8107bca83b63b7d1321ee83de19b97f83b1c2f0962f9288948b0a
+EBUILD togl-2.0-r2.ebuild 871 BLAKE2B eb08c55e5a7a64ae0eb63ce9620531c91d8ca72147f4711317590fd242465a6cdd0c31b71d5dec9b70a1b8d01f5147f0f97f261c76adabe431c12a8762a54223 SHA512 abfe4987bdb7a2f77f105386d4093bec7aa9e7f0d301ce0871a34535ca92ac9aabae37bf82ab15b1c7587710945677f0ac310b5c852d3f3c3820697165ed1a8a
+MISC metadata.xml 1191 BLAKE2B c421c6f81a32e715643716995a0c336166f1892c46f663bbcd4f910f2c208f9e5249e2820b9df10e22c76111d27bec7d61e4d405ebb9193a9c44166aed58c52b SHA512 890b9b1bb4b9ae4255e9fa24efb01e3f109a8e7675055ef9166a71d9ec1624494d2e5115cf3d8f074f400f805a61a3409558a8f21d544f91e4d8775fb2f3c5ef
diff --git a/dev-tcltk/togl/metadata.xml b/dev-tcltk/togl/metadata.xml
new file mode 100644
index 000000000000..e8e075423cc0
--- /dev/null
+++ b/dev-tcltk/togl/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>tcltk@gentoo.org</email>
+ <name>Gentoo Tcltk Project</name>
+ </maintainer>
+ <longdescription>
+Togl is a Tk widget for OpenGL rendering. Togl was originally based on
+OGLTK, written by Benjamin Bederson at the University of New Mexico. Togl's
+main features are:
+
+* unifies Microsoft Windows, X11 (Linux/IRIX/...), and Mac OS X Aqua support
+* support for requesting stencil, accumulation, alpha buffers, etc.
+* multiple OpenGL drawing windows
+* simple stereo rendering support
+* simple, portable font support
+* color-index mode support including color allocation functions
+* overlay plane support
+* OpenGL extension testing from Tcl
+* Tcl Extension Architecture (TEA) 3 compliant
+
+Togl does almost no OpenGL drawing itself, instead it manages OpenGL
+drawing by calling various Tcl commands (a.k.a., callback functions). Those
+commands can be C functions that call OpenGL (in)directly or another Tcl
+package (e.g., Tcl3D).
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">togl</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-tcltk/togl/togl-2.0-r2.ebuild b/dev-tcltk/togl/togl-2.0-r2.ebuild
new file mode 100644
index 000000000000..58d12aadd6c7
--- /dev/null
+++ b/dev-tcltk/togl/togl-2.0-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+MY_P=Togl${PV}
+
+DESCRIPTION="A Tk widget for OpenGL rendering"
+HOMEPAGE="http://togl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}-src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="debug +threads"
+
+RDEPEND="
+ dev-lang/tk
+ virtual/opengl
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}"
+
+# tests directory is missing
+RESTRICT="test"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed \
+ -e 's:-fomit-frame-pointer::g' \
+ -e 's:-O2::g' \
+ -e 's:-pipe::g' \
+ -i configure || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug symbols) \
+ $(use_enable threads)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dohtml doc/*
+ dodoc README*
+}