summaryrefslogtreecommitdiff
path: root/dev-tcltk/tkXwin/tkXwin-1.0-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-tcltk/tkXwin/tkXwin-1.0-r4.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-tcltk/tkXwin/tkXwin-1.0-r4.ebuild')
-rw-r--r--dev-tcltk/tkXwin/tkXwin-1.0-r4.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-tcltk/tkXwin/tkXwin-1.0-r4.ebuild b/dev-tcltk/tkXwin/tkXwin-1.0-r4.ebuild
new file mode 100644
index 000000000000..471945156f57
--- /dev/null
+++ b/dev-tcltk/tkXwin/tkXwin-1.0-r4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit autotools-utils multilib toolchain-funcs
+
+DESCRIPTION="Tcl/Tk library to detect idle periods of an X session"
+HOMEPAGE="http://beepcore-tcl.sourceforge.net/"
+SRC_URI="http://beepcore-tcl.sourceforge.net/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="debug static-libs threads"
+KEYWORDS="amd64 ppc x86"
+
+RDEPEND="
+ dev-lang/tk[threads?]
+ x11-libs/libXScrnSaver
+ x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-Makefile.in.diff
+ "${FILESDIR}"/${P}-configure.patch
+ )
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_prepare() {
+ tc-export CC AR RANLIB
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-tcl="${EPREFIX}/usr/$(get_libdir)"
+ --with-tk="${EPREFIX}/usr/$(get_libdir)"
+ --enable-gcc
+ --with-x
+ $(use_enable threads)
+ $(use_enable debug symbols)
+ )
+ autotools-utils_src_configure
+}