summaryrefslogtreecommitdiff
path: root/dev-tcltk/thread/thread-2.8.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-27 11:40:34 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-27 11:40:34 +0000
commite4be1c42deab59fa5baee33fa9b1c48e5c4c6dc7 (patch)
treeb4534a27fdf6bf08f5703b897a4684732e78151a /dev-tcltk/thread/thread-2.8.8.ebuild
parent0a5376618896a890256bc26687f4cd8bbe302df6 (diff)
gentoo auto-resync : 27:02:2024 - 11:40:34
Diffstat (limited to 'dev-tcltk/thread/thread-2.8.8.ebuild')
-rw-r--r--dev-tcltk/thread/thread-2.8.8.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-tcltk/thread/thread-2.8.8.ebuild b/dev-tcltk/thread/thread-2.8.8.ebuild
new file mode 100644
index 000000000000..0d61f5d80f0b
--- /dev/null
+++ b/dev-tcltk/thread/thread-2.8.8.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+MY_P="${PN}${PV}"
+
+DESCRIPTION="Tcl Thread extension"
+HOMEPAGE="http://www.tcl.tk/"
+SRC_URI="mirror://sourceforge/project/tcl/Thread%20Extension/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+DEPEND="dev-lang/tcl:0=[threads]"
+RDEPEND="${DEPEND}"
+
+QA_CONFIG_IMPL_DECL_SKIP=(
+ stat64 # used to test for Large File Support
+)
+
+S="${WORKDIR}"/${MY_P}
+
+PATCHES=( "${FILESDIR}"/${PN}-2.8.5-musl.patch )
+
+src_prepare() {
+ default
+
+ # Search for libs in libdir not just exec_prefix/lib
+ sed -i -e 's:${exec_prefix}/lib:${libdir}:' \
+ aclocal.m4 || die "sed failed"
+
+ sed -i -e "s/relid'/relid/" tclconfig/tcl.m4 || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-tclinclude="${EPREFIX}/usr/include" \
+ --with-tcl="${EPREFIX}/usr/$(get_libdir)"
+}