summaryrefslogtreecommitdiff
path: root/dev-tcltk/tdom/tdom-0.8.3-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-tcltk/tdom/tdom-0.8.3-r4.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-tcltk/tdom/tdom-0.8.3-r4.ebuild')
-rw-r--r--dev-tcltk/tdom/tdom-0.8.3-r4.ebuild87
1 files changed, 0 insertions, 87 deletions
diff --git a/dev-tcltk/tdom/tdom-0.8.3-r4.ebuild b/dev-tcltk/tdom/tdom-0.8.3-r4.ebuild
deleted file mode 100644
index ed89bad9d1e5..000000000000
--- a/dev-tcltk/tdom/tdom-0.8.3-r4.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools eutils flag-o-matic multilib toolchain-funcs
-
-MY_P="tDOM-${PV}"
-
-DESCRIPTION="A XML/DOM/XPath/XSLT Implementation for Tcl"
-HOMEPAGE="https://tdom.github.com/"
-#SRC_URI="https://cloud.github.com/downloads/tDOM/${PN}/${MY_P}.tgz"
-SRC_URI="https://github.com/downloads/tDOM/${PN}/${MY_P}.tgz"
-
-LICENSE="MPL-1.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="static-libs threads"
-
-DEPEND="
- dev-lang/tcl:0=
- dev-libs/expat"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}/"${PN}-0.8.2.patch
- "${FILESDIR}/"${P}-soname.patch
- "${FILESDIR}/"${P}-expat.patch
- "${FILESDIR}/"${PN}-0.8.2-tnc.patch
- "${FILESDIR}/"${P}-tcl8.6.patch
- )
-
-src_prepare() {
- tc-export AR
- append-libs -lm
- sed \
- -e 's:-O2::g' \
- -e 's:-pipe::g' \
- -e 's:-fomit-frame-pointer::g' \
- -e '/SHLIB_LD_LIBS/s:\"$: ${TCL_LIB_FLAG}":g' \
- -i {.,extensions/tnc}/configure tclconfig/tcl.m4 || die
- epatch "${PATCHES[@]}"
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_enable threads)
- --enable-shared
- --disable-tdomalloc
- --with-expat
- --with-tcl="${EPREFIX}"/usr/$(get_libdir)
- )
-
- cd "${S}"/unix && ECONF_SOURCE=".." econf ${myeconfargs}
- cd "${S}"/extensions/tdomhtml && econf ${myeconfargs}
- cd "${S}"/extensions/tnc && econf ${myeconfargs}
-}
-
-src_compile() {
- local dir
-
- for dir in "${S}"/unix "${S}"/extensions/tnc; do
- pushd ${dir} > /dev/null
- emake
- popd > /dev/null
- done
-}
-
-src_install() {
- local dir
-
- dodoc CHANGES ChangeLog README*
-
- for dir in "${S}"/unix "${S}"/extensions/tdomhtml "${S}"/extensions/tnc; do
- pushd ${dir} > /dev/null
- emake DESTDIR="${D}" install
- popd > /dev/null
- done
-
- if ! use static-libs; then
- einfo "Removing static libs ..."
- rm -f "${ED}"/usr/$(get_libdir)/*.{a,la} || die
- fi
-}