summaryrefslogtreecommitdiff
path: root/dev-tcltk/tclxml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-tcltk/tclxml
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-tcltk/tclxml')
-rw-r--r--dev-tcltk/tclxml/Manifest2
-rw-r--r--dev-tcltk/tclxml/tclxml-3.2.7.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-tcltk/tclxml/Manifest b/dev-tcltk/tclxml/Manifest
index 96dc38f1f641..7eb0635b2d2e 100644
--- a/dev-tcltk/tclxml/Manifest
+++ b/dev-tcltk/tclxml/Manifest
@@ -1,5 +1,7 @@
AUX tclxml-3.2-fix-implicit-declarations.patch 488 BLAKE2B 1feca37c6c6e87d8c04d884dc6cfcaaacf64eead99f48825cb6473a677161876b3c3be8db6dd04e30195379dbaff2647cfe3cbe8dde4ee3ee9b17d817390100b SHA512 9f8a0c55886c01324e318aec70c99b85f845567a486daddbb897900f242d8a9fec99026c8f6ec7d73e5dca8ee22bf851dc64eab2a83a3a2c959828a24e79e4ca
AUX tclxml-3.2-format-security.patch 647 BLAKE2B b35232d7b553ee3e95b0a6c1998ad98b50be7198af8383bc5f3e00c6892bac29c257bdce9e04ec783098b878b06736c032b801684d9152b5d8ff1df5c4db771d SHA512 2b76363f015400642f00ce24ef67fd8f7607cd6ed0a63a5768aa343fbe9d6a8af50e15ccebecff813aa0c6d0714d65626c31e2edc860b6b826e52952bb47d435
+DIST tclxml-3.2.7.tar.gz 313751 BLAKE2B 43983d2d6c2f339fa320c4748f889db49fbe9cfff15219e898fdfe5a9a7d6526a2b40b7697fdca6f5272bdfb52cbe68af53ced711ad5d476dc2c5e31898c00ba SHA512 23cb17466f777538088998fa4cce55531708bba517d45cb8b4281401779c418f8532376e4aefcf4bb5f3674ee5bab2e0db25ab2a69c153d3e5820c509edf12ae
DIST tclxml-3.2.tar.gz 757594 BLAKE2B 6ddadb6add6ccba0db55e704ddffafe1c0f22740d27a5c49bf9c8fd00e1592aed46fd1cef49155101ac1544de8559f0d808731c598cf2189ff84a681bbf870e6 SHA512 5e7d45063c1a311d49ecc42f664bf7d88862fc19a46b64f52d038e2adfcc5b6964ae74d61b40bcf8eb4e1440f849339095fd8712bd39f0cb57e279acea58a3da
EBUILD tclxml-3.2-r2.ebuild 1104 BLAKE2B c7fb3d0496a9fae3ee378d98705c47997a6a800f603a24ece4310a329c764255ba167d5b69765be4635bb313938e220e87a719a56e0ea5318e3e3c76c10dce9c SHA512 64f2f89b49e6c3a72e68daedcdbd6baa1b88f66b57396e55ffc2de0dd7100a9781635db83e1046677ba782f9627407709fa8eff7fc052b65bbfef56ac4602590
+EBUILD tclxml-3.2.7.ebuild 1034 BLAKE2B 9b1e98d8f9c975c758c40848dc669e2d36a202a0fba201e972b27076b141d4f546f4d625be300f3c59f3b7ef676c0921d1b0a82a5b11a0cdd98673f453b6fa6c SHA512 e8cef1f3d1c31844d6c926cb96c99a8b2eba2a4801ad47577c07e20e77c90d35dd823f1ab2c5bfb53172b55b9792e0e899f3a99c0759bf1e11aea191d3b0bc36
MISC metadata.xml 329 BLAKE2B 6a79c9f1952fa24494921c92da92aaceae631ec090df7e08b39e8f037330cccff13a537c04340364552ad8a0f9c8aa41e642bf5ccc5ecac5264f4836a696fb06 SHA512 32f679fcef8e5ad247a7e566ccfe9098116d093ce83e7326e744dbfede0eeb47fbcc3de723e135a1dd3733d337de6648632ab1b5191ec2e9135d48a3b2988e5d
diff --git a/dev-tcltk/tclxml/tclxml-3.2.7.ebuild b/dev-tcltk/tclxml/tclxml-3.2.7.ebuild
new file mode 100644
index 000000000000..af6d475303e1
--- /dev/null
+++ b/dev-tcltk/tclxml/tclxml-3.2.7.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils multilib
+
+DESCRIPTION="Pure Tcl implementation of an XML parser"
+HOMEPAGE="http://tclxml.sourceforge.net/"
+SRC_URI="https://github.com/wjoye/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+IUSE="debug threads"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="
+ >=dev-lang/tcl-8.2:0
+ >=dev-libs/libxml2-2.6.9
+ dev-libs/libxslt
+ >=dev-tcltk/tcllib-1.2
+ dev-libs/expat"
+# test? ( dev-tcltk/tclparser )
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.2-fix-implicit-declarations.patch
+)
+
+src_configure() {
+ local myconf=""
+
+ use threads && myconf="${myconf} --enable-threads"
+
+ econf ${myconf} \
+ --with-xml2-config="${EPREFIX}"/usr/bin/xml2-config \
+ --with-xslt-config="${EPREFIX}"/usr/bin/xslt-config \
+ --with-tclinclude="${EPREFIX}"/usr/include \
+ --with-tcl="${EPREFIX}"/usr/$(get_libdir) \
+ $(use_enable amd64 64bit) \
+ $(use_enable debug symbols)
+}