summaryrefslogtreecommitdiff
path: root/dev-tcltk/tclpython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-tcltk/tclpython
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-tcltk/tclpython')
-rw-r--r--dev-tcltk/tclpython/Manifest4
-rw-r--r--dev-tcltk/tclpython/files/tclpython-5.0-gentoo.patch20
-rw-r--r--dev-tcltk/tclpython/tclpython-5.0-r1.ebuild4
3 files changed, 24 insertions, 4 deletions
diff --git a/dev-tcltk/tclpython/Manifest b/dev-tcltk/tclpython/Manifest
index 3bf710eb9d8c..b04e7537ab25 100644
--- a/dev-tcltk/tclpython/Manifest
+++ b/dev-tcltk/tclpython/Manifest
@@ -1,4 +1,4 @@
-AUX tclpython-5.0-gentoo.patch 856 BLAKE2B cd2efc191b03a24ed9fc7ed69349a8503228de30b9f79d01d81a11b1b166819e202901a6a1f246d0c142ae55fd7589a3c2ad7e81a1cbc7ca5ef486b5424c7292 SHA512 2cf2a99979d7457e5b16c795c86883b81069ecb01b485d52990e1c69ef412dbced3a10dfcfb803b8e1aa0cb0a09221598d7317a19dd20576e4c9fe163d29811f
+AUX tclpython-5.0-gentoo.patch 1476 BLAKE2B 86b099a5a30506c4f3dfb4c382a34dbc211b8eceabe039e033d6ec45d80d03bf64a259673ac80f4478b49a55e4605c8387bf17f3c9e3f4467345ca66ba2d98c7 SHA512 abc41ffae87ad1dabbac1dbc747c7df199559aa4d9be9676282d55020d5f1c9bde444ceb59363ddbcb2e786749fa9e42a0192d300be0fd945a01021da2abe8a9
DIST tclpython-5.0.tar.gz 19327 BLAKE2B bad25a6eb04dbcd9ca3e9bc81d44f098f31f2acf367ecc32307596d5da3ed95752b3c60d9ee74fc04e21669e0361f0790edad3ad5793c78ece4904beacd92900 SHA512 fe15218fe00e921384dbd9611685b86cb6dfacb515a95545079550aeadaaafc3964e6ef0594a268a3fd900f40d178659e8b7f6f2a6d9aa507b59a8be0bd116af
-EBUILD tclpython-5.0-r1.ebuild 1009 BLAKE2B 4a50f494553343273be173da0a2876d05908546d39ef72df017f690e334eac16728ab34d875702ada8a45eef828a8a8551aec8bc3c4638f2b9f5762cdde61d8f SHA512 87935c4964c2b786d4f2eea70a22bdbe99aa143d67bd6827a8712783481290d22139503d273e1d4bfbbb6382a2ae7e770a4e1e20c1ea03f06e135d787b46e057
+EBUILD tclpython-5.0-r1.ebuild 1011 BLAKE2B b4b43d8454b52f0362e223f629994e7a4fca7482d2ae81c3b9b219c0b026e07e5afe4fac1fba47230f1dff9e5b34bffa85e11b79aeca574fc3c00334805cc719 SHA512 54a05401712058687bf35962bb31966d393d55627dd2f99b6c5ea56951f3875edb783bef985891664a8e95c9711597f9a5de94b09bf2c285f6fb7cfbff654014
MISC metadata.xml 260 BLAKE2B 9864f2503702b03d3ad715b3f2bd7ef7077f9ddef089de0d6a0840599d99a7f99d439ee50c12afc9ca99b0e288babf74b0bb2a6132ae6dd656b8d7c15e9b10a9 SHA512 3d1e4f14995736fb28198da21587a813a31f1330873ae3078dcd9a2452c1196d23e45983877d2e296353e1ac35cc6ff461b309585237bcc768e37e6b2728c23b
diff --git a/dev-tcltk/tclpython/files/tclpython-5.0-gentoo.patch b/dev-tcltk/tclpython/files/tclpython-5.0-gentoo.patch
index c77339982fd6..39bdf20c095c 100644
--- a/dev-tcltk/tclpython/files/tclpython-5.0-gentoo.patch
+++ b/dev-tcltk/tclpython/files/tclpython-5.0-gentoo.patch
@@ -24,3 +24,23 @@
ifneq ($(MAKECMDGOALS), clean)
-include $(DEPEND)
+--- a/src/py.c 2022-02-06 10:20:03.352580186 +0100
++++ b/src/py.c 2022-02-06 11:16:49.504796684 +0100
+@@ -24,7 +24,6 @@
+ // First time initializing Python
+ Py_NoSiteFlag = 1;
+ Py_Initialize();
+- PyEval_InitThreads();
+ GlobalThread = PyEval_SaveThread();
+ }
+
+@@ -60,7 +59,8 @@
+ #ifdef WITH_THREAD
+ PyEval_RestoreThread(interp->thread_state);
+ Py_EndInterpreter(interp->thread_state);
+- PyEval_ReleaseLock();
++ PyThreadState_Swap(GlobalThread);
++ PyEval_SaveThread();
+ #endif
+
+ free(interp);
diff --git a/dev-tcltk/tclpython/tclpython-5.0-r1.ebuild b/dev-tcltk/tclpython/tclpython-5.0-r1.ebuild
index 05156fc6ea87..92a9fda120d9 100644
--- a/dev-tcltk/tclpython/tclpython-5.0-r1.ebuild
+++ b/dev-tcltk/tclpython/tclpython-5.0-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit python-single-r1 toolchain-funcs