summaryrefslogtreecommitdiff
path: root/dev-tcltk/tcl3d/tcl3d-0.4.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
commit36ac65103bf5503e5bad1ecc7e8cb9e7643f6840 (patch)
treed9d1fbc20509d4c90f57fb2d9e1459bc8034c831 /dev-tcltk/tcl3d/tcl3d-0.4.0-r1.ebuild
parenta1392efe64137262023d92492396ca9156d22396 (diff)
Revert "gentoo resync : 13.09.2019"
This reverts commit a1392efe64137262023d92492396ca9156d22396.
Diffstat (limited to 'dev-tcltk/tcl3d/tcl3d-0.4.0-r1.ebuild')
-rw-r--r--dev-tcltk/tcl3d/tcl3d-0.4.0-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-tcltk/tcl3d/tcl3d-0.4.0-r1.ebuild b/dev-tcltk/tcl3d/tcl3d-0.4.0-r1.ebuild
new file mode 100644
index 000000000000..c424262b15bb
--- /dev/null
+++ b/dev-tcltk/tcl3d/tcl3d-0.4.0-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit flag-o-matic multilib toolchain-funcs
+
+DESCRIPTION="Tcl bindings to OpenGL and other 3D libraries"
+HOMEPAGE="http://www.tcl3d.org"
+SRC_URI="http://www.tcl3d.org/download/${P}.distrib/${PN}-src-${PV}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug"
+
+RDEPEND="
+ dev-games/ode
+ dev-lang/tk:0=
+ dev-lang/tcl:0=
+ media-libs/libsdl
+ media-libs/ftgl
+ virtual/opengl
+ x11-libs/libXmu
+"
+DEPEND="${RDEPEND}
+ >=dev-lang/swig-1.3.19"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ TCL_VERSION=( $(echo 'puts [info tclversion]' | tclsh | tr '.' ' ') )
+ einfo "Configuring for Tcl ${TCL_VERSION[0]}.${TCL_VERSION[1]}"
+ sed -i \
+ -e 's:^\(TCLMAJOR\) *=\(.*\)$:\1 = '${TCL_VERSION[0]}':' \
+ -e 's:^\(TCLMINOR\) *=\(.*\)$:\1 = '${TCL_VERSION[1]}':' \
+ config_Linux* || die
+
+ # fix libSDL link
+ sed -i \
+ -e 's:-lSDL-1\.2:-lSDL:g' \
+ tcl3dSDL/Makefile || die
+}
+
+src_compile() {
+ append-flags -mieee-fp -ffloat-store -fPIC
+ use debug || append-flags -DNDEBUG
+
+ emake \
+ INSTDIR="/usr" OPT="${CFLAGS}" CC="$(tc-getCC) -c" \
+ CXX="$(tc-getCXX) -c" LD="$(tc-getLD)" \
+ WRAP_FTGL=1 WRAP_SDL=1 WRAP_GL2PS=0 WRAP_ODE=1
+}
+
+src_install() {
+ emake INSTDIR="${D}/usr" DESTDIR="${D}" INSTLIB="${D}/usr/$(get_libdir)" install
+}