summaryrefslogtreecommitdiff
path: root/dev-scheme/owl-lisp/owl-lisp-0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-11 15:35:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-11 15:35:17 +0100
commit75949673f38270397841d9c2322dbb774ac41554 (patch)
treeefeb01f94fd2a5bf01d3c892bd0c0d5a32b63770 /dev-scheme/owl-lisp/owl-lisp-0.2.ebuild
parent7e2b5bc2c2e2e045de6095d46c24ee857453adf2 (diff)
gentoo auto-resync : 11:08:2023 - 15:35:17
Diffstat (limited to 'dev-scheme/owl-lisp/owl-lisp-0.2.ebuild')
-rw-r--r--dev-scheme/owl-lisp/owl-lisp-0.2.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-scheme/owl-lisp/owl-lisp-0.2.ebuild b/dev-scheme/owl-lisp/owl-lisp-0.2.ebuild
deleted file mode 100644
index 05adcbd2ae8e..000000000000
--- a/dev-scheme/owl-lisp/owl-lisp-0.2.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# NOTICE: Because it is "purely functional" it is not scheme-compatible ootb
-
-EAPI=8
-
-inherit toolchain-funcs
-
-DESCRIPTION="Purely functional dialect of Scheme"
-HOMEPAGE="https://haltp.org/posts/owl.html"
-
-if [[ "${PV}" == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://gitlab.com/owl-lisp/owl.git"
-else
- SRC_URI="https://gitlab.com/owl-lisp/owl/-/archive/v${PV}/owl-v${PV}.tar.gz"
- KEYWORDS="~amd64"
- S="${WORKDIR}/owl-v${PV}"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-
-src_prepare() {
- default
-
- sed -i 's|make bin/vm|$(MAKE) bin/vm|g' ./Makefile || die
-}
-
-src_compile(){
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" owl
-}
-
-src_install() {
- einstalldocs
-
- dobin ./bin/ol
- newbin ./bin/vm ovm
-
- doman ./doc/*.1
-}