summaryrefslogtreecommitdiff
path: root/dev-scheme/owl-lisp/owl-lisp-0.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-11 15:35:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-11 15:35:17 +0100
commit75949673f38270397841d9c2322dbb774ac41554 (patch)
treeefeb01f94fd2a5bf01d3c892bd0c0d5a32b63770 /dev-scheme/owl-lisp/owl-lisp-0.2.1.ebuild
parent7e2b5bc2c2e2e045de6095d46c24ee857453adf2 (diff)
gentoo auto-resync : 11:08:2023 - 15:35:17
Diffstat (limited to 'dev-scheme/owl-lisp/owl-lisp-0.2.1.ebuild')
-rw-r--r--dev-scheme/owl-lisp/owl-lisp-0.2.1.ebuild18
1 files changed, 12 insertions, 6 deletions
diff --git a/dev-scheme/owl-lisp/owl-lisp-0.2.1.ebuild b/dev-scheme/owl-lisp/owl-lisp-0.2.1.ebuild
index 9a3d4efc4581..569d3b931745 100644
--- a/dev-scheme/owl-lisp/owl-lisp-0.2.1.ebuild
+++ b/dev-scheme/owl-lisp/owl-lisp-0.2.1.ebuild
@@ -1,14 +1,13 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# NOTICE: Because it is "purely functional" it is not scheme-compatible ootb
-
EAPI=8
inherit toolchain-funcs
DESCRIPTION="Purely functional dialect of Scheme"
-HOMEPAGE="https://haltp.org/posts/owl.html"
+HOMEPAGE="https://haltp.org/posts/owl.html
+ https://gitlab.com/owl-lisp/owl/"
if [[ "${PV}" == *9999* ]]; then
inherit git-r3
@@ -22,10 +21,15 @@ fi
LICENSE="MIT"
SLOT="0"
+PATCHES=( "${FILESDIR}"/${PN}-0.2.1-make-no-test.patch )
+
src_prepare() {
default
sed -i 's|make bin/vm|$(MAKE) bin/vm|g' "${S}"/Makefile || die
+
+ # Skip "tests/char-ready.sh", "does not work in background subshell".
+ rm tests/char-ready.sh || die
}
src_compile(){
@@ -33,9 +37,11 @@ src_compile(){
}
src_install() {
- einstalldocs
+ exeinto /usr/bin
+ doexe "${S}"/bin/ol
+ newexe "${S}"/bin/vm ovm
- dobin "${S}"/bin/ol
- newbin "${S}"/bin/vm ovm
doman "${S}"/doc/*.1
+
+ einstalldocs
}