summaryrefslogtreecommitdiff
path: root/dev-scheme/gauche-gl/gauche-gl-0.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
commite23a08d0c97a0cc415aaa165da840b056f93c997 (patch)
tree4c5f7db60483518201fef36f8cc0712789a08db2 /dev-scheme/gauche-gl/gauche-gl-0.6.ebuild
parent391b5b359a346aff490103da7dddc85047f83830 (diff)
gentoo resync : 08.10.2021
Diffstat (limited to 'dev-scheme/gauche-gl/gauche-gl-0.6.ebuild')
-rw-r--r--dev-scheme/gauche-gl/gauche-gl-0.6.ebuild19
1 files changed, 16 insertions, 3 deletions
diff --git a/dev-scheme/gauche-gl/gauche-gl-0.6.ebuild b/dev-scheme/gauche-gl/gauche-gl-0.6.ebuild
index 3d8aac3c5ebe..840d7c958120 100644
--- a/dev-scheme/gauche-gl/gauche-gl-0.6.ebuild
+++ b/dev-scheme/gauche-gl/gauche-gl-0.6.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
+
+inherit autotools
MY_P="${P^g}"
@@ -20,9 +22,20 @@ RDEPEND=">=dev-scheme/gauche-0.9.4
x11-libs/libXmu
cg? ( media-gfx/nvidia-cg-toolkit )"
DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
S="${WORKDIR}/${MY_P}"
-PATCHES=( "${FILESDIR}"/${P}-simple.viewer.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-simple.viewer.patch
+ "${FILESDIR}"/${P}-cflags.patch
+ "${FILESDIR}"/${P}-cg.patch
+ "${FILESDIR}"/${P}-info.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
src_configure() {
econf $(usex cg --enable-cg "")