summaryrefslogtreecommitdiff
path: root/dev-scheme/gambit/gambit-4.9.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-14 11:04:34 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-14 11:04:34 +0100
commitdd762ff83c330186ee2ede002e08b2f780cddd51 (patch)
tree63198edcc3ad5df8e2566c28ff9bd8af50cc2174 /dev-scheme/gambit/gambit-4.9.3.ebuild
parent51af5f0eb4cddbe6aa7953717873691d77aae9ff (diff)
gentoo resync : 14.07.2019
Diffstat (limited to 'dev-scheme/gambit/gambit-4.9.3.ebuild')
-rw-r--r--dev-scheme/gambit/gambit-4.9.3.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/dev-scheme/gambit/gambit-4.9.3.ebuild b/dev-scheme/gambit/gambit-4.9.3.ebuild
new file mode 100644
index 000000000000..d31d3757ed4c
--- /dev/null
+++ b/dev-scheme/gambit/gambit-4.9.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils elisp-common
+
+MY_PV="${PV//./_}"
+MY_P="${PN}-v${MY_PV}"
+
+DESCRIPTION="Gambit-C is a native Scheme to C compiler and interpreter"
+HOMEPAGE="http://www.iro.umontreal.ca/~gambit/"
+SRC_URI="http://www-labs.iro.umontreal.ca/~gambit/download/gambit/v${PV%.*}/source/${MY_P}.tgz"
+
+LICENSE="|| ( Apache-2.0 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+
+RDEPEND="ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="emacs? ( virtual/emacs )"
+
+SITEFILE="50gambit-gentoo.el"
+
+S="${WORKDIR}/${MY_P}" #-devel
+
+IUSE="emacs libressl ssl static"
+
+src_configure() {
+ econf $(use_enable !static shared) \
+ $(use_enable ssl openssl) \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --enable-gnu-gcc-specific-options \
+ --enable-gnu-gcc-no-strict-aliasing \
+ --enable-single-host \
+ --disable-absolute-shared-libs \
+ --enable-type-checking
+}
+
+src_compile() {
+ emake bootstrap
+
+ if use emacs; then
+ elisp-compile misc/*.el || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ keepdir /usr/share/"${MY_PN}"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}