summaryrefslogtreecommitdiff
path: root/dev-scheme/elk/elk-3.99.8-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-24 19:36:06 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-24 19:36:06 +0000
commit8c39538f1e5cf37f42c409a6c742f96abef56f3b (patch)
treefeb0b0792d417455747892f388078029dd6aee66 /dev-scheme/elk/elk-3.99.8-r1.ebuild
parentba4938837d52c0aff763d8acdc03ce103dd3ff82 (diff)
gentoo auto-resync : 24:12:2023 - 19:36:06
Diffstat (limited to 'dev-scheme/elk/elk-3.99.8-r1.ebuild')
-rw-r--r--dev-scheme/elk/elk-3.99.8-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-scheme/elk/elk-3.99.8-r1.ebuild b/dev-scheme/elk/elk-3.99.8-r1.ebuild
new file mode 100644
index 000000000000..5254a1c930ab
--- /dev/null
+++ b/dev-scheme/elk/elk-3.99.8-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Scheme implementation designed to be embeddable extension to C/C++ applications"
+HOMEPAGE="http://sam.zoy.org/elk/"
+SRC_URI="http://sam.zoy.org/elk/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-implicit-int-incompat-ptr.patch
+ "${FILESDIR}"/${P}-implicit-function.patch
+)
+
+src_configure() {
+ econf --disable-static
+}
+
+src_compile() {
+ # parallel build is broken
+ emake -j1
+}
+
+# tests are run automatically during make and fail with default src_test
+src_test() {
+ echo "Tests already run during compile"
+}
+
+src_install() {
+ # parallel install is broken
+ emake -j1 DESTDIR="${D}" \
+ docsdir="${EPREFIX}"/usr/share/doc/${PF} \
+ examplesdir="${EPREFIX}"/usr/share/doc/${PF}/examples \
+ install
+ einstalldocs
+ docompress -x /usr/share/doc/${PF}
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
+}