summaryrefslogtreecommitdiff
path: root/dev-scheme/cyclone
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-scheme/cyclone
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-scheme/cyclone')
-rw-r--r--dev-scheme/cyclone/Manifest4
-rw-r--r--dev-scheme/cyclone/cyclone-0.33.0.ebuild55
-rw-r--r--dev-scheme/cyclone/cyclone-9999.ebuild55
-rw-r--r--dev-scheme/cyclone/metadata.xml26
4 files changed, 140 insertions, 0 deletions
diff --git a/dev-scheme/cyclone/Manifest b/dev-scheme/cyclone/Manifest
new file mode 100644
index 000000000000..cf538f24f96c
--- /dev/null
+++ b/dev-scheme/cyclone/Manifest
@@ -0,0 +1,4 @@
+DIST cyclone-0.33.0.tar.gz 3946573 BLAKE2B 7eba62995ef3d327e14d6fbcf433d40e73c244508f8858d636a3a3fd05660e2921055932dedbe50ce8b384e9a9b44a09112aca6f851af6cd38b9b372769b2adc SHA512 96ffd3d04636b27f36c98920359a9f880c4b2a15e9820e5d91c82f821dc93357b665537e7688b00510d6a4fd113666edbd5ec109ff491f4f18d547129527b763
+EBUILD cyclone-0.33.0.ebuild 1158 BLAKE2B 47fa760d10dc84bd13fe82b970cd693c4ba5eb03f5356c3ee28bff36abb1603e91691d1aa7077ede2b612e09c39bf575003448169dffe4cd16a835ab658f8711 SHA512 59a1d7d1b3f900e6b9aadd7177328a3af20a42fe09e1177075124a089f9f58d315f6eaf0c023d6f63f0463a265e8ee024c43dea773cd61bec1ba50fbfcd87103
+EBUILD cyclone-9999.ebuild 1164 BLAKE2B b00e6cfba08aabf30efd64d9905696e8c46d9f31c811736cd21fac09e5f0dd7bc41f8811d44d062324c213bd3c0d3d4dbfa6ee17ec308577f06ef83cf71d94b8 SHA512 a24b4cf4f5454a1b41800c6b06c138d716dfd198e4ec7cfa8927a36df20aafe72e132d094e72c69c428f6ba729182fe21b3c04a5fc3bc9f39873499aab78832d
+MISC metadata.xml 1180 BLAKE2B 2d15145f5940e17f775a55dfa507d8f6bbeaa955be48dfb9d026d2bf7f4f1fb0b3422aa990d2d2149ec9e86449f0fb6a0c94e1809b39ed2b2d51acdfeda52eee SHA512 a35f542ac1c1ac6605241a5ba556975394255595a4c177c13277399c8ba03a8bf99703812b1b7e2200ec555294a85c1fea2f8d22fcaab6da8ee2217555b299ab
diff --git a/dev-scheme/cyclone/cyclone-0.33.0.ebuild b/dev-scheme/cyclone/cyclone-0.33.0.ebuild
new file mode 100644
index 000000000000..2a50206ddfee
--- /dev/null
+++ b/dev-scheme/cyclone/cyclone-0.33.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Cyclone is a self-hosting Scheme to C compiler
+# cyclone-bootstrap is the Cyclone SOURCE transpiled by it to C
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="R7RS Scheme to C compiler"
+HOMEPAGE="http://justinethier.github.io/cyclone/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/justinethier/${PN}-bootstrap.git"
+else
+ SRC_URI="https://github.com/justinethier/${PN}-bootstrap/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-bootstrap-${PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="dev-libs/concurrencykit"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ export CYC_GCC_OPT_FLAGS="${CFLAGS}"
+ append-cflags -fPIC -Iinclude
+ append-ldflags -L.
+ tc-export AR CC RANLIB
+}
+
+src_compile() {
+ local myopts=(
+ PREFIX="/usr"
+ CYC_GCC_OPT_FLAGS="${CYC_GCC_OPT_FLAGS}"
+ AR="$(tc-getAR)"
+ CC="$(tc-getCC)"
+ RANLIB="$(tc-getRANLIB)"
+ )
+ emake "${myopts[@]}"
+}
+
+src_test() {
+ emake LDFLAGS="" test
+}
+
+src_install() {
+ einstalldocs
+
+ emake PREFIX="/usr" DESTDIR="${D}" install
+}
diff --git a/dev-scheme/cyclone/cyclone-9999.ebuild b/dev-scheme/cyclone/cyclone-9999.ebuild
new file mode 100644
index 000000000000..12a81a63780a
--- /dev/null
+++ b/dev-scheme/cyclone/cyclone-9999.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Cyclone is a self-hosting Scheme to C compiler
+# cyclone-bootstrap is the Cyclone SOURCE transpiled by it to C
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="R7RS Scheme to C compiler"
+HOMEPAGE="http://justinethier.github.io/cyclone/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/justinethier/${PN}-bootstrap.git"
+else
+ SRC_URI="https://github.com/justinethier/${PN}-bootstrap/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-bootstrap-${PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="dev-libs/concurrencykit"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ export CYC_GCC_OPT_FLAGS="${CFLAGS}"
+ append-cflags -fPIC -Iinclude
+ append-ldflags -L.
+ tc-export AR CC RANLIB
+}
+
+src_compile() {
+ local myopts=(
+ PREFIX="/usr"
+ CYC_GCC_OPT_FLAGS="${CYC_GCC_OPT_FLAGS}"
+ AR="$(tc-getAR)"
+ CC="$(tc-getCC)"
+ RANLIB="$(tc-getRANLIB)"
+ )
+ emake "${myopts[@]}"
+}
+
+src_test() {
+ emake LDFLAGS="" test
+}
+
+src_install() {
+ einstalldocs
+
+ emake PREFIX="/usr" DESTDIR="${D}" install
+}
diff --git a/dev-scheme/cyclone/metadata.xml b/dev-scheme/cyclone/metadata.xml
new file mode 100644
index 000000000000..8e37f78fc1e8
--- /dev/null
+++ b/dev-scheme/cyclone/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>scheme@gentoo.org</email>
+ <name>Gentoo Scheme Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Cyclone Scheme is a brand-new compiler that allows real-world
+ application development using the R7RS Scheme Language standard.
+ We provide modern features and a stable system capable of generating
+ fast native binaries.
+ Cheney on the MTA is used by Cyclone's runtime to implement full tail
+ recursion, continuations, and generational garbage collection.
+ In addition, the Cheney on the MTA concept has been extended to allow
+ execution of multiple native threads. An on-the-fly garbage collector
+ is used to manage the second-generation heap and perform major
+ collections without "stopping the world".
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/justinethier/cyclone/issues</bugs-to>
+ <remote-id type="github">justinethier/cyclone-bootstrap</remote-id>
+ <remote-id type="github">justinethier/cyclone</remote-id>
+ </upstream>
+</pkgmetadata>