summaryrefslogtreecommitdiff
path: root/dev-ruby
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-02 14:53:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-02 14:53:28 +0000
commit4eaeaf683cb193978f14d55e52ea834d32e8a089 (patch)
treecd23a4d91c322f29e5c001bc033a008e309831a4 /dev-ruby
parente12724a13a1677867978f5ecd7fabda4eb1e3aa8 (diff)
gentoo auto-resync : 02:01:2024 - 14:53:28
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/Manifest.gzbin109042 -> 109040 bytes
-rw-r--r--dev-ruby/faraday-net_http_persistent/Manifest4
-rw-r--r--dev-ruby/faraday-net_http_persistent/faraday-net_http_persistent-1.2.0.ebuild38
-rw-r--r--dev-ruby/faraday-net_http_persistent/faraday-net_http_persistent-2.1.0.ebuild4
-rw-r--r--dev-ruby/faraday/Manifest2
-rw-r--r--dev-ruby/faraday/faraday-1.4.3.ebuild99
6 files changed, 144 insertions, 3 deletions
diff --git a/dev-ruby/Manifest.gz b/dev-ruby/Manifest.gz
index 87123d321ef0..79643b0e5bab 100644
--- a/dev-ruby/Manifest.gz
+++ b/dev-ruby/Manifest.gz
Binary files differ
diff --git a/dev-ruby/faraday-net_http_persistent/Manifest b/dev-ruby/faraday-net_http_persistent/Manifest
index 086d36a0ce17..0374abfc274e 100644
--- a/dev-ruby/faraday-net_http_persistent/Manifest
+++ b/dev-ruby/faraday-net_http_persistent/Manifest
@@ -1,3 +1,5 @@
+DIST faraday-net_http_persistent-1.2.0.tar.gz 6330 BLAKE2B ebd14e0035a86b2529e206704ae611ba82e35fc5296652dcb5b83b4aa9fac3b636a93baf45d7a47f3138550345920d15d87f0648b0107ed7264827b3a34d947f SHA512 4172b93aa72b5f9dcd9fa526789bc336b777fb6785753f0351410c58b8f3fe7e6f989c0812d71e1aa4f6449877cbed8908412321daefe95997483cf51158fa4c
DIST faraday-net_http_persistent-2.1.0.tar.gz 6953 BLAKE2B 5b1c43fbd647c36315c24aa0ff12817edef9940de7f42edb59815b41ec5a5b15c137be6d9e10a07192144064e5a32fa8ab0d9fa1ec15c3e3ec064424b5f299a9 SHA512 3ad70814a231dedff56dd2891d834c6cd5f377e30bac4b31e6290097667d18b4eac5b44ad46b14fda873ee80e3b49e018337d60d666f0b32017fe0f4653d905a
-EBUILD faraday-net_http_persistent-2.1.0.ebuild 868 BLAKE2B 6da09f5e96ef4dc9c498ec3660694f070e424dee6b23af587ca155a8d923d84f94962a67a4e3c336eb1d002763bb762ee9e6caf4a32424b1e5e2ba367fce13b4 SHA512 ddbd58afbca74172259700dc299b1b04c418578884b84b68eff14f8fb247506ada432e55ccbfb702cbf9156174ed6a194e16d774ba6c63623fb877fecb264b02
+EBUILD faraday-net_http_persistent-1.2.0.ebuild 895 BLAKE2B 135857e7030b9839e1abf622a292c0d5f03b6b6a3243aa27a35453918ba5f964975576ca1855895a7ccd1b39a3bb05915974cd9854fd15eeb28a1ec313811500 SHA512 c28243c32be75863da612089147482298ae2771b9140f9acf2ef22842c4c14184de7dcf0cc8bd09f55a7062ea9ed632cff0ba1116249f2d08e6296687d69fb44
+EBUILD faraday-net_http_persistent-2.1.0.ebuild 890 BLAKE2B 89f6a12eeaa7762f27c8fe6334c22e31f92b0098b3a7499fca344572c3d050091dfd8362525ac9ca3f4bf425cb0d0e7df76076e2cf5ae9af84255410e1d8e474 SHA512 d39e559bf74e1e31dde0d4e68e969019d84dc888ffa0a571f8c3cbd0dadf9d7894102360f7f10771a6d5a59c0494e82a97d3659d5cf6b10e1ca458f94bfcc22d
MISC metadata.xml 365 BLAKE2B 45ccbb64b2945de074d5e085e7eab2db13205ed3d4f84c40bb01c32ff11e8faffafb7e31e880614aec10986354e0dd55371c206dff7035bfcdefd2e3c3a95500 SHA512 a44ba95f925fa92241f1cc042e6890779d6c66d7a0fcc454c1f786333a601e3ce65e18979a9a79a60bf3b502e0402f10f282d94ebc1a3cfc6651719e6c4760b2
diff --git a/dev-ruby/faraday-net_http_persistent/faraday-net_http_persistent-1.2.0.ebuild b/dev-ruby/faraday-net_http_persistent/faraday-net_http_persistent-1.2.0.ebuild
new file mode 100644
index 000000000000..8c143ca9c3f6
--- /dev/null
+++ b/dev-ruby/faraday-net_http_persistent/faraday-net_http_persistent-1.2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Faraday adapter for NetHttpPersistent"
+HOMEPAGE="https://github.com/lostisland/faraday-net_http_persistent"
+SRC_URI="https://github.com/lostisland/faraday-net_http_persistent/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+ruby_add_depend "test? (
+ dev-ruby/faraday:1
+ >=dev-ruby/net-http-persistent-3.1
+ >=dev-ruby/webmock-3.4
+)"
+
+all_ruby_prepare() {
+ sed -i -e 's:_relative ":"./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ sed -e '/simplecov/I s:^:#:' \
+ -e '3igem "faraday", "~> 1.0"' \
+ -i spec/spec_helper.rb || die
+}
diff --git a/dev-ruby/faraday-net_http_persistent/faraday-net_http_persistent-2.1.0.ebuild b/dev-ruby/faraday-net_http_persistent/faraday-net_http_persistent-2.1.0.ebuild
index f72e2522a7e1..6ddf9dad74df 100644
--- a/dev-ruby/faraday-net_http_persistent/faraday-net_http_persistent-2.1.0.ebuild
+++ b/dev-ruby/faraday-net_http_persistent/faraday-net_http_persistent-2.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -20,7 +20,7 @@ SRC_URI="https://github.com/lostisland/faraday-net_http_persistent/archive/v${PV
LICENSE="MIT"
SLOT="$(ver_cut 1)"
-KEYWORDS="~amd64"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
IUSE=""
ruby_add_rdepend "
diff --git a/dev-ruby/faraday/Manifest b/dev-ruby/faraday/Manifest
index 542b0c99a377..5ab8b6e2abf4 100644
--- a/dev-ruby/faraday/Manifest
+++ b/dev-ruby/faraday/Manifest
@@ -1,4 +1,5 @@
DIST faraday-1.3.1.tar.gz 840638 BLAKE2B 284f7f612d3ab791a00ceab823be0246685fa38356bfeb6e01c12e81c7369c500719a6023dd929160ca598b41401b82cda0d8e9e363d0e7bdd91791742f8e68f SHA512 b89839e5d602911904ce009f52d011c124f84811e0676a3a524d22ea7084d99a971b6573dcde6d512bf933909cc461ef01cd82a8eeb9df581c56f17f31966b1b
+DIST faraday-1.4.3.tar.gz 838150 BLAKE2B 324788f73e450d386655e805163ffd6299c6d11453a7b034f55b549d3d4edcf3d2936b732e1e13fe4c38286f09b8c1aec7aa5ca42e2c2d6bd2f841a7b412e822 SHA512 7a7c370715c912434fcca5bae11543d24ef0990d24a8ab069f1bebdb534b8d1a9bc90c9625574e34f0ad9c4543391b24ce134a103ddc40b152ebd65d958c5517
DIST faraday-2.7.10.tar.gz 833034 BLAKE2B dca3ef6a48aa4d14f1717344c5ec85b1e9caf7205eb7ae1be76a7a96bdee9fbef2d112c05f96f5625262d2783fc0e5e196343f67b371e480532c5e74f77b73eb SHA512 e1d2792f49df5679c16d3690a2475c56db9ae537bf53db4bb7cc256b41455d3db36d8d672eaf3f8a63fb2b04349d45dd4d32a2c194606fd795de51b1f79ead85
DIST faraday-2.7.11.tar.gz 1029832 BLAKE2B fd5cc5a9fa0d8c40893600a89f71d906a9de0b800c9723d64e8dad5dac1bff4ec61ba2714347b38beeadafb42a29ed6fb217344ffdb122e137607ff140b6aed7 SHA512 eafbc0c88a94f03bfe659b10a86050d07e79c6c2fc81c16af9e2aad68bc5482748a4a41a0a7828b272a9e034cb77dab06e0a9a0e136a56c72b72ed97e5bad50c
DIST faraday-2.7.12.tar.gz 1029923 BLAKE2B 267880c4d35284c1eb2f894e9c2803662cf5a901417b5a8c6934b8cef3fe842924d945b64b6617dcd017cbfdc3c9be19271c7c295e2c39518215aba3ab8304bb SHA512 e35aaa7096a77a3dc76aa0a2c262d6e83d894564474dd5b1414488615e54096e96fefa245d65804afa71fc22ef55748c18a32213ba6eaedb431246d5f8d382a1
@@ -6,6 +7,7 @@ DIST faraday-2.7.6.tar.gz 832525 BLAKE2B 6d53bcabbdc6ce67433e475e7ac83d08a65a3ba
DIST faraday-2.8.0.tar.gz 1030670 BLAKE2B b0dc09bb4b760e1e194276709f6d2fdc391af0422f2eeba1f07e8824bb02346dcbd05dd701cb5bfbdebd32ae77bb75914955061b43e85f5e47843b11d40e3b2b SHA512 14aa19b24996140467e74abf35129d60781eefaf97fcc3eea7f83f9dd8db17318fbc57d263e1564f94cd9cd1a03129cef210b50190491e4e094092196c72aa67
DIST faraday-2.8.1.tar.gz 1030720 BLAKE2B c52733fa00143882d43bf7e48dc6fd79621aad9b096f01eb0cc05bb0808bffff0c01282d3823d3b105554d953dc003d86f85c7ef9505a733214a4569764b45a6 SHA512 b2af1dbfcefb92969ae45138401c8cc9a8a1b10ca2bd93dc6aad66337aefbad4cf5700949fb821b93bdba46ec5c7c61b83dcc934b5797a5516c53aab50a287cb
EBUILD faraday-1.3.1.ebuild 2439 BLAKE2B e41538c7de42c191107c94bca876198576c6fd1a7c43af9bdb23cb7e2cf7b71d799d92ad33f786736b65a4f5ba7c88bd66021c2f70254259998819aed1b3ba45 SHA512 8af16340781f5627079e7861ff4fa38d5cc55b42d3ef73e65f1e4698322632d4e55df60745d3cddea64b5659a0460816059bb834ae58f7b13ad48df715b73e8a
+EBUILD faraday-1.4.3.ebuild 3078 BLAKE2B bee32e7be9e3431314a03c2e2211d6ce1d442b4afb528b3a159d4620df7fdab645d78890ff167916dd1535833f0248eeec8fb821eb1363ece01ed021782655cd SHA512 38a954e0ce49b908d04f4a96dd5bb6799243edb008e2fa400d8adc93d67e25ae2b69d12e72d872720a32cc49180b7f7f883d7c4dc7c757251062f94a5f838bde
EBUILD faraday-2.7.10.ebuild 1526 BLAKE2B 6c6cea52e6dfdadb2071dcb32b3259d3d0fbecf2ac350b5730610b742662e74154b7c388fdf116c617f1068a6f29a1ae15adcb777f8a02a908d0452717a11e29 SHA512 7945a49dc179a42102f29d3be5e714a6bcbe18f0f94d943895aab2363a6abfc1e5b3a95465528082804d7522f8a0fb16156b45d9619167c8542be24bdfee5f6c
EBUILD faraday-2.7.11.ebuild 1537 BLAKE2B a1b0065e58330c1238a64351d97c46adefe7cd30b82da6569c0c6b2b0fe410cc75a8a201390a6307c76108de323669f7580104537f409d7caa9dd33e7d7a4941 SHA512 061b30ca8fe0741e0fafef99337a78a903300c4a3b7fb494d350e01379b203cab2b1da4ab372aeb1b56bb812e30945aec33176067f53b096f82030b458566c60
EBUILD faraday-2.7.12.ebuild 1537 BLAKE2B a1b0065e58330c1238a64351d97c46adefe7cd30b82da6569c0c6b2b0fe410cc75a8a201390a6307c76108de323669f7580104537f409d7caa9dd33e7d7a4941 SHA512 061b30ca8fe0741e0fafef99337a78a903300c4a3b7fb494d350e01379b203cab2b1da4ab372aeb1b56bb812e30945aec33176067f53b096f82030b458566c60
diff --git a/dev-ruby/faraday/faraday-1.4.3.ebuild b/dev-ruby/faraday/faraday-1.4.3.ebuild
new file mode 100644
index 000000000000..37c40778929b
--- /dev/null
+++ b/dev-ruby/faraday/faraday-1.4.3.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_RECIPE_DOC="none"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_EXTRAINSTALL="spec"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="HTTP/REST API client library with pluggable components"
+HOMEPAGE="https://github.com/lostisland/faraday"
+SRC_URI="https://github.com/lostisland/faraday/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+
+DEPEND+=" test? ( sys-process/lsof )"
+
+ruby_add_rdepend "
+ dev-ruby/faraday-net_http_persistent:1
+ dev-ruby/faraday-net_http:1
+ >=dev-ruby/multipart-post-1.2.0 <dev-ruby/multipart-post-3
+ dev-ruby/ruby2_keywords
+"
+ruby_add_bdepend "test? (
+ >=dev-ruby/test-unit-2.4
+ >=dev-ruby/connection_pool-2.2.2
+ >=dev-ruby/patron-0.4.2
+ dev-ruby/rack
+ >=dev-ruby/rack-test-0.6
+ dev-ruby/webmock
+ )"
+
+all_ruby_prepare() {
+ # Remove bundler support.
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/d ; 1irequire "yaml"' Rakefile || die
+ sed -i -e '/bundler/,/^fi/ s:^:#:' script/test || die
+ # Avoid loading all lib files since some of them require unpackaged dependencies.
+ sed -e '/[Cc]overall/ s:^:#:' \
+ -e '/lib\/\*\*/ s:^:#:' \
+ -e '/simplecov/ s:^:#:' \
+ -e '/SimpleCov/,/end/ s:^:#:' \
+ -e '/pry/ s:^:#:' \
+ -e '3igem "faraday-net_http", "~> 1.0"; gem "faraday-net_http_persistent", "~> 1.0"' \
+ -i spec/spec_helper.rb || die
+
+ sed -e '/git ls-files/ s:^:#:' \
+ -e "s:_relative ': './:" \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid multipart tests that require an unpackaged dependency
+ # that appears to be no longer maintained.
+ rm -f spec/faraday/request/multipart_spec.rb || die
+ sed -e '/multipart_parser/ s:^:#:' \
+ -i spec/support/helper_methods.rb || die
+
+ # Remove specs for unpackaged adapters
+ rm -f spec/faraday/adapter/{em_http,em_synchrony,excon,httpclient}_spec.rb || die
+
+ # Remove unpackaged adapters. These packages where part of earlier
+ # faraday versions but since we do not package their dependencies
+ # they never worked on a pure Gentoo install. We are taking this
+ # approach so we can add ruby32 compatibility to faraday:1 for
+ # those adapters that we do support.
+ sed -e '/require.*\(em_http\|em_synchrony\|excon\)/ s:^:#:' \
+ -i lib/faraday.rb ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Make this adapter optional since it comes with a long list of
+ # dependencies.
+ if ! has_version "dev-ruby/typhoeus:1" ; then
+ rm -f spec/faraday/adapter/typhoeus_spec.rb || die
+ fi
+
+ # Avoid a spec that gets tripped up by recent rack encoding changes.
+ sed -e '/encodes rack compat/ s/it/xit/' -i spec/faraday/params_encoders/nested_spec.rb || die
+}
+
+each_ruby_prepare() {
+ # Make sure the test scripts use the right ruby interpreter
+ sed -i -e 's:ruby:'${RUBY}':' script/* || die
+}
+
+each_ruby_test() {
+ MT_NO_PLUGINS=true each_fakegem_test
+
+ # Sleep some time to allow the sinatra test server to die
+ einfo "Waiting for test server to stop"
+ sleep 10
+}