summaryrefslogtreecommitdiff
path: root/dev-ruby
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-29 06:30:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-29 06:30:44 +0000
commit0e12f8e53cdddba84b0eb27dca59153e2cf52309 (patch)
tree8dec970370295a71970b82457ae1db36dbbbd07c /dev-ruby
parent72fd2b48b7154274a1d2009cdaab54e7f49fb3aa (diff)
gentoo auto-resync : 29:12:2024 - 06:30:44
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/Manifest.gzbin111244 -> 111727 bytes
-rw-r--r--dev-ruby/observer/Manifest3
-rw-r--r--dev-ruby/observer/metadata.xml12
-rw-r--r--dev-ruby/observer/observer-0.1.2.ebuild34
-rw-r--r--dev-ruby/repl_type_completor/Manifest3
-rw-r--r--dev-ruby/repl_type_completor/metadata.xml12
-rw-r--r--dev-ruby/repl_type_completor/repl_type_completor-0.1.9.ebuild35
-rw-r--r--dev-ruby/syslog/Manifest3
-rw-r--r--dev-ruby/syslog/metadata.xml12
-rw-r--r--dev-ruby/syslog/syslog-0.2.0.ebuild35
10 files changed, 149 insertions, 0 deletions
diff --git a/dev-ruby/Manifest.gz b/dev-ruby/Manifest.gz
index f1889efa5c56..dea111967d5b 100644
--- a/dev-ruby/Manifest.gz
+++ b/dev-ruby/Manifest.gz
Binary files differ
diff --git a/dev-ruby/observer/Manifest b/dev-ruby/observer/Manifest
new file mode 100644
index 000000000000..d7e4ef855adc
--- /dev/null
+++ b/dev-ruby/observer/Manifest
@@ -0,0 +1,3 @@
+DIST observer-0.1.2.tar.gz 6108 BLAKE2B 4ef4a17e3f30420bbfc8c01c83c433b331234cf0c905221759ac3a6f3d8e004657a3ed7e0c3509980effab71ed7213cac6531f34b142570c6877e55e9f5032c0 SHA512 05add384226459a637b5ec3081fc90da06a72ffa5c333e61844c6e0cc7dc0a17279008f54c2d3240123767cfde0e0e9e95e9364b77eee77c4310e0a0f675ed23
+EBUILD observer-0.1.2.ebuild 1008 BLAKE2B 54ef55f6c83ab65255128749e70069c28709ed3fe6e949bc41dff3ac2a7f74f8728730946db971f280db61f801d3221caf11d0db7b88498773814f1389438d43 SHA512 29ae5df4f441ad4c4f8f9f7df0c69e3ec1453a84f5a2c89a6a7841bdb7069c0a4a6faa999014876a2cd3034fdf9354873c97d62cca30a9e0e104057690bf23dc
+MISC metadata.xml 392 BLAKE2B f69bfabb68541e549f2a8445b24bd4102059d0e29b7909a34e75905abf2d30c28f7b2bf17232e9e625fe58e9bc26b3579f4fb8cebacc40275e3c579214712902 SHA512 a317fc80af042a068a6ffbeaf1fb94a47f1aa5bdf4eee2536d547eb8d873e5f7d1df3b48f9715d4b42febaabe09cecaa6c0c444654b7e3a234d1af5e1d29f896
diff --git a/dev-ruby/observer/metadata.xml b/dev-ruby/observer/metadata.xml
new file mode 100644
index 000000000000..ece1345eff9b
--- /dev/null
+++ b/dev-ruby/observer/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ruby/observer</remote-id>
+ <remote-id type="rubygems">observer</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/observer/observer-0.1.2.ebuild b/dev-ruby/observer/observer-0.1.2.ebuild
new file mode 100644
index 000000000000..8adea82ac0a3
--- /dev/null
+++ b/dev-ruby/observer/observer-0.1.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="observer.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implementation of the Observer object-oriented design pattern"
+HOMEPAGE="https://github.com/ruby/observer"
+SRC_URI="https://github.com/ruby/observer/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit )"
+
+all_ruby_prepare() {
+ sed -e 's/__dir__/"."/' \
+ -e 's/__FILE__/"'${RUBY_FAKEGEM_GEMSPEC}'"/' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test:test/lib -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
+}
diff --git a/dev-ruby/repl_type_completor/Manifest b/dev-ruby/repl_type_completor/Manifest
new file mode 100644
index 000000000000..0d003893f9cb
--- /dev/null
+++ b/dev-ruby/repl_type_completor/Manifest
@@ -0,0 +1,3 @@
+DIST repl_type_completor-0.1.9.tar.gz 32275 BLAKE2B aecec4bed189fd1907f7ac50d787b87cc2e9ee22f0042d2888cfbc565e55a231725ed26c2fb5a5776ea7a427ba07def468d3bc6d7ab45576dd7486b3a889bb51 SHA512 c3c88a4127fc37614c8e651b81cbc0636684f2feddd1032f2e4a060b7a6b341d758f64afcb14e8cbfe59306caeba528fb97343cba424d4612f23e095d5486a9e
+EBUILD repl_type_completor-0.1.9.ebuild 1007 BLAKE2B 48f60495910547a699e5212334daf4fe946d2a735c14ad490b542716d201d67c5823c40f7075126eb63f0c7afa9e4a21d67b0f5b139f3e0ced284c85c0cde270 SHA512 d4635fb9c6880f892ebd6f225cd347ee2f1c44432c01e20132647618b5ea22d9c5dde3b9b11189c9a31b0dcac8b90160b65498bafb5a70868f33a25864e7d046
+MISC metadata.xml 414 BLAKE2B 14a94a6435a95bcb0490b3308460e5b051fa6eb4e7ae73d76e7cfb9c86ca1ebde600ea02a234baf474642bdc081bd7ab3825b0ec29f3baee57221141e54f7b25 SHA512 8087e239f338ea579860f133cfb7bdbbef7e351b2b4152667209595c389094b23486bc9352794409c04512664b2c17161557ae9d93d57292e0d44d5cc8c4cefd
diff --git a/dev-ruby/repl_type_completor/metadata.xml b/dev-ruby/repl_type_completor/metadata.xml
new file mode 100644
index 000000000000..c17bfcf16e02
--- /dev/null
+++ b/dev-ruby/repl_type_completor/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ruby/repl_type_completor</remote-id>
+ <remote-id type="rubygems">repl_type_completor</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/repl_type_completor/repl_type_completor-0.1.9.ebuild b/dev-ruby/repl_type_completor/repl_type_completor-0.1.9.ebuild
new file mode 100644
index 000000000000..b83bcfb74d63
--- /dev/null
+++ b/dev-ruby/repl_type_completor/repl_type_completor-0.1.9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="repl_type_completor.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Type based completion for REPL"
+HOMEPAGE="https://github.com/ruby/repl_type_completor"
+SRC_URI="https://github.com/ruby/repl_type_completor/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+IUSE="test"
+
+ruby_add_rdepend "
+ dev-ruby/prism:1
+ <dev-ruby/rbs-4
+"
+
+ruby_add_bdepend "test? ( >=dev-ruby/irb-1.10.0 =dev-ruby/rake-13* dev-ruby/test-unit dev-ruby/test-unit-ruby-core )"
+
+all_ruby_prepare() {
+ sed -e 's/__dir__/"."/' \
+ -e 's:_relative ": "./:' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
diff --git a/dev-ruby/syslog/Manifest b/dev-ruby/syslog/Manifest
new file mode 100644
index 000000000000..2efbf7ae6fbe
--- /dev/null
+++ b/dev-ruby/syslog/Manifest
@@ -0,0 +1,3 @@
+DIST syslog-0.2.0.tar.gz 15018 BLAKE2B 19ed351cb7d1f4a1ddef5ce2bd84b5a63c975998020c12569b16c531dfd5959302a7adf62d9103c05c2fcb000c074d579e2aed13eafd485679669a66d48f2328 SHA512 949cc3cabe6cf78f127e8e06145e83c35dda848ad2409d7fc6a7171aca4cfff89df1e340978a8d80ca4bf8c3337aaa4731948d1a5fea1d165cf728cf0397aead
+EBUILD syslog-0.2.0.ebuild 1041 BLAKE2B 30aa8ff132a09f03a3dac64ec4558c957a63f54a3925777045ca80b3536b888bee05d38bcdd7fe8e57f76234972e67196063cf9864ffcf8f03aec08129bbc14f SHA512 30d79d80532c4a91846a99da5c4c78293cd066e40c1fdfd49c574f2ef184a969b70807acdf0ba64c3de5f767e6dfa56326e54f44b038be7e7aae2b496c8a8325
+MISC metadata.xml 388 BLAKE2B e00e73f34e5a0e5591f97c32cf7d81e4c86dc4f529f759e83b27783bf1681eadd54a23cac4ae2d1c61feb052e421d4dc9d9aedb1e9200f189c49afc8f739287d SHA512 428cb16a81800b9d984073ee82597bbf153b8f70bc0e260b12ae4a735376288a015177a8915e4a8feca22c9dfd3f48f2962488fdcb8c015bcb2c239ef7d0bddc
diff --git a/dev-ruby/syslog/metadata.xml b/dev-ruby/syslog/metadata.xml
new file mode 100644
index 000000000000..b27c3a42d6f2
--- /dev/null
+++ b/dev-ruby/syslog/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ruby/syslog</remote-id>
+ <remote-id type="rubygems">syslog</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/syslog/syslog-0.2.0.ebuild b/dev-ruby/syslog/syslog-0.2.0.ebuild
new file mode 100644
index 000000000000..574dfdc84624
--- /dev/null
+++ b/dev-ruby/syslog/syslog-0.2.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTENSIONS=(ext/syslog/extconf.rb)
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="syslog.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby interface for the POSIX system logging facility"
+HOMEPAGE="https://github.com/ruby/syslog"
+SRC_URI="https://github.com/ruby/syslog/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit )"
+
+all_ruby_prepare() {
+ sed -e 's/__dir__/"."/' \
+ -e 's/__FILE__/"'${RUBY_FAKEGEM_GEMSPEC}'"/' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test:test/lib -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
+}