summaryrefslogtreecommitdiff
path: root/dev-ruby/zentest/zentest-4.12.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-28 08:17:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-28 08:17:07 +0100
commit5a165c60b9b8c4847067cb83b4be7da785d01f93 (patch)
tree166b01591366d3479084ea774c888bc84aaa8d4f /dev-ruby/zentest/zentest-4.12.0.ebuild
parenta5b65c81168c90928784a1e92cda84ed5d6b9eb3 (diff)
gentoo resync : 28.09.2019
Diffstat (limited to 'dev-ruby/zentest/zentest-4.12.0.ebuild')
-rw-r--r--dev-ruby/zentest/zentest-4.12.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/zentest/zentest-4.12.0.ebuild b/dev-ruby/zentest/zentest-4.12.0.ebuild
new file mode 100644
index 000000000000..cee4f383b6c0
--- /dev/null
+++ b/dev-ruby/zentest/zentest-4.12.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_NAME=ZenTest
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt example.txt example1.rb example2.rb"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Testing tools: zentest, unit_diff, autotest, multiruby, and Test::Rails"
+HOMEPAGE="https://github.com/seattlerb/zentest"
+LICENSE="Ruby"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/minitest:5
+ )"
+
+each_ruby_test() {
+ ${RUBY} -Ilib:. -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
+}