summaryrefslogtreecommitdiff
path: root/dev-ruby/zeitwerk/zeitwerk-2.6.15.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-29 00:07:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-29 00:07:15 +0100
commit5c4786a868bad6e3f46aecf32ad6c6dc5de98408 (patch)
tree1a1792815761a5b6f645c8d55b6b698e102dca48 /dev-ruby/zeitwerk/zeitwerk-2.6.15.ebuild
parent3c1648a0749c1d66b300d857e6b417c1162890da (diff)
gentoo auto-resync : 29:05:2024 - 00:07:15
Diffstat (limited to 'dev-ruby/zeitwerk/zeitwerk-2.6.15.ebuild')
-rw-r--r--dev-ruby/zeitwerk/zeitwerk-2.6.15.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/zeitwerk/zeitwerk-2.6.15.ebuild b/dev-ruby/zeitwerk/zeitwerk-2.6.15.ebuild
new file mode 100644
index 000000000000..eb0be93eb354
--- /dev/null
+++ b/dev-ruby/zeitwerk/zeitwerk-2.6.15.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Efficient and thread-safe code loader for Ruby"
+HOMEPAGE="https://github.com/fxn/zeitwerk"
+SRC_URI="https://github.com/fxn/zeitwerk/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/bundler dev-ruby/warning )"
+
+all_ruby_prepare() {
+ rm -f Gemfile.lock || die
+ # Dropping proveit should be fine based on https://github.com/fxn/zeitwerk/pull/253
+ # It's more of a quality check for the tests themselves rather than a test
+ sed -i -e '/\(focus\|reporters\|Reporters\|prove_\?it\)/ s:^:#:' Gemfile test/test_helper.rb || die
+
+ sed -i -e 's:require_relative "lib:require "./lib:' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ ${RUBY} -S bundle exec rake test || die
+}