summaryrefslogtreecommitdiff
path: root/dev-ruby/zeitwerk/zeitwerk-2.6.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-26 11:27:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-26 11:27:54 +0100
commit25e2c97a4a6f12a367115508fc86d34fe76a6f5e (patch)
tree68acc191d796190f572dc374002717fec321e616 /dev-ruby/zeitwerk/zeitwerk-2.6.12.ebuild
parent1aa38370b2506ce90ad64cd4e18968d6612ebea5 (diff)
gentoo auto-resync : 26:09:2023 - 11:27:54
Diffstat (limited to 'dev-ruby/zeitwerk/zeitwerk-2.6.12.ebuild')
-rw-r--r--dev-ruby/zeitwerk/zeitwerk-2.6.12.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/zeitwerk/zeitwerk-2.6.12.ebuild b/dev-ruby/zeitwerk/zeitwerk-2.6.12.ebuild
new file mode 100644
index 000000000000..ceb5b959ebb4
--- /dev/null
+++ b/dev-ruby/zeitwerk/zeitwerk-2.6.12.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Efficient and thread-safe code loader for Ruby"
+HOMEPAGE="https://github.com/fxn/zeitwerk"
+SRC_URI="https://github.com/fxn/zeitwerk/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~riscv ~sparc ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/bundler dev-ruby/warning )"
+
+all_ruby_prepare() {
+ rm -f Gemfile.lock || die
+ # Dropping proveit should be fine based on https://github.com/fxn/zeitwerk/pull/253
+ # It's more of a quality check for the tests themselves rather than a test
+ sed -i -e '/\(focus\|reporters\|Reporters\|prove_\?it\)/ s:^:#:' Gemfile test/test_helper.rb || die
+
+ sed -i -e 's:require_relative "lib:require "./lib:' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ ${RUBY} -S bundle exec rake test || die
+}